aboutsummaryrefslogtreecommitdiff
path: root/games/plee-the-bear/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-18 23:30:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-18 23:30:48 +0000
commitb26f95bb8318c1a3c0a69ae0f0135d42b5013dfd (patch)
tree9fc14b5525ea303df23b19b0c216d4b78f846de9 /games/plee-the-bear/Makefile
parentdf3e0ace6af777817df6426cae08de4587fa20ca (diff)
downloadports-b26f95bb8318c1a3c0a69ae0f0135d42b5013dfd.tar.gz
ports-b26f95bb8318c1a3c0a69ae0f0135d42b5013dfd.zip
Plee The Bear will be a 2D platform jump and run game, as fun as
the best platform games of the 90's (the golden age of this kind of games). You're a bear, trying to catch his son, which ran away after he ate all your honey. WWW: http://plee-the-bear.sourceforge.net/ PR: ports/124624 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Notes
Notes: svn path=/head/; revision=215190
Diffstat (limited to 'games/plee-the-bear/Makefile')
-rw-r--r--games/plee-the-bear/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/games/plee-the-bear/Makefile b/games/plee-the-bear/Makefile
new file mode 100644
index 000000000000..33a67e67e55c
--- /dev/null
+++ b/games/plee-the-bear/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: plee-the-bear
+# Date created: 28 Mar 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plee-the-bear
+PORTVERSION= 0.2.1
+CATEGORIES= games
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-light
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= 2D platform jump and run game
+
+LIB_DEPENDS= boost_filesystem.4:${PORTSDIR}/devel/boost
+BUILD_DEPENDS= ${LOCALBASE}/bin/claw-config:${PORTSDIR}/devel/libclaw
+RUN_DEPENDS= ${LOCALBASE}/bin/claw-config:${PORTSDIR}/devel/libclaw
+
+USE_BZIP2= yes
+USE_SDL= sdl mixer
+USE_GL= gl glu
+WANT_GNOME= yes
+INSTALLS_ICONS= yes
+USE_LDCONFIG= yes
+
+USE_CMAKE= yes
+CMAKE_ARGS= -DCMAKE_MODULE_PATH="${LOCALBASE}/lib/claw/"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|"stats.dat"|get_custom_game_file(&).c_str()| ' \
+ ${WRKSRC}/dev/bear_engine/src/core/engine/code/game.cpp
+
+.include <bsd.port.mk>