aboutsummaryrefslogtreecommitdiff
path: root/games/py-pychess/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2008-07-09 12:28:54 +0000
committerNicola Vitale <nivit@FreeBSD.org>2008-07-09 12:28:54 +0000
commitd0287ad5882ea9cd5e4c1939748a09c60d06cff4 (patch)
treea76a73f84765c009de3454b82e68ec23adbe4d03 /games/py-pychess/Makefile
parent3aaf42683776e00435fdb2108e26a26fdda7a396 (diff)
downloadports-d0287ad5882ea9cd5e4c1939748a09c60d06cff4.tar.gz
ports-d0287ad5882ea9cd5e4c1939748a09c60d06cff4.zip
- Update to 0.8.2
- Fix installation when user sets NO_INSTALL_MANPAGES - Use ${MASTER_SITE_GOOGLE_CODE} as primary download site - Use versioned Python command in the bang line of the scripts
Notes
Notes: svn path=/head/; revision=216602
Diffstat (limited to 'games/py-pychess/Makefile')
-rw-r--r--games/py-pychess/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/games/py-pychess/Makefile b/games/py-pychess/Makefile
index 17707498d4bd..a7113fe19f6a 100644
--- a/games/py-pychess/Makefile
+++ b/games/py-pychess/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= pychess
-DISTVERSION= 0.8beta4
+PORTVERSION= 0.8.2
#PORTREVISION= 0
#PORTEPOCH= 0
-PORTREVISION= 1
CATEGORIES= games
-MASTER_SITES= http://nivi.interfree.it/distfiles/${PORTNAME}/
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
@@ -35,15 +35,17 @@ USE_GETTEXT= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-REINPLACE_ARGS= -i.bak -e 's,%%PREFIX%%,${PREFIX},' -e 's,share/games/pychess,${DATADIR},'
+REINPLACE_ARGS= -i.bak -e 's,%%PREFIX%%,${PREFIX},' -e 's,share/games/pychess,${DATADIR},' -e '1s,/usr/bin/env python,&${PYTHON_VER},'
.if !defined(NO_INSTALL_MANPAGES)
MAN1= ${PORTNAME}.1
MANCOMPRESSED= yes
+.else
+MAKE_ENV+= NO_INSTALL_MANPAGES=${NO_INSTALL_MANPAGES}
.endif
post-patch:
- cd ${WRKSRC} && ${REINPLACE_CMD} ${PORTNAME} ${PYSETUP}
+ cd ${WRKSRC} && ${REINPLACE_CMD} ${PORTNAME} ${PYSETUP} lib/pychess/Utils/Move.py
.include <bsd.port.pre.mk>