aboutsummaryrefslogtreecommitdiff
path: root/games/pyfa/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2015-12-22 15:17:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2015-12-22 15:17:46 +0000
commit19f5069bf879c7c63038bfb8c4ae3c639980448f (patch)
tree2687599a74f5f188145791e162a6a9900af9d32d /games/pyfa/Makefile
parent3214000276433e4bcd200ee261421d3ca43e590f (diff)
downloadports-19f5069bf879c7c63038bfb8c4ae3c639980448f.tar.gz
ports-19f5069bf879c7c63038bfb8c4ae3c639980448f.zip
- Update to 1.17.1
PR: 205295 Submitted by: Andrey Fesenko Approved by: mat (mentor) Differential Revision: D4571
Notes
Notes: svn path=/head/; revision=404240
Diffstat (limited to 'games/pyfa/Makefile')
-rw-r--r--games/pyfa/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/games/pyfa/Makefile b/games/pyfa/Makefile
index e0e896a8a9f2..65a9556ffd04 100644
--- a/games/pyfa/Makefile
+++ b/games/pyfa/Makefile
@@ -2,33 +2,33 @@
# $FreeBSD$
PORTNAME= pyfa
-PORTVERSION= 1.13.1
+PORTVERSION= 1.17.1
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= games python
MAINTAINER= andrey@bsdnir.info
COMMENT= Fitting tool for EVE Online
LICENSE= GPLv3 # or later
-LICENSE_FILE= ${WRKSRC}/gpl.txt
+LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil \
- ${PYTHON_PKGNAMEPREFIX}sqlalchemy>0:${PORTSDIR}/databases/py-sqlalchemy
+ ${PYTHON_PKGNAMEPREFIX}sqlalchemy>=0.6:${PORTSDIR}/databases/py-sqlalchemy \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.3.0:${PORTSDIR}/www/py-requests
USE_GITHUB= yes
GH_ACCOUNT= DarkFenX
USES= python:2 dos2unix
DOS2UNIX_GLOB= *.py
+NO_ARCH= yes
WRKSRC= ${WRKDIR}/Pyfa-${PORTVERSION}
PLIST_FILES= bin/pyfa
PORTDATA= *
-USE_WX= 2.8
-WX_COMPS= python:run
-WX_UNICODE= yes
+USE_WX= 2.8 3.0
+WX_COMPS= wx:run python:run
OPTIONS_DEFINE= DPSGRAPHING
DPSGRAPHING_DESC= DPS graphing (requires NumPy and matplotlib. need fix)