aboutsummaryrefslogtreecommitdiff
path: root/games/pykawari
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2004-02-03 16:16:14 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2004-02-03 16:16:14 +0000
commit07ba1772bc2c8bbe8c9071a152dfb26ad14b1aaa (patch)
treebdc45cbd691f830cc8c7c5b25a08b3e8ec36c600 /games/pykawari
parenta37446b1dc89c7075086bea600423ec661510369 (diff)
downloadports-07ba1772bc2c8bbe8c9071a152dfb26ad14b1aaa.tar.gz
ports-07ba1772bc2c8bbe8c9071a152dfb26ad14b1aaa.zip
Add pykawari 8.1.0, pykawari is a real kawari8 module for ninix-aya.
PR: ports/61787 Submitted by: UMENO Takashi <umeno@rr.iij4u.or.jp>
Notes
Notes: svn path=/head/; revision=99884
Diffstat (limited to 'games/pykawari')
-rw-r--r--games/pykawari/Makefile49
-rw-r--r--games/pykawari/distinfo2
-rw-r--r--games/pykawari/files/patch-build::src::gcc.mak28
-rw-r--r--games/pykawari/pkg-descr5
-rw-r--r--games/pykawari/pkg-plist41
5 files changed, 125 insertions, 0 deletions
diff --git a/games/pykawari/Makefile b/games/pykawari/Makefile
new file mode 100644
index 000000000000..11db1ac43794
--- /dev/null
+++ b/games/pykawari/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: pykawari
+# Date created: 23 Jan 2004
+# Whom: UMENO Takashi
+#
+# $FreeBSD$
+#
+
+PORTNAME= pykawari
+PORTVERSION= 8.1.0
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= kawari
+DISTNAME= kawari-${PORTVERSION:S/.//g}
+EXTRACT_SUFX= .lzh
+
+PATCH_SITES= http://rinakusu.at.infoseek.co.jp/
+PATCHFILES= kawari-810-py-module.patch
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= umeno@rr.iij4u.or.jp
+COMMENT= Pykawari is a real kawari8 module for ninix-aya
+
+BUILD_DEPENDS= lha:${PORTSDIR}/archivers/lha
+RUN_DEPENDS= ninix:${PORTSDIR}/games/ninix-aya
+
+EXTRACT_CMD= lha
+EXTRACT_BEFORE_ARGS= xfqw=${WRKDIR}
+EXTRACT_AFTER_ARGS= # empty
+
+PLIST_SUB= LOCALBASE=${LOCALBASE}
+
+USE_PYTHON= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+WRKSRC= ${WRKDIR}/kawari-${PORTVERSION:S/.//g}
+CFLAGS+= ${PTHREAD_CFLAGS}
+
+do-build:
+ (cd ${WRKSRC}/build/src; ${GMAKE} -f gcc.mak PYTHONBASE=${PYTHONBASE} PYTHON_VERSION=${PYTHON_VERSION})
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/kawari
+ ${TAR} -cf - document license.txt readme.1st build/build.txt -C ${WRKSRC} | ${TAR} -xvpf - -C ${PREFIX}/share/kawari
+ ${LN} ${WRKSRC}/build/mach/freebsd/libshiori.so ${WRKSRC}/build/mach/freebsd/_kawari8.so
+ ${MKDIR} ${PREFIX}/libexec/ninix
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/mach/freebsd/_kawari8.so ${PREFIX}/libexec/ninix
+
+.include <bsd.port.mk>
diff --git a/games/pykawari/distinfo b/games/pykawari/distinfo
new file mode 100644
index 000000000000..e498c1478dee
--- /dev/null
+++ b/games/pykawari/distinfo
@@ -0,0 +1,2 @@
+MD5 (kawari-810.lzh) = 20021f6164f306a2ff9063f3f357cf20
+MD5 (kawari-810-py-module.patch) = 1074f8c088f7a7b6c0ac20e5af08aa92
diff --git a/games/pykawari/files/patch-build::src::gcc.mak b/games/pykawari/files/patch-build::src::gcc.mak
new file mode 100644
index 000000000000..ebb09ce7c7f3
--- /dev/null
+++ b/games/pykawari/files/patch-build::src::gcc.mak
@@ -0,0 +1,28 @@
+--- build/src/gcc.mak.orig Thu Jan 22 07:47:30 2004
++++ build/src/gcc.mak Thu Jan 22 07:49:18 2004
+@@ -6,7 +6,7 @@
+ # ターゲットによって書き換え
+
+ ## mach type: cygwin, mingw, linux, freebsd, darwin
+-MACH_TYPE = linux
++MACH_TYPE = freebsd
+
+ ## target name
+ SHIORI = shiori
+@@ -42,6 +42,7 @@
+ ## (Python) and if win32
+ # PYTHON_CFLAGS = -I/python22jp/include
+ # PYTHON_LIBS = -L/python22jp/libs
++PYTHON_LIBS = -L${PYTHONBASE}/lib/${PYTHON_VERSION}/config -l${PYTHON_VERSION}
+
+ #==========================================================================
+ # 以下、基本的に書き換え不要
+@@ -146,7 +147,7 @@
+ $(CXX) -o $@ -bundle $(SHIOOBJ) $(LIBOBJ) $(LDFLAGS)
+
+ $(MACH)/kosui$(EXEEXT) : $(KOSUIOBJ) $(LIBOBJ)
+- $(CXX) -o $@ $(KOSUIOBJ) $(LIBOBJ) $(LDFLAGS)
++ $(CXX) -o $@ $(KOSUIOBJ) $(LIBOBJ) $(LDFLAGS) ${PTHREAD_LIBS} -lutil
+ $(STRIP) $@
+
+ $(MACH)/kawari_encode$(EXEEXT) : tool/kawari_encode$(OBJEXT) $(CRYPTOBJ)
diff --git a/games/pykawari/pkg-descr b/games/pykawari/pkg-descr
new file mode 100644
index 000000000000..9f5631be5495
--- /dev/null
+++ b/games/pykawari/pkg-descr
@@ -0,0 +1,5 @@
+Pykawari is a real kawari8 module for ninix-aya.
+
+For more information, see
+WWW: http://kawari.sourceforge.net/
+WWW: http://rinakusu.at.infoseek.co.jp/
diff --git a/games/pykawari/pkg-plist b/games/pykawari/pkg-plist
new file mode 100644
index 000000000000..478aedd98cbe
--- /dev/null
+++ b/games/pykawari/pkg-plist
@@ -0,0 +1,41 @@
+libexec/ninix/_kawari8.so
+share/kawari/license.txt
+share/kawari/readme.1st
+share/kawari/document/banners/kawalinks.png
+share/kawari/document/banners/kawari.png
+share/kawari/document/banners/kawaribts.png
+share/kawari/document/banners/kawariplus.png
+share/kawari/document/banners/kawarisf.png
+share/kawari/document/banners/kawari_bbs.png
+share/kawari/document/banners/kawari_logo.png
+share/kawari/document/banners/kpcg_banner.png
+share/kawari/document/images/logo.png
+share/kawari/document/images/logo2.png
+share/kawari/document/images/ver_731.png
+share/kawari/document/images/ver_790.png
+share/kawari/document/images/ver_800.png
+share/kawari/document/images/ver_810.png
+share/kawari/document/index.html
+share/kawari/document/kawari.css
+share/kawari/document/kis_reference.html
+share/kawari/document/kiu_specbnf.txt
+share/kawari/document/kosui.html
+share/kawari/document/license.html
+share/kawari/document/programming.html
+share/kawari/document/programming_1.html
+share/kawari/document/programming_2.html
+share/kawari/document/programming_3.html
+share/kawari/document/programming_4.html
+share/kawari/document/programming_5.html
+share/kawari/document/start.html
+share/kawari/document/story.html
+share/kawari/document/tips.html
+share/kawari/document/users.html
+share/kawari/document/convert.html
+share/kawari/document/errormes.html
+share/kawari/build/build.txt
+@dirrm share/kawari/document/banners
+@dirrm share/kawari/document/images
+@dirrm share/kawari/document
+@dirrm share/kawari/build
+@dirrm share/kawari