aboutsummaryrefslogtreecommitdiff
path: root/games/qnetwalk
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-11-12 12:02:57 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-11-12 12:02:57 +0000
commit20222b5ca7cf16f9efbd3164f6cced5ce39bbc43 (patch)
tree639677c27f378d61ee7413603f33c770fdeb21aa /games/qnetwalk
parent056e356ac98faf6dab80ac18c05278acee4f8e33 (diff)
downloadports-20222b5ca7cf16f9efbd3164f6cced5ce39bbc43.tar.gz
ports-20222b5ca7cf16f9efbd3164f6cced5ce39bbc43.zip
Add qnetwalk, QT version of the netwalk game
Notes
Notes: svn path=/head/; revision=121445
Diffstat (limited to 'games/qnetwalk')
-rw-r--r--games/qnetwalk/Makefile34
-rw-r--r--games/qnetwalk/distinfo2
-rw-r--r--games/qnetwalk/pkg-descr12
-rw-r--r--games/qnetwalk/pkg-plist9
4 files changed, 57 insertions, 0 deletions
diff --git a/games/qnetwalk/Makefile b/games/qnetwalk/Makefile
new file mode 100644
index 000000000000..ae6236d28dec
--- /dev/null
+++ b/games/qnetwalk/Makefile
@@ -0,0 +1,34 @@
+# New ports collection Makefile for: qnetwalk
+# Date created: 2004-11-12
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= qnetwalk
+PORTVERSION= 1.0
+CATEGORIES= games
+MASTER_SITES= http://qt.osdn.org.ua/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Qt-version of the NetWalk game
+
+USE_QT_VER= 3
+QMAKESPEC?= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+QMAKE?= qmake
+USE_REINPLACE= yes
+
+do-configure:
+ ${REINPLACE_CMD} -e "s,/usr/local/share/games/qnetwalk,${DATADIR}," ${WRKSRC}/qnetwalk.pro
+ ${REINPLACE_CMD} -e "s,share/games/,share/," ${WRKSRC}/main.cpp ${WRKSRC}/mainwindow.cpp
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
+ -spec ${QMAKESPEC} ${PORTNAME}.pro
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/qnetwalk ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}/sounds
+ cd ${WRKSRC}; ${INSTALL_DATA} qnetwalk_ru.qm ${DATADIR}
+ cd ${WRKSRC}; ${INSTALL_DATA} sounds/click.wav \
+ sounds/connect.wav sounds/start.wav sounds/turn.wav \
+ sounds/win.wav ${DATADIR}/sounds
+
+.include <bsd.port.mk>
diff --git a/games/qnetwalk/distinfo b/games/qnetwalk/distinfo
new file mode 100644
index 000000000000..d38a1d9fe719
--- /dev/null
+++ b/games/qnetwalk/distinfo
@@ -0,0 +1,2 @@
+MD5 (qnetwalk-1.0.tar.gz) = 49e7c5288cbec1eb01281159b4a6fe98
+SIZE (qnetwalk-1.0.tar.gz) = 124445
diff --git a/games/qnetwalk/pkg-descr b/games/qnetwalk/pkg-descr
new file mode 100644
index 000000000000..92e611dc1805
--- /dev/null
+++ b/games/qnetwalk/pkg-descr
@@ -0,0 +1,12 @@
+QNetWalk, the Qt-version of the popular NetWalk game for system administrators.
+
+Features:
+* Built-in generator of the levels.
+* Novice, Amateur, Expert, and Master levels of the skill.
+* Auto saving of settings.
+* Turn's animation.
+* Highscores.
+* Sound Support.
+
+WWW: http://qt.osdn.org.ua/qnetwalk.html
+Author: Andi Peredri
diff --git a/games/qnetwalk/pkg-plist b/games/qnetwalk/pkg-plist
new file mode 100644
index 000000000000..c37838005fdc
--- /dev/null
+++ b/games/qnetwalk/pkg-plist
@@ -0,0 +1,9 @@
+bin/qnetwalk
+%%DATADIR%%/qnetwalk_ru.qm
+%%DATADIR%%/sounds/click.wav
+%%DATADIR%%/sounds/connect.wav
+%%DATADIR%%/sounds/start.wav
+%%DATADIR%%/sounds/turn.wav
+%%DATADIR%%/sounds/win.wav
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%