aboutsummaryrefslogtreecommitdiff
path: root/games/quake2-source/files/Makefile.game
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-10-16 05:58:42 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-10-16 05:58:42 +0000
commit7e4cbdf713e92dcd3bbbb81798f53bfa8e900201 (patch)
tree34a6271409eb26f5cad65b008da7d80afbb93cb7 /games/quake2-source/files/Makefile.game
parent385b4cf1e7879edd02668eff425bab0004024841 (diff)
downloadports-7e4cbdf713e92dcd3bbbb81798f53bfa8e900201.tar.gz
ports-7e4cbdf713e92dcd3bbbb81798f53bfa8e900201.zip
[NEW PORT] games/quake2-source - Quake II game source
Quake II game source. This port installs the Quake II game source, together with BSD Makefiles, for building modifications. It can also install the Capture the Flag mod, Rogue and Xatrix game source. PR: ports/86737 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Notes
Notes: svn path=/head/; revision=145520
Diffstat (limited to 'games/quake2-source/files/Makefile.game')
-rw-r--r--games/quake2-source/files/Makefile.game54
1 files changed, 54 insertions, 0 deletions
diff --git a/games/quake2-source/files/Makefile.game b/games/quake2-source/files/Makefile.game
new file mode 100644
index 000000000000..0e31cad102ba
--- /dev/null
+++ b/games/quake2-source/files/Makefile.game
@@ -0,0 +1,54 @@
+# BSD Makefile for Quake II game source
+
+SHLIB_NAME= game.so
+
+SRCS= g_ai.c \
+ g_chase.c \
+ g_cmds.c \
+ g_combat.c \
+ g_func.c \
+ g_items.c \
+ g_main.c \
+ g_misc.c \
+ g_monster.c \
+ g_phys.c \
+ g_save.c \
+ g_spawn.c \
+ g_svcmds.c \
+ g_target.c \
+ g_trigger.c \
+ g_turret.c \
+ g_utils.c \
+ g_weapon.c \
+ m_actor.c \
+ m_berserk.c \
+ m_boss2.c \
+ m_boss3.c \
+ m_boss31.c \
+ m_boss32.c \
+ m_brain.c \
+ m_chick.c \
+ m_flash.c \
+ m_flipper.c \
+ m_float.c \
+ m_flyer.c \
+ m_gladiator.c \
+ m_gunner.c \
+ m_hover.c \
+ m_infantry.c \
+ m_insane.c \
+ m_medic.c \
+ m_move.c \
+ m_mutant.c \
+ m_parasite.c \
+ m_soldier.c \
+ m_supertank.c \
+ m_tank.c \
+ p_client.c \
+ p_hud.c \
+ p_trail.c \
+ p_view.c \
+ p_weapon.c \
+ q_shared.c
+
+.include <bsd.lib.mk>