aboutsummaryrefslogtreecommitdiff
path: root/games/quake2lnx
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-11-18 10:02:24 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-11-18 10:02:24 +0000
commit4ebe1fe922ed7773ff021643fca7ca71478852be (patch)
tree5d80a31cfec422bee2541eeeb569cfd943913769 /games/quake2lnx
parent4d4ecb55f113a1cf4859ac1d4598c26f26c34f5a (diff)
downloadports-4ebe1fe922ed7773ff021643fca7ca71478852be.tar.gz
ports-4ebe1fe922ed7773ff021643fca7ca71478852be.zip
Start curing the damage done in previous massive commit:
- Reindent OPTIONS for easy reading - Add SHA256 hashes while here
Notes
Notes: svn path=/head/; revision=148712
Diffstat (limited to 'games/quake2lnx')
-rw-r--r--games/quake2lnx/Makefile48
-rw-r--r--games/quake2lnx/distinfo13
2 files changed, 36 insertions, 25 deletions
diff --git a/games/quake2lnx/Makefile b/games/quake2lnx/Makefile
index 853a4f624bd0..97a1b3ba3d62 100644
--- a/games/quake2lnx/Makefile
+++ b/games/quake2lnx/Makefile
@@ -23,27 +23,27 @@ COMMENT= Cleaned up copy of the original Quake II source code
USE_GMAKE= yes
WANT_SDL= yes
-OPTIONS= AA "Build ASCII software renderer" off \
- ARTS "Enable support for aRts sound daemon" off \
- CLIENT "Build client executable" on \
- CTF "Build Capture The Flag mod" off \
- EYECANDY "Build executable with fancier GL graphics" off \
- GAME "Build a main game .so file" on \
- GLX "Build GLX driver" on \
- IPV6 "Enable experimental IPv6 support" off \
- JOYSTICK "Enable joystick support" off \
+OPTIONS= AA "Build ASCII software renderer" off \
+ ARTS "Enable support for aRts sound daemon" off \
+ CLIENT "Build client executable" on \
+ CTF "Build Capture The Flag mod" off \
+ EYECANDY "Build executable with fancier GL graphics" off \
+ GAME "Build a main game .so file" on \
+ GLX "Build GLX driver" on \
+ IPV6 "Enable experimental IPv6 support" off \
+ JOYSTICK "Enable joystick support" off \
OPTIMIZED_CFLAGS "Enable extra optimization options" off \
- REDBLUE "Enable 3D glasses rendering" off \
- RETEXTURE "Enable support of retextured graphics" off \
- ROGUE "Build Ground Zero (Rogue) mission pack" off \
- SDL "Build SDL software driver" off \
- SDLCLIENT "Build executable that uses SDL" off \
- SDLGL "Build SDL OpenGL driver" off \
- SERVER "Build dedicated server executable" on \
- SVGA "Build SVGA driver" off \
- XATRIX "Build The Reckoning (Xatrix) mission pack" off \
- X11 "Build X11 software driver" on \
- X86_ASM "Enable use of x86 assembly code" on
+ REDBLUE "Enable 3D glasses rendering" off \
+ RETEXTURE "Enable support of retextured graphics" off \
+ ROGUE "Build Ground Zero (Rogue) mission pack" off \
+ SDL "Build SDL software driver" off \
+ SDLCLIENT "Build executable that uses SDL" off \
+ SDLGL "Build SDL OpenGL driver" off \
+ SERVER "Build dedicated server executable" on \
+ SVGA "Build SVGA driver" off \
+ XATRIX "Build The Reckoning (Xatrix) mission pack" off \
+ X11 "Build X11 software driver" on \
+ X86_ASM "Enable use of x86 assembly code" on
ALL_TARGET= build_release
MAKE_ENV= DATADIR="${DATADIR}" LIBDIR="${LIBDIR}"
@@ -228,19 +228,19 @@ do-install:
.for tgt in ${EXE_TARGETS}
${INSTALL_PROGRAM} ${TGTDIR}/${tgt} ${PREFIX}/bin
.endfor
- ${MKDIR} ${LIBDIR}
+ @${MKDIR} ${LIBDIR}
.for tgt in ${REF_TARGETS}
${INSTALL_PROGRAM} ${TGTDIR}/ref_${tgt}.so ${LIBDIR}
.endfor
.if defined(WITH_CTF)
- ${MKDIR} ${LIBDIR}/ctf
+ @${MKDIR} ${LIBDIR}/ctf
${INSTALL_PROGRAM} ${TGTDIR}/ctf/game.so ${LIBDIR}/ctf
.endif
.if defined(WITH_EYECANDY)
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/maxpak.pak ${DATADIR}/baseq2
.endif
.if defined(WITH_GAME)
- ${MKDIR} ${LIBDIR}/baseq2
+ @${MKDIR} ${LIBDIR}/baseq2
${INSTALL_PROGRAM} ${TGTDIR}/game.so ${LIBDIR}/baseq2
.endif
.if defined(WITH_RETEXTURE)
@@ -249,7 +249,7 @@ do-install:
. endfor
.endif
.for mp in ${Q2MP}
- ${MKDIR} ${LIBDIR}/${mp}
+ @${MKDIR} ${LIBDIR}/${mp}
${INSTALL_PROGRAM} ${TGTDIR}/${mp}/game.so ${LIBDIR}/${mp}
.endfor
.if !defined(NOPORTDOCS)
diff --git a/games/quake2lnx/distinfo b/games/quake2lnx/distinfo
index 71e3dffeeee5..08c85b125211 100644
--- a/games/quake2lnx/distinfo
+++ b/games/quake2lnx/distinfo
@@ -1,25 +1,36 @@
MD5 (quake2lnx/quake2-r0.16.2.tar.gz) = 872fee27fb13a2a4c8876d5973c3c691
-SIZE (quake2lnx/quake2-r0.16.2.tar.gz) = 1496377
SHA256 (quake2lnx/quake2-r0.16.2.tar.gz) = 98cea3cbd70bd1f195e5190d0ae047c636e00e21dbc6cc5bdee4acd52876d3e9
+SIZE (quake2lnx/quake2-r0.16.2.tar.gz) = 1496377
MD5 (quake2lnx/maxpak.pak) = 04d3f1fb7fb4dada7175a41f4595c7eb
+SHA256 (quake2lnx/maxpak.pak) = 653569fe880f1ed5f7529483ac961b22078482e6ff0e83f4d9d1bc503c866770
SIZE (quake2lnx/maxpak.pak) = 3282742
MD5 (quake2lnx/pak10.pak) = fc2de3c33c23cca5f0e6fcec068ce616
+SHA256 (quake2lnx/pak10.pak) = 196dc096c1f4fd620c19a09593e5b770ddbeed7d864ca3a95383f7bf9538fbc3
SIZE (quake2lnx/pak10.pak) = 16315845
MD5 (quake2lnx/pak11.pak) = 221019679613a13c6d7e5f9e21701d85
+SHA256 (quake2lnx/pak11.pak) = dcddd989b568cb28aa6c2a877d81df50a71fd9a649ce6dd44f454efe13e26a73
SIZE (quake2lnx/pak11.pak) = 1702702
MD5 (quake2lnx/pak12.pak) = 0c8b49c303014e535394168aed9b668a
+SHA256 (quake2lnx/pak12.pak) = 170af42c090940c89f1bf16e8518733bc39dac070e0d42e4eacad727b37de256
SIZE (quake2lnx/pak12.pak) = 3629554
MD5 (quake2lnx/pak13.pak) = 9628c82566535e48c59caaee5281b963
+SHA256 (quake2lnx/pak13.pak) = 085b22e5a9f23299e6f0519e402711725cdac51fc399ce577d0d701df0a72681
SIZE (quake2lnx/pak13.pak) = 2198193
MD5 (quake2lnx/pak14.pak) = 5d47605de09c458c7f1c69d8e6fea6a7
+SHA256 (quake2lnx/pak14.pak) = 78d3b02d20f856b3a0680035b0d67a80a16bede372eef3330b58c755387ff1ff
SIZE (quake2lnx/pak14.pak) = 2397651
MD5 (quake2lnx/pak16.pak) = 94b18e1f2d76fb7e7d0c5bd0ae8d7c69
+SHA256 (quake2lnx/pak16.pak) = eb21fbc6d0bcd69fb1d3768bcb7f0bbff03e28c18c67f239497d15749913ded3
SIZE (quake2lnx/pak16.pak) = 2675893
MD5 (quake2lnx/pak17.pak) = e24d79286ba3c1f3da1f9642a78c49af
+SHA256 (quake2lnx/pak17.pak) = e9585c18ec1f53b95dad833f76ac2df54586d3171e0f3a93ba7c2acce8d915be
SIZE (quake2lnx/pak17.pak) = 1431798
MD5 (quake2lnx/pak19.pak) = 070a4d00b93a2a427ca92adee2736000
+SHA256 (quake2lnx/pak19.pak) = ee7d5aaee977a8dd198c61a2bcca446b2ab421ee6eaa3a18159671dd742a9540
SIZE (quake2lnx/pak19.pak) = 648896
MD5 (quake2lnx/roguesrc320.shar.Z) = 7d5e052839c9e629bad0a6570aa70554
+SHA256 (quake2lnx/roguesrc320.shar.Z) = ceefb2fd748961cb0bc3244220f3eb09d8f7b8ca2eb32cdf9b284727a2fdc919
SIZE (quake2lnx/roguesrc320.shar.Z) = 626769
MD5 (quake2lnx/xatrixsrc320.shar.Z) = 41fc4ecc4f25c068e7d1f488bd4a1e1a
+SHA256 (quake2lnx/xatrixsrc320.shar.Z) = 94bf596cd85d38ea294b99ccb0ebb5e4b9776cca335001b3803e2d8407395589
SIZE (quake2lnx/xatrixsrc320.shar.Z) = 455917