aboutsummaryrefslogtreecommitdiff
path: root/games/randomshooter
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-14 20:36:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-14 20:36:50 +0000
commitf45a686f54cf804e7419736e66564640b4f4057a (patch)
treeff26fb84feca3e03e7b08c760ce1fbd6aaa55fcf /games/randomshooter
parenta5d574339aa4834f2c3d51c2ab5f9f54dc67911b (diff)
downloadports-f45a686f54cf804e7419736e66564640b4f4057a.tar.gz
ports-f45a686f54cf804e7419736e66564640b4f4057a.zip
This is the first release of a shoot em up game written in SDL. The
objective is simple: you have 1 life and 1 hit will kill you. Try and destroy as many enemies as possible before this happens. The game features an online scoring system and the ability to replay game sessions. WWW: http://www.parallelrealities.co.uk/randomShooter.php PR: ports/121203 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Notes
Notes: svn path=/head/; revision=209070
Diffstat (limited to 'games/randomshooter')
-rw-r--r--games/randomshooter/Makefile40
-rw-r--r--games/randomshooter/distinfo3
-rw-r--r--games/randomshooter/files/patch-makefile33
-rw-r--r--games/randomshooter/files/patch-src-input.c11
-rw-r--r--games/randomshooter/pkg-descr8
-rw-r--r--games/randomshooter/pkg-plist55
6 files changed, 150 insertions, 0 deletions
diff --git a/games/randomshooter/Makefile b/games/randomshooter/Makefile
new file mode 100644
index 000000000000..06648cad11eb
--- /dev/null
+++ b/games/randomshooter/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: randomshooter
+# Date created: 27 Feb 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= randomshooter
+DISTVERSION= 0.1-1
+CATEGORIES= games
+# original url: http://parallelrealities.co.uk/download.php?proj=randomShooter&file=${DISTNAME}&type=zip
+MASTER_SITES= http://www.amdmi3.ru/distfiles/
+DISTNAME= RandomShooter-${DISTVERSION}
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= A simple shoot'em up with online scoring and replays
+
+USE_GMAKE= yes
+USE_SDL= sdl mixer image ttf net
+
+WRKSRC= ${WRKDIR}/RandomShooter
+PORTDOCS= *
+
+MAKEFILE= makefile
+MAKE_ENV= CXX="${CXX}"
+CXXFLAGS+= -DINSTALL_DIR=\\\"${DATADIR}/\\\"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.for dir in font gfx music
+ ${MKDIR} ${DATADIR}/${dir}
+ ${INSTALL_DATA} ${WRKSRC}/${dir}/* ${DATADIR}/${dir}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/help/help.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/randomshooter/distinfo b/games/randomshooter/distinfo
new file mode 100644
index 000000000000..8188798e950d
--- /dev/null
+++ b/games/randomshooter/distinfo
@@ -0,0 +1,3 @@
+MD5 (RandomShooter-0.1-1.tar.gz) = 710d334ebaaea7336bb08cfdf61f5839
+SHA256 (RandomShooter-0.1-1.tar.gz) = 7dea906bf6573784953075a81f795451f9dcc158a834c555651698094103a759
+SIZE (RandomShooter-0.1-1.tar.gz) = 362257
diff --git a/games/randomshooter/files/patch-makefile b/games/randomshooter/files/patch-makefile
new file mode 100644
index 000000000000..0a0eb18378a2
--- /dev/null
+++ b/games/randomshooter/files/patch-makefile
@@ -0,0 +1,33 @@
+--- makefile.orig 2008-02-26 00:44:53.000000000 +0300
++++ makefile 2008-02-27 23:28:42.000000000 +0300
+@@ -1,19 +1,19 @@
+ VERSION = 0.1
+
+-CFLAGS = -Wall -pedantic -Werror -DUNIX -DVERSION=$(VERSION)
+-LFLAGS = `sdl-config --libs` -lSDL -lSDL_mixer -lSDL_image -lSDL_ttf -lSDL_net
++CXXFLAGS += -Wall -DUNIX -DVERSION=$(VERSION) `${SDL_CONFIG} --cflags`
++LFLAGS = `${SDL_CONFIG} --libs` -lSDL_mixer -lSDL_image -lSDL_ttf -lSDL_net
+ OBJS = animation.o audio.o bullets.o collisions.o colors.o draw.o enemies.o entities.o font.o game.o highscores.o
+ OBJS += init.o input.o main.o menu.o movement.o particles.o player.o random.o replay.o score.o screenshot.o
+ OBJS += settings.o stars.o vector.o wave.o weapons.o
+ PROG = randomshooter
+-CXX = gcc
++CXX ?= gcc
+
+ # top-level rule to create the program.
+ all: $(PROG)
+
+ # compiling other source files.
+ %.o: src/%.c src/%.h src/structs.h src/defs.h
+- $(CXX) $(CFLAGS) -c -s $<
++ $(CXX) $(CXXFLAGS) -c -s $<
+
+ # linking the program.
+ $(PROG): $(OBJS)
+@@ -24,4 +24,4 @@
+ rm $(PROG) *.o
+
+ install:
+- echo "make install isn't supported yet..."
+\ No newline at end of file
++ echo "make install isn't supported yet..."
diff --git a/games/randomshooter/files/patch-src-input.c b/games/randomshooter/files/patch-src-input.c
new file mode 100644
index 000000000000..df76df7d0cba
--- /dev/null
+++ b/games/randomshooter/files/patch-src-input.c
@@ -0,0 +1,11 @@
+--- src/input.c.orig 2008-02-23 12:14:38.000000000 +0300
++++ src/input.c 2008-02-27 23:53:35.000000000 +0300
+@@ -170,7 +170,7 @@
+ {
+ char *name = (char *)malloc(25);
+
+- strncpy(name, SDL_GetKeyName(inputValue), 24);
++ strncpy(name, SDL_GetKeyName((SDLKey)inputValue), 24);
+
+ if (strcmp(name, "unknown key") == 0)
+ {
diff --git a/games/randomshooter/pkg-descr b/games/randomshooter/pkg-descr
new file mode 100644
index 000000000000..4f20d88819bc
--- /dev/null
+++ b/games/randomshooter/pkg-descr
@@ -0,0 +1,8 @@
+This is the first release of a shoot em up game written in SDL. The
+objective is simple: you have 1 life and 1 hit will kill you. Try
+and destroy as many enemies as possible before this happens.
+
+The game features an online scoring system and the ability to replay
+game sessions.
+
+WWW: http://www.parallelrealities.co.uk/randomShooter.php
diff --git a/games/randomshooter/pkg-plist b/games/randomshooter/pkg-plist
new file mode 100644
index 000000000000..6ea4ea35f6b8
--- /dev/null
+++ b/games/randomshooter/pkg-plist
@@ -0,0 +1,55 @@
+bin/randomshooter
+%%DATADIR%%/font/blackWolf.ttf
+%%DATADIR%%/gfx/enemy_bullet0001.png
+%%DATADIR%%/gfx/enemy_frame0001.png
+%%DATADIR%%/gfx/enemy_frame0002.png
+%%DATADIR%%/gfx/enemy_frame0003.png
+%%DATADIR%%/gfx/enemy_frame0004.png
+%%DATADIR%%/gfx/enemy_frame0005.png
+%%DATADIR%%/gfx/enemy_frame0006.png
+%%DATADIR%%/gfx/enemy_frame0007.png
+%%DATADIR%%/gfx/enemy_frame0008.png
+%%DATADIR%%/gfx/enemy_frame0009.png
+%%DATADIR%%/gfx/enemy_frame0010.png
+%%DATADIR%%/gfx/enemy_frame0011.png
+%%DATADIR%%/gfx/enemy_frame0012.png
+%%DATADIR%%/gfx/enemy_frame0013.png
+%%DATADIR%%/gfx/enemy_frame0014.png
+%%DATADIR%%/gfx/enemy_frame0015.png
+%%DATADIR%%/gfx/menu_ball0001.png
+%%DATADIR%%/gfx/menu_ball0002.png
+%%DATADIR%%/gfx/menu_ball0003.png
+%%DATADIR%%/gfx/menu_ball0004.png
+%%DATADIR%%/gfx/menu_ball0005.png
+%%DATADIR%%/gfx/menu_ball0006.png
+%%DATADIR%%/gfx/menu_ball0007.png
+%%DATADIR%%/gfx/menu_ball0008.png
+%%DATADIR%%/gfx/menu_ball0009.png
+%%DATADIR%%/gfx/menu_ball0010.png
+%%DATADIR%%/gfx/menu_ball0011.png
+%%DATADIR%%/gfx/menu_ball0012.png
+%%DATADIR%%/gfx/menu_ball0013.png
+%%DATADIR%%/gfx/menu_ball0014.png
+%%DATADIR%%/gfx/menu_ball0015.png
+%%DATADIR%%/gfx/player0001.png
+%%DATADIR%%/gfx/player_bullet0001.png
+%%DATADIR%%/gfx/points_frame0001.png
+%%DATADIR%%/gfx/points_frame0002.png
+%%DATADIR%%/gfx/points_frame0003.png
+%%DATADIR%%/gfx/points_frame0004.png
+%%DATADIR%%/gfx/points_frame0005.png
+%%DATADIR%%/gfx/points_frame0006.png
+%%DATADIR%%/gfx/points_frame0007.png
+%%DATADIR%%/gfx/points_frame0008.png
+%%DATADIR%%/gfx/points_frame0009.png
+%%DATADIR%%/gfx/points_frame0010.png
+%%DATADIR%%/gfx/points_frame0011.png
+%%DATADIR%%/gfx/points_frame0012.png
+%%DATADIR%%/gfx/points_frame0013.png
+%%DATADIR%%/gfx/points_frame0014.png
+%%DATADIR%%/gfx/points_frame0015.png
+%%DATADIR%%/music/17.mod
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%/font
+@dirrm %%DATADIR%%