aboutsummaryrefslogtreecommitdiff
path: root/games/redeclipse-data/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-01-28 11:16:18 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-01-28 11:16:18 +0000
commitd1fb430224a566557c787000b7f2609423787e48 (patch)
treea1d8dcf4d91c1033cc2e99a7d7fd0fa987fd29c8 /games/redeclipse-data/Makefile
parent3f35072ca4041f56ed5b622b19fa805ccb5c6650 (diff)
downloadports-d1fb430224a566557c787000b7f2609423787e48.tar.gz
ports-d1fb430224a566557c787000b7f2609423787e48.zip
- Update to 2.0.0
Notes
Notes: svn path=/head/; revision=563123
Diffstat (limited to 'games/redeclipse-data/Makefile')
-rw-r--r--games/redeclipse-data/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/games/redeclipse-data/Makefile b/games/redeclipse-data/Makefile
index e2b34ae74a92..61688d0bdd71 100644
--- a/games/redeclipse-data/Makefile
+++ b/games/redeclipse-data/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= redeclipse-data
-PORTVERSION= 1.6.0
+PORTVERSION= 2.0.0
DISTVERSIONPREFIX= v
CATEGORIES= games
@@ -10,13 +10,8 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Data files for Red Eclipse first-person shooter
USE_GITHUB= nodefault
-GH_TUPLE= ${DATAFILES:C/.*/red-eclipse:&:${DISTVERSIONPREFIX}${PORTVERSION}:&\/&/}
-DATAFILES= acerspyro actors appleflap blendbrush caustics crosshairs \
- decals dziq elyvisions fonts freezurbern john jojo jwin luckystrike \
- maps mayhem mikeplus64 misc nieb nobiax particles philipk \
- projectiles props skyboxes snipergoth sounds textures torley \
- trak ulukai unnamed vanities vegetation weapons wicked
+.include "${.CURDIR}/Makefile.tuples"
NO_BUILD= yes
NO_ARCH= yes
@@ -26,6 +21,18 @@ DATADIR= ${PREFIX}/share/redeclipse
PORTDATA= *
do-install:
- @cd ${WRKSRC} && ${COPYTREE_SHARE} "${DATAFILES}" ${STAGEDIR}${DATADIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
+
+Makefile.tuples::
+ @${ECHO_CMD} '# $$Free''BSD$$' > ${.CURDIR}/Makefile.tuples
+ @${RM} -rf ${WRKDIR}/.maintainer.checkout
+ @${MKDIR} ${WRKDIR}/.maintainer.checkout \
+ && cd ${WRKDIR}/.maintainer.checkout \
+ && git clone --depth=1 --branch=${DISTVERSIONPREFIX}${PORTVERSION} \
+ https://github.com/redeclipse/base.git . \
+ && git submodule \
+ | awk '{print substr($$1,2,7), substr($$2,6)}' \
+ | awk '{printf("%sredeclipse:%s:%s:%s/%s \\\n", NR==1 ? "GH_TUPLE=\t" : "\t\t", $$2, $$1, $$2, $$2, $$2)}' \
+ >> ${.CURDIR}/Makefile.tuples
.include <bsd.port.mk>