aboutsummaryrefslogtreecommitdiff
path: root/games/scid
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-04 15:11:47 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-03-04 15:11:47 +0000
commit7eeb1f1cd610d4ca47ea4bea9f13ff5a02bc3038 (patch)
tree7dbab975412748a948dbeccebed4b646fcce56e0 /games/scid
parente73f181a7d78ad0664a6d3d1653e6969779e367e (diff)
downloadports-7eeb1f1cd610d4ca47ea4bea9f13ff5a02bc3038.tar.gz
ports-7eeb1f1cd610d4ca47ea4bea9f13ff5a02bc3038.zip
add scid 3.2
A free chess database application
Notes
Notes: svn path=/head/; revision=55523
Diffstat (limited to 'games/scid')
-rw-r--r--games/scid/Makefile24
-rw-r--r--games/scid/distinfo1
-rw-r--r--games/scid/files/patch-Makefile60
-rw-r--r--games/scid/pkg-comment1
-rw-r--r--games/scid/pkg-descr18
-rw-r--r--games/scid/pkg-plist16
6 files changed, 120 insertions, 0 deletions
diff --git a/games/scid/Makefile b/games/scid/Makefile
new file mode 100644
index 000000000000..82ef7fe25d24
--- /dev/null
+++ b/games/scid/Makefile
@@ -0,0 +1,24 @@
+# ex:ts=8
+# Ports collection makefile for: scid
+# Date created: Mar 4, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= scid
+PORTVERSION= 3.2
+CATEGORIES= games
+MASTER_SITES= http://scid.sourceforge.net/download/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= tcl83:${PORTSDIR}/lang/tcl83 \
+ tk83:${PORTSDIR}/x11-toolkits/tk83
+
+USE_XLIB= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/games/scid/distinfo b/games/scid/distinfo
new file mode 100644
index 000000000000..b0d53d5beb66
--- /dev/null
+++ b/games/scid/distinfo
@@ -0,0 +1 @@
+MD5 (scid-3.2.tar.gz) = 299f021aeb7166971c25af3a28058a3f
diff --git a/games/scid/files/patch-Makefile b/games/scid/files/patch-Makefile
new file mode 100644
index 000000000000..f74b108db16b
--- /dev/null
+++ b/games/scid/files/patch-Makefile
@@ -0,0 +1,60 @@
+--- Makefile.orig Fri Feb 22 11:39:00 2002
++++ Makefile Mon Mar 4 23:02:42 2002
+@@ -8,11 +8,11 @@
+
+ # BINDIR: where the Scid programs are copied for "make install".
+ #
+-BINDIR = /usr/local/bin
++BINDIR = ${PREFIX}/bin
+
+ # SHAREDIR: where scid.eco and spelling.ssp are copied for "make install".
+ #
+-SHAREDIR = /usr/local/share/scid
++SHAREDIR = ${PREFIX}/share/scid
+
+ ### TCL_VERSION: Set this according to the version of Tcl/Tk you have
+ # installed that you want Scid to use: 8.0, 8.1, 8.2, 8.3, etc.
+@@ -26,9 +26,9 @@
+ #
+ # You have not run "./configure" yet. The default settings are:
+ #
+-TCL_INCLUDE = -I/usr/include
+-TCL_LIBRARY = -L/usr/lib -ltcl$(TCL_VERSION) -ldl
+-TK_LIBRARY = $(TCL_LIBRARY) -ltk$(TCL_VERSION) -L/usr/X11R6/lib -lX11
++#TCL_INCLUDE = -I/usr/include
++#TCL_LIBRARY = -L/usr/lib -ltcl$(TCL_VERSION) -ldl
++#TK_LIBRARY = $(TCL_LIBRARY) -ltk$(TCL_VERSION) -L/usr/X11R6/lib -lX11
+
+ ### Here are other commonly used settings for the Tcl/Tk compiler options:
+
+@@ -50,9 +50,9 @@
+
+ # Someone sent me these settings for FreeBSD with Tcl/Tk 8.0:
+ ### FreeBSD:
+-# TCL_INCLUDE = -I /usr/local/include/tcl8.0 -I /usr/local/include/tk8.0
+-# TCL_LIBRARY = -L /usr/local/lib -ltcl80 -ldl
+-# TK_LIBRARY = $(TCL_LIBRARY) -ltk80 -L /usr/X11/lib -lX11
++TCL_INCLUDE = -I${LOCALBASE}/include/tcl8.3 -I${LOCALBASE}/include/tk8.3 -I${X11BASE}/include
++TCL_LIBRARY = -L${LOCALBASE}/lib -ltcl83
++TK_LIBRARY = $(TCL_LIBRARY) -ltk83 -L${X11BASE}/lib -lX11
+
+
+ ########################################
+@@ -79,7 +79,7 @@
+ # On some systems, adding "-fno-rtti" and "-fno-exceptions" produces
+ # smaller, faster programs since Scid does not use those C++ features.
+ #
+-OPTIMIZE = -O4 -fno-rtti -fno-exceptions
++OPTIMIZE = ${CXXFLAGS} -fno-rtti -fno-exceptions
+
+ ### DEBUG: Defining the macro ASSERTIONS will turn on assertions, which
+ # helps to track bugs after modifications, but the programs will run
+@@ -110,7 +110,7 @@
+ # can reduce the size of the Scid program by only specifying
+ # the languages you want supported.
+ #
+-LANGUAGES = tcl/deutsch.tcl tcl/francais.tcl tcl/italian.tcl tcl/nederlan.tcl tcl/spanish.tcl tcl/portbr.tcl tcl/swedish.tcl tcl/norsk.tcl tcl/polish.tcl tcl/czech.tcl tcl/serbian.tcl
++LANGUAGES =
+
+
+ ############################################################
diff --git a/games/scid/pkg-comment b/games/scid/pkg-comment
new file mode 100644
index 000000000000..3c4be87a2ecb
--- /dev/null
+++ b/games/scid/pkg-comment
@@ -0,0 +1 @@
+A free chess database application
diff --git a/games/scid/pkg-descr b/games/scid/pkg-descr
new file mode 100644
index 000000000000..1f1cf781a0e8
--- /dev/null
+++ b/games/scid/pkg-descr
@@ -0,0 +1,18 @@
+Scid is a chess database application; with it you can browse databases of
+chess games, edit games and search for games by various criteria.
+
+Scid uses its own special three-file database format which is very compact
+and fast, but it can convert to and from the standard PGN (Portable Game
+Notation) format. Scids PGN window displays the text of the current game in
+PGN format.
+
+You can use Scid to add chess games to a database, using the keyboard or mouse
+to enter moves.
+
+You can also use Scid as a PGN file browser, by pasting PGN text into Scids
+Import window or by opening a PGN file in Scid. However, PGN files cannot be
+edited by Scid (it opens them read-only) and they use more memory and are
+slower to load, so for large PGN files it is recommended that you create a
+Scid database from them first with the pgnscid utility.
+
+WWW: http://scid.sourceforge.net/
diff --git a/games/scid/pkg-plist b/games/scid/pkg-plist
new file mode 100644
index 000000000000..bf0040001603
--- /dev/null
+++ b/games/scid/pkg-plist
@@ -0,0 +1,16 @@
+bin/pgnfix
+bin/pgnscid
+bin/sc_addmove
+bin/sc_eco
+bin/sc_epgn
+bin/sc_import
+bin/sc_spell
+bin/sc_tree
+bin/scid
+bin/scidpgn
+bin/scmerge
+bin/tcscid
+bin/tkscid
+share/scid/scid.eco
+share/scid/spelling.ssp
+@dirrm share/scid