aboutsummaryrefslogtreecommitdiff
path: root/games/scourge/Makefile
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2006-06-17 18:05:19 +0000
committerStefan Walter <stefan@FreeBSD.org>2006-06-17 18:05:19 +0000
commitc975d28ce0bcdf4d8be57c825e4bc78e81539104 (patch)
treea47dad6870a9b921765b2622f198673845848f18 /games/scourge/Makefile
parent016ac5bb36d553c3fbe3a739cb6e6adc76a31762 (diff)
downloadports-c975d28ce0bcdf4d8be57c825e4bc78e81539104.tar.gz
ports-c975d28ce0bcdf4d8be57c825e4bc78e81539104.zip
- Update to 0.14.
- Add dependency on newly-created games/scourge-data. - Remove USE_X_PREFIX. PR: 98926 Submitted by: maintainer Approved by: arved (mentor)
Notes
Notes: svn path=/head/; revision=165657
Diffstat (limited to 'games/scourge/Makefile')
-rw-r--r--games/scourge/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/games/scourge/Makefile b/games/scourge/Makefile
index dd801db65e60..03e1e8548940 100644
--- a/games/scourge/Makefile
+++ b/games/scourge/Makefile
@@ -6,17 +6,18 @@
#
PORTNAME= scourge
-PORTVERSION= 0.13
+PORTVERSION= 0.14
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= scourge
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DIST_SUBDIR= ${PORTNAME}
MAINTAINER= acardenas@bsd.org.pe
COMMENT= S.C.O.U.R.G.E. is a rogue-like game
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+RUN_DEPENDS= ${DATADIR}/world/gui.txt:${PORTSDIR}/games/scourge-data
-USE_X_PREFIX= yes
USE_GL= yes
USE_SDL= sdl mixer net
USE_GMAKE= yes
@@ -29,17 +30,18 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-data-dir=${DATADIR}
+PLIST_FILES= bin/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
OPTIONS= DEBUG "Produce an executable with debugging symbols" off
+.include <bsd.port.pre.mk>
+
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin/
- @${MKDIR} ${DATADIR}
- @cd ${WRKSRC}/data && \
- ${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
- ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>