aboutsummaryrefslogtreecommitdiff
path: root/games/sdl-ball
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-06 00:41:13 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-06 00:41:13 +0000
commit1e85259f841c221927375264c78fb5070bcdf91d (patch)
treee547bb61c1e8651273739286d1a5ce527ee5ed30 /games/sdl-ball
parent843250c138eb5ff378503407f23a1678852d8263 (diff)
downloadports-1e85259f841c221927375264c78fb5070bcdf91d.tar.gz
ports-1e85259f841c221927375264c78fb5070bcdf91d.zip
Arkanoid/Breakout clone with pretty graphics.
Notes
Notes: svn path=/head/; revision=219962
Diffstat (limited to 'games/sdl-ball')
-rw-r--r--games/sdl-ball/Makefile31
-rw-r--r--games/sdl-ball/distinfo3
-rw-r--r--games/sdl-ball/files/patch-Makefile12
-rw-r--r--games/sdl-ball/pkg-descr3
-rw-r--r--games/sdl-ball/pkg-plist61
5 files changed, 110 insertions, 0 deletions
diff --git a/games/sdl-ball/Makefile b/games/sdl-ball/Makefile
new file mode 100644
index 000000000000..9ca2c81c08e7
--- /dev/null
+++ b/games/sdl-ball/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: sdl-ball
+# Date created: 22 Apr 2008
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl-ball
+PORTVERSION= 0.10
+CATEGORIES= games
+MASTER_SITES= SF
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Arkanoid/Breakout clone with pretty graphics
+
+USE_BZIP2= yes
+USE_SDL= sdl image ttf
+USE_GL= gl glu
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|data/|${DATADIR}/|' \
+ ${WRKSRC}/main.cpp ${WRKSRC}/menu.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sdl-ball ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/data && ${COPYTREE_SHARE} . ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/sdl-ball/distinfo b/games/sdl-ball/distinfo
new file mode 100644
index 000000000000..3521184a288b
--- /dev/null
+++ b/games/sdl-ball/distinfo
@@ -0,0 +1,3 @@
+MD5 (sdl-ball-0.10.tar.bz2) = 6a4a5ed16e281d39162929c4b1e4c982
+SHA256 (sdl-ball-0.10.tar.bz2) = a51a38241c96c6ab2503861e61614196b94596d22f507501fa12d18f7a683e61
+SIZE (sdl-ball-0.10.tar.bz2) = 1119165
diff --git a/games/sdl-ball/files/patch-Makefile b/games/sdl-ball/files/patch-Makefile
new file mode 100644
index 000000000000..ae25675fad73
--- /dev/null
+++ b/games/sdl-ball/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig 2008-08-22 22:07:53.000000000 +0400
++++ Makefile 2008-09-06 03:21:15.000000000 +0400
+@@ -1,7 +1,5 @@
+-CC=g++
+-#CFLAGS=-g -c -Wall
+-CFLAGS=-c -Wall
+-LDFLAGS=-lGL -lGLU -lSDL -lSDL_image -lSDL_ttf
++CFLAGS+=-c -Wall `${SDL_CONFIG} --cflags`
++LDFLAGS=-lGL -lGLU `${SDL_CONFIG} --libs` -lSDL_image -lSDL_ttf
+ # -lopenal
+ SOURCES=main.cpp
+ OBJECTS=$(SOURCES:.cpp=.o)
diff --git a/games/sdl-ball/pkg-descr b/games/sdl-ball/pkg-descr
new file mode 100644
index 000000000000..a6af1813d715
--- /dev/null
+++ b/games/sdl-ball/pkg-descr
@@ -0,0 +1,3 @@
+Arkanoid/Breakout clone with pretty graphics.
+
+WWW: http://sourceforge.net/projects/sdl-ball
diff --git a/games/sdl-ball/pkg-plist b/games/sdl-ball/pkg-plist
new file mode 100644
index 000000000000..21fcc1117fc6
--- /dev/null
+++ b/games/sdl-ball/pkg-plist
@@ -0,0 +1,61 @@
+bin/sdl-ball
+%%DATADIR%%/font/acidic.ttf
+%%DATADIR%%/font/ack.ttf
+%%DATADIR%%/gfx/ball/fireball.png
+%%DATADIR%%/gfx/ball/tail.png
+%%DATADIR%%/gfx/ball/test.png
+%%DATADIR%%/gfx/border.png
+%%DATADIR%%/gfx/brick/ani1.png
+%%DATADIR%%/gfx/brick/base.png
+%%DATADIR%%/gfx/brick/cement.png
+%%DATADIR%%/gfx/brick/doom-org.png
+%%DATADIR%%/gfx/brick/doom.png
+%%DATADIR%%/gfx/brick/explosive.png
+%%DATADIR%%/gfx/brick/glass.png
+%%DATADIR%%/gfx/brick/invisible.png
+%%DATADIR%%/gfx/highscore/entername.png
+%%DATADIR%%/gfx/highscore/numbers.png
+%%DATADIR%%/gfx/menu/but0.png
+%%DATADIR%%/gfx/menu/but1.png
+%%DATADIR%%/gfx/menu/but2.png
+%%DATADIR%%/gfx/menu/highscorebg.png
+%%DATADIR%%/gfx/menu/life.png
+%%DATADIR%%/gfx/menu/menu0.png
+%%DATADIR%%/gfx/paddle/aim.png
+%%DATADIR%%/gfx/paddle/base.png
+%%DATADIR%%/gfx/paddle/glue.png
+%%DATADIR%%/gfx/paddle/gun.png
+%%DATADIR%%/gfx/particle.png
+%%DATADIR%%/gfx/powerup/aim.png
+%%DATADIR%%/gfx/powerup/aimhelp.png
+%%DATADIR%%/gfx/powerup/bigball.png
+%%DATADIR%%/gfx/powerup/bullet.png
+%%DATADIR%%/gfx/powerup/detonate.png
+%%DATADIR%%/gfx/powerup/die.png
+%%DATADIR%%/gfx/powerup/drop.png
+%%DATADIR%%/gfx/powerup/easybrick.png
+%%DATADIR%%/gfx/powerup/explosive-grow.png
+%%DATADIR%%/gfx/powerup/explosive.png
+%%DATADIR%%/gfx/powerup/glue.png
+%%DATADIR%%/gfx/powerup/go-thru.png
+%%DATADIR%%/gfx/powerup/gravity.png
+%%DATADIR%%/gfx/powerup/growbat.png
+%%DATADIR%%/gfx/powerup/gun.png
+%%DATADIR%%/gfx/powerup/laser.png
+%%DATADIR%%/gfx/powerup/life.png
+%%DATADIR%%/gfx/powerup/multiball.png
+%%DATADIR%%/gfx/powerup/nextlevel.png
+%%DATADIR%%/gfx/powerup/normalball.png
+%%DATADIR%%/gfx/powerup/shrinkbat.png
+%%DATADIR%%/gfx/powerup/smallball.png
+%%DATADIR%%/levels.txt
+%%DATADIR%%/powerups.txt
+@dirrm %%DATADIR%%/gfx/powerup
+@dirrm %%DATADIR%%/gfx/paddle
+@dirrm %%DATADIR%%/gfx/menu
+@dirrm %%DATADIR%%/gfx/highscore
+@dirrm %%DATADIR%%/gfx/brick
+@dirrm %%DATADIR%%/gfx/ball
+@dirrm %%DATADIR%%/gfx
+@dirrm %%DATADIR%%/font
+@dirrm %%DATADIR%%