aboutsummaryrefslogtreecommitdiff
path: root/games/slune/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-10 17:46:45 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-10 17:46:45 +0000
commit72b3e863911e6821723c6d3edf223e8ade7cb1e9 (patch)
treece09bf02910e5cc08cc376951e91641976da8f4c /games/slune/Makefile
parent40bb5822a291a72cdbadc74e5f7d9dd95081ae18 (diff)
downloadports-72b3e863911e6821723c6d3edf223e8ade7cb1e9.tar.gz
ports-72b3e863911e6821723c6d3edf223e8ade7cb1e9.zip
Remove games/py-slune to reflect real name.
-- New port games/slune Slune is a fun action 3D game where races, pursuits, car crashing, and corrosive humour are all waiting for you! Slune is Free Software, under the GNU GPL license, and is a Nekeme Prod. game PR: 87013 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
Notes
Notes: svn path=/head/; revision=144850
Diffstat (limited to 'games/slune/Makefile')
-rw-r--r--games/slune/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/games/slune/Makefile b/games/slune/Makefile
new file mode 100644
index 000000000000..9158a26ac217
--- /dev/null
+++ b/games/slune/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: slune
+# Date created: 2005-10-06
+# Whom: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= slune
+PORTVERSION= 1.0.10
+CATEGORIES= games python
+MASTER_SITES= http://download.gna.org/slune/
+DISTNAME= Slune-${PORTVERSION}
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= 3D game. includes racing, car-crashing, and lots of action
+
+RUN_DEPENDS= soya_editor:${PORTSDIR}/graphics/py-soya3d \
+ ${PYTHON_SITELIBDIR}/_openal.so:${PORTSDIR}/audio/py-openal \
+ ${PYTHON_SITELIBDIR}/pysdl_mixer/sdl_mixer.so:${PORTSDIR}/audio/py-sdl_mixer \
+ ${PYTHON_SITELIBDIR}/ogg/vorbis.so:${PORTSDIR}/audio/py-vorbis \
+ ${PYTHON_SITELIBDIR}/py2play/level.py:${PORTSDIR}/net/py-py2play
+LIB_DEPENDS= cal3d.11:${PORTSDIR}/graphics/cal3d \
+ GLEW.1:${PORTSDIR}/graphics/glew
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_GL= yes
+USE_SDL= sdl mixer
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>