aboutsummaryrefslogtreecommitdiff
path: root/games/sol/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2014-05-13 20:53:42 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2014-05-13 20:53:42 +0000
commitaae3af8290a276503c6201bd5e0e3af3f1d4caf8 (patch)
tree0401c37efb2e601c4994dcb1003e2265c208893b /games/sol/Makefile
parent4cdf0359ba20b81766acfd7878c66a99b1aff754 (diff)
downloadports-aae3af8290a276503c6201bd5e0e3af3f1d4caf8.tar.gz
ports-aae3af8290a276503c6201bd5e0e3af3f1d4caf8.zip
Fix staging
Notes
Notes: svn path=/head/; revision=353993
Diffstat (limited to 'games/sol/Makefile')
-rw-r--r--games/sol/Makefile37
1 files changed, 17 insertions, 20 deletions
diff --git a/games/sol/Makefile b/games/sol/Makefile
index 85e36350403e..93dc4eb78176 100644
--- a/games/sol/Makefile
+++ b/games/sol/Makefile
@@ -10,38 +10,35 @@ MASTER_SITES= http://shh.thathost.com/pub-unix/files/
MAINTAINER= edwin@mavetju.org
COMMENT= Solitaire card game for X Window System
-LIB_DEPENDS= shhopt.1:${PORTSDIR}/devel/libshhopt \
- shhmsg.1:${PORTSDIR}/devel/libshhmsg \
- xalloc.1:${PORTSDIR}/devel/libxalloc \
- shhcards.1:${PORTSDIR}/games/libshhcards
+LIB_DEPENDS= libshhopt.so.1:${PORTSDIR}/devel/libshhopt \
+ libshhmsg.so.1:${PORTSDIR}/devel/libshhmsg \
+ libxalloc.so.1:${PORTSDIR}/devel/libxalloc \
+ libshhcards.so.1:${PORTSDIR}/games/libshhcards
CONFLICTS= gnome-games-*
-USE_GMAKE= yes
+USES= gmake
USE_XORG= xpm x11 xaw
-MAN6= sol.6
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
pre-build:
cd ${WRKSRC} && ${GMAKE} readme.var
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sol ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/sol.6 ${PREFIX}/man/man6
- @${MKDIR} ${PREFIX}/share/sol
- ${INSTALL_DATA} ${WRKSRC}/sol.score ${PREFIX}/share/sol
- @${CHOWN} root:games ${PREFIX}/bin/sol
- @${CHOWN} root:games ${PREFIX}/share/sol/sol.score
- @${CHMOD} 2755 ${PREFIX}/bin/sol
- @${CHMOD} 770 ${PREFIX}/share/sol
- @${CHMOD} 660 ${PREFIX}/share/sol/sol.score
+ ${INSTALL_PROGRAM} ${WRKSRC}/sol ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/sol.6 ${STAGEDIR}${PREFIX}/man/man6
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/sol
+ ${INSTALL_DATA} ${WRKSRC}/sol.score ${STAGEDIR}${PREFIX}/share/sol
+ @${CHOWN} root:games ${STAGEDIR}${PREFIX}/bin/sol
+ @${CHOWN} root:games ${STAGEDIR}${PREFIX}/share/sol/sol.score
+ @${CHMOD} 2755 ${STAGEDIR}${PREFIX}/bin/sol
+ @${CHMOD} 770 ${STAGEDIR}${PREFIX}/share/sol
+ @${CHMOD} 660 ${STAGEDIR}${PREFIX}/share/sol/sol.score
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/sol
- ${INSTALL_DATA} ${WRKSRC}/CREDITS ${PREFIX}/share/doc/sol
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/sol
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/doc/sol
+ ${INSTALL_DATA} ${WRKSRC}/CREDITS ${STAGEDIR}${PREFIX}/share/doc/sol
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${PREFIX}/share/doc/sol
.endif
.include <bsd.port.post.mk>