aboutsummaryrefslogtreecommitdiff
path: root/games/solarus
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2020-04-21 23:04:38 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2020-04-21 23:04:38 +0000
commit7cac5cd703c079d9b63534aa456636160b4d83b9 (patch)
tree28437c89f98faf7a1cf1224709ee83eb41a8567a /games/solarus
parent2609331d94b0c94d93a3428068a450a69bc227cc (diff)
downloadports-7cac5cd703c079d9b63534aa456636160b4d83b9.tar.gz
ports-7cac5cd703c079d9b63534aa456636160b4d83b9.zip
- Update to 1.6.4
Notes
Notes: svn path=/head/; revision=532433
Diffstat (limited to 'games/solarus')
-rw-r--r--games/solarus/Makefile11
-rw-r--r--games/solarus/distinfo6
-rw-r--r--games/solarus/pkg-plist282
3 files changed, 22 insertions, 277 deletions
diff --git a/games/solarus/Makefile b/games/solarus/Makefile
index d499a41ce6a9..a4d076fcbe96 100644
--- a/games/solarus/Makefile
+++ b/games/solarus/Makefile
@@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= solarus
-PORTVERSION= 1.6.2
+PORTVERSION= 1.6.4
DISTVERSIONPREFIX= v
-PORTREVISION= 1
CATEGORIES= games
MAINTAINER= danilo@FreeBSD.org
@@ -16,12 +15,14 @@ LIB_DEPENDS= libphysfs.so:devel/physfs \
libmodplug.so:audio/libmodplug \
libvorbis.so:audio/libvorbis \
libogg.so:audio/libogg
+RUN_DEPENDS= glm>0:math/glm
+BUILD_DEPENDS= glm>0:math/glm
USES= cmake:noninja compiler:c++11-lib gl openal qmake qt:5 sdl xorg
USE_GITLAB= yes
GL_ACCOUNT= solarus-games
-GL_COMMIT= 004d6f792d9ad5dcfc0575e6a029b987bd9f8807
+GL_COMMIT= f43727b232b3ed13d98440a845e2a29e470e4f0d
MAKE_ARGS+= DESTDIR=${STAGEDIR}
USE_QT= buildtools_build core gui linguisttools_build widgets
@@ -41,8 +42,4 @@ LUAJIT_USES_OFF= lua:51
CMAKE_ARGS+= -DSOLARUS_MANUAL_INSTALL_DESTINATION:STRING="man"
-post-install:
- ${GZIP_CMD} ${STAGEDIR}${PREFIX}/man/man6/solarus-run.6 \
- ${STAGEDIR}${PREFIX}/man/man6/solarus.6
-
.include <bsd.port.mk>
diff --git a/games/solarus/distinfo b/games/solarus/distinfo
index d53d8e5dc863..b8f0df459553 100644
--- a/games/solarus/distinfo
+++ b/games/solarus/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1567194123
-SHA256 (solarus-games-solarus-004d6f792d9ad5dcfc0575e6a029b987bd9f8807_GL0.tar.gz) = 36f29d154447c93a54e92a6979a0005017fd00c83dd1cd9d9d2c4f92d6c452c7
-SIZE (solarus-games-solarus-004d6f792d9ad5dcfc0575e6a029b987bd9f8807_GL0.tar.gz) = 15073302
+TIMESTAMP = 1587498822
+SHA256 (solarus-games-solarus-f43727b232b3ed13d98440a845e2a29e470e4f0d_GL0.tar.gz) = 750d0bd650485d5462c1b181e852a52e6a188d5c11962b92d53c2084001557d8
+SIZE (solarus-games-solarus-f43727b232b3ed13d98440a845e2a29e470e4f0d_GL0.tar.gz) = 14994373
diff --git a/games/solarus/pkg-plist b/games/solarus/pkg-plist
index 7f53ceefa668..267e0db3fc83 100644
--- a/games/solarus/pkg-plist
+++ b/games/solarus/pkg-plist
@@ -240,260 +240,6 @@ include/solarus/movements/StraightMovement.h
include/solarus/movements/TargetMovement.h
include/solarus/third_party/KHR/khrplatform.h
include/solarus/third_party/glad/glad.h
-include/solarus/third_party/glm/CMakeLists.txt
-include/solarus/third_party/glm/common.hpp
-include/solarus/third_party/glm/detail/_features.hpp
-include/solarus/third_party/glm/detail/_fixes.hpp
-include/solarus/third_party/glm/detail/_noise.hpp
-include/solarus/third_party/glm/detail/_swizzle.hpp
-include/solarus/third_party/glm/detail/_swizzle_func.hpp
-include/solarus/third_party/glm/detail/_vectorize.hpp
-include/solarus/third_party/glm/detail/dummy.cpp
-include/solarus/third_party/glm/detail/func_common.hpp
-include/solarus/third_party/glm/detail/func_common.inl
-include/solarus/third_party/glm/detail/func_exponential.hpp
-include/solarus/third_party/glm/detail/func_exponential.inl
-include/solarus/third_party/glm/detail/func_geometric.hpp
-include/solarus/third_party/glm/detail/func_geometric.inl
-include/solarus/third_party/glm/detail/func_integer.hpp
-include/solarus/third_party/glm/detail/func_integer.inl
-include/solarus/third_party/glm/detail/func_matrix.hpp
-include/solarus/third_party/glm/detail/func_matrix.inl
-include/solarus/third_party/glm/detail/func_packing.hpp
-include/solarus/third_party/glm/detail/func_packing.inl
-include/solarus/third_party/glm/detail/func_trigonometric.hpp
-include/solarus/third_party/glm/detail/func_trigonometric.inl
-include/solarus/third_party/glm/detail/func_vector_relational.hpp
-include/solarus/third_party/glm/detail/func_vector_relational.inl
-include/solarus/third_party/glm/detail/glm.cpp
-include/solarus/third_party/glm/detail/intrinsic_common.hpp
-include/solarus/third_party/glm/detail/intrinsic_common.inl
-include/solarus/third_party/glm/detail/intrinsic_exponential.hpp
-include/solarus/third_party/glm/detail/intrinsic_exponential.inl
-include/solarus/third_party/glm/detail/intrinsic_geometric.hpp
-include/solarus/third_party/glm/detail/intrinsic_geometric.inl
-include/solarus/third_party/glm/detail/intrinsic_integer.hpp
-include/solarus/third_party/glm/detail/intrinsic_integer.inl
-include/solarus/third_party/glm/detail/intrinsic_matrix.hpp
-include/solarus/third_party/glm/detail/intrinsic_matrix.inl
-include/solarus/third_party/glm/detail/intrinsic_trigonometric.hpp
-include/solarus/third_party/glm/detail/intrinsic_trigonometric.inl
-include/solarus/third_party/glm/detail/intrinsic_vector_relational.hpp
-include/solarus/third_party/glm/detail/intrinsic_vector_relational.inl
-include/solarus/third_party/glm/detail/precision.hpp
-include/solarus/third_party/glm/detail/setup.hpp
-include/solarus/third_party/glm/detail/type_float.hpp
-include/solarus/third_party/glm/detail/type_gentype.hpp
-include/solarus/third_party/glm/detail/type_gentype.inl
-include/solarus/third_party/glm/detail/type_half.hpp
-include/solarus/third_party/glm/detail/type_half.inl
-include/solarus/third_party/glm/detail/type_int.hpp
-include/solarus/third_party/glm/detail/type_mat.hpp
-include/solarus/third_party/glm/detail/type_mat.inl
-include/solarus/third_party/glm/detail/type_mat2x2.hpp
-include/solarus/third_party/glm/detail/type_mat2x2.inl
-include/solarus/third_party/glm/detail/type_mat2x3.hpp
-include/solarus/third_party/glm/detail/type_mat2x3.inl
-include/solarus/third_party/glm/detail/type_mat2x4.hpp
-include/solarus/third_party/glm/detail/type_mat2x4.inl
-include/solarus/third_party/glm/detail/type_mat3x2.hpp
-include/solarus/third_party/glm/detail/type_mat3x2.inl
-include/solarus/third_party/glm/detail/type_mat3x3.hpp
-include/solarus/third_party/glm/detail/type_mat3x3.inl
-include/solarus/third_party/glm/detail/type_mat3x4.hpp
-include/solarus/third_party/glm/detail/type_mat3x4.inl
-include/solarus/third_party/glm/detail/type_mat4x2.hpp
-include/solarus/third_party/glm/detail/type_mat4x2.inl
-include/solarus/third_party/glm/detail/type_mat4x3.hpp
-include/solarus/third_party/glm/detail/type_mat4x3.inl
-include/solarus/third_party/glm/detail/type_mat4x4.hpp
-include/solarus/third_party/glm/detail/type_mat4x4.inl
-include/solarus/third_party/glm/detail/type_vec.hpp
-include/solarus/third_party/glm/detail/type_vec.inl
-include/solarus/third_party/glm/detail/type_vec1.hpp
-include/solarus/third_party/glm/detail/type_vec1.inl
-include/solarus/third_party/glm/detail/type_vec2.hpp
-include/solarus/third_party/glm/detail/type_vec2.inl
-include/solarus/third_party/glm/detail/type_vec3.hpp
-include/solarus/third_party/glm/detail/type_vec3.inl
-include/solarus/third_party/glm/detail/type_vec4.hpp
-include/solarus/third_party/glm/detail/type_vec4.inl
-include/solarus/third_party/glm/detail/type_vec4_avx.inl
-include/solarus/third_party/glm/detail/type_vec4_avx2.inl
-include/solarus/third_party/glm/detail/type_vec4_sse2.inl
-include/solarus/third_party/glm/exponential.hpp
-include/solarus/third_party/glm/ext.hpp
-include/solarus/third_party/glm/fwd.hpp
-include/solarus/third_party/glm/geometric.hpp
-include/solarus/third_party/glm/glm.hpp
-include/solarus/third_party/glm/gtc/bitfield.hpp
-include/solarus/third_party/glm/gtc/bitfield.inl
-include/solarus/third_party/glm/gtc/color_space.hpp
-include/solarus/third_party/glm/gtc/color_space.inl
-include/solarus/third_party/glm/gtc/constants.hpp
-include/solarus/third_party/glm/gtc/constants.inl
-include/solarus/third_party/glm/gtc/epsilon.hpp
-include/solarus/third_party/glm/gtc/epsilon.inl
-include/solarus/third_party/glm/gtc/integer.hpp
-include/solarus/third_party/glm/gtc/integer.inl
-include/solarus/third_party/glm/gtc/matrix_access.hpp
-include/solarus/third_party/glm/gtc/matrix_access.inl
-include/solarus/third_party/glm/gtc/matrix_integer.hpp
-include/solarus/third_party/glm/gtc/matrix_inverse.hpp
-include/solarus/third_party/glm/gtc/matrix_inverse.inl
-include/solarus/third_party/glm/gtc/matrix_transform.hpp
-include/solarus/third_party/glm/gtc/matrix_transform.inl
-include/solarus/third_party/glm/gtc/noise.hpp
-include/solarus/third_party/glm/gtc/noise.inl
-include/solarus/third_party/glm/gtc/packing.hpp
-include/solarus/third_party/glm/gtc/packing.inl
-include/solarus/third_party/glm/gtc/quaternion.hpp
-include/solarus/third_party/glm/gtc/quaternion.inl
-include/solarus/third_party/glm/gtc/random.hpp
-include/solarus/third_party/glm/gtc/random.inl
-include/solarus/third_party/glm/gtc/reciprocal.hpp
-include/solarus/third_party/glm/gtc/reciprocal.inl
-include/solarus/third_party/glm/gtc/round.hpp
-include/solarus/third_party/glm/gtc/round.inl
-include/solarus/third_party/glm/gtc/type_precision.hpp
-include/solarus/third_party/glm/gtc/type_precision.inl
-include/solarus/third_party/glm/gtc/type_ptr.hpp
-include/solarus/third_party/glm/gtc/type_ptr.inl
-include/solarus/third_party/glm/gtc/ulp.hpp
-include/solarus/third_party/glm/gtc/ulp.inl
-include/solarus/third_party/glm/gtc/vec1.hpp
-include/solarus/third_party/glm/gtc/vec1.inl
-include/solarus/third_party/glm/gtx/associated_min_max.hpp
-include/solarus/third_party/glm/gtx/associated_min_max.inl
-include/solarus/third_party/glm/gtx/bit.hpp
-include/solarus/third_party/glm/gtx/bit.inl
-include/solarus/third_party/glm/gtx/closest_point.hpp
-include/solarus/third_party/glm/gtx/closest_point.inl
-include/solarus/third_party/glm/gtx/color_space.hpp
-include/solarus/third_party/glm/gtx/color_space.inl
-include/solarus/third_party/glm/gtx/color_space_YCoCg.hpp
-include/solarus/third_party/glm/gtx/color_space_YCoCg.inl
-include/solarus/third_party/glm/gtx/common.hpp
-include/solarus/third_party/glm/gtx/common.inl
-include/solarus/third_party/glm/gtx/compatibility.hpp
-include/solarus/third_party/glm/gtx/compatibility.inl
-include/solarus/third_party/glm/gtx/component_wise.hpp
-include/solarus/third_party/glm/gtx/component_wise.inl
-include/solarus/third_party/glm/gtx/dual_quaternion.hpp
-include/solarus/third_party/glm/gtx/dual_quaternion.inl
-include/solarus/third_party/glm/gtx/euler_angles.hpp
-include/solarus/third_party/glm/gtx/euler_angles.inl
-include/solarus/third_party/glm/gtx/extend.hpp
-include/solarus/third_party/glm/gtx/extend.inl
-include/solarus/third_party/glm/gtx/extented_min_max.hpp
-include/solarus/third_party/glm/gtx/extented_min_max.inl
-include/solarus/third_party/glm/gtx/fast_exponential.hpp
-include/solarus/third_party/glm/gtx/fast_exponential.inl
-include/solarus/third_party/glm/gtx/fast_square_root.hpp
-include/solarus/third_party/glm/gtx/fast_square_root.inl
-include/solarus/third_party/glm/gtx/fast_trigonometry.hpp
-include/solarus/third_party/glm/gtx/fast_trigonometry.inl
-include/solarus/third_party/glm/gtx/gradient_paint.hpp
-include/solarus/third_party/glm/gtx/gradient_paint.inl
-include/solarus/third_party/glm/gtx/handed_coordinate_space.hpp
-include/solarus/third_party/glm/gtx/handed_coordinate_space.inl
-include/solarus/third_party/glm/gtx/hash.hpp
-include/solarus/third_party/glm/gtx/hash.inl
-include/solarus/third_party/glm/gtx/integer.hpp
-include/solarus/third_party/glm/gtx/integer.inl
-include/solarus/third_party/glm/gtx/intersect.hpp
-include/solarus/third_party/glm/gtx/intersect.inl
-include/solarus/third_party/glm/gtx/io.hpp
-include/solarus/third_party/glm/gtx/io.inl
-include/solarus/third_party/glm/gtx/log_base.hpp
-include/solarus/third_party/glm/gtx/log_base.inl
-include/solarus/third_party/glm/gtx/matrix_cross_product.hpp
-include/solarus/third_party/glm/gtx/matrix_cross_product.inl
-include/solarus/third_party/glm/gtx/matrix_decompose.hpp
-include/solarus/third_party/glm/gtx/matrix_decompose.inl
-include/solarus/third_party/glm/gtx/matrix_interpolation.hpp
-include/solarus/third_party/glm/gtx/matrix_interpolation.inl
-include/solarus/third_party/glm/gtx/matrix_major_storage.hpp
-include/solarus/third_party/glm/gtx/matrix_major_storage.inl
-include/solarus/third_party/glm/gtx/matrix_operation.hpp
-include/solarus/third_party/glm/gtx/matrix_operation.inl
-include/solarus/third_party/glm/gtx/matrix_query.hpp
-include/solarus/third_party/glm/gtx/matrix_query.inl
-include/solarus/third_party/glm/gtx/matrix_transform_2d.hpp
-include/solarus/third_party/glm/gtx/matrix_transform_2d.inl
-include/solarus/third_party/glm/gtx/mixed_product.hpp
-include/solarus/third_party/glm/gtx/mixed_product.inl
-include/solarus/third_party/glm/gtx/norm.hpp
-include/solarus/third_party/glm/gtx/norm.inl
-include/solarus/third_party/glm/gtx/normal.hpp
-include/solarus/third_party/glm/gtx/normal.inl
-include/solarus/third_party/glm/gtx/normalize_dot.hpp
-include/solarus/third_party/glm/gtx/normalize_dot.inl
-include/solarus/third_party/glm/gtx/number_precision.hpp
-include/solarus/third_party/glm/gtx/number_precision.inl
-include/solarus/third_party/glm/gtx/optimum_pow.hpp
-include/solarus/third_party/glm/gtx/optimum_pow.inl
-include/solarus/third_party/glm/gtx/orthonormalize.hpp
-include/solarus/third_party/glm/gtx/orthonormalize.inl
-include/solarus/third_party/glm/gtx/perpendicular.hpp
-include/solarus/third_party/glm/gtx/perpendicular.inl
-include/solarus/third_party/glm/gtx/polar_coordinates.hpp
-include/solarus/third_party/glm/gtx/polar_coordinates.inl
-include/solarus/third_party/glm/gtx/projection.hpp
-include/solarus/third_party/glm/gtx/projection.inl
-include/solarus/third_party/glm/gtx/quaternion.hpp
-include/solarus/third_party/glm/gtx/quaternion.inl
-include/solarus/third_party/glm/gtx/range.hpp
-include/solarus/third_party/glm/gtx/raw_data.hpp
-include/solarus/third_party/glm/gtx/raw_data.inl
-include/solarus/third_party/glm/gtx/rotate_normalized_axis.hpp
-include/solarus/third_party/glm/gtx/rotate_normalized_axis.inl
-include/solarus/third_party/glm/gtx/rotate_vector.hpp
-include/solarus/third_party/glm/gtx/rotate_vector.inl
-include/solarus/third_party/glm/gtx/scalar_multiplication.hpp
-include/solarus/third_party/glm/gtx/scalar_relational.hpp
-include/solarus/third_party/glm/gtx/scalar_relational.inl
-include/solarus/third_party/glm/gtx/simd_mat4.hpp
-include/solarus/third_party/glm/gtx/simd_mat4.inl
-include/solarus/third_party/glm/gtx/simd_quat.hpp
-include/solarus/third_party/glm/gtx/simd_quat.inl
-include/solarus/third_party/glm/gtx/simd_vec4.hpp
-include/solarus/third_party/glm/gtx/simd_vec4.inl
-include/solarus/third_party/glm/gtx/spline.hpp
-include/solarus/third_party/glm/gtx/spline.inl
-include/solarus/third_party/glm/gtx/std_based_type.hpp
-include/solarus/third_party/glm/gtx/std_based_type.inl
-include/solarus/third_party/glm/gtx/string_cast.hpp
-include/solarus/third_party/glm/gtx/string_cast.inl
-include/solarus/third_party/glm/gtx/transform.hpp
-include/solarus/third_party/glm/gtx/transform.inl
-include/solarus/third_party/glm/gtx/transform2.hpp
-include/solarus/third_party/glm/gtx/transform2.inl
-include/solarus/third_party/glm/gtx/type_aligned.hpp
-include/solarus/third_party/glm/gtx/type_aligned.inl
-include/solarus/third_party/glm/gtx/vector_angle.hpp
-include/solarus/third_party/glm/gtx/vector_angle.inl
-include/solarus/third_party/glm/gtx/vector_query.hpp
-include/solarus/third_party/glm/gtx/vector_query.inl
-include/solarus/third_party/glm/gtx/wrap.hpp
-include/solarus/third_party/glm/gtx/wrap.inl
-include/solarus/third_party/glm/integer.hpp
-include/solarus/third_party/glm/mat2x2.hpp
-include/solarus/third_party/glm/mat2x3.hpp
-include/solarus/third_party/glm/mat2x4.hpp
-include/solarus/third_party/glm/mat3x2.hpp
-include/solarus/third_party/glm/mat3x3.hpp
-include/solarus/third_party/glm/mat3x4.hpp
-include/solarus/third_party/glm/mat4x2.hpp
-include/solarus/third_party/glm/mat4x3.hpp
-include/solarus/third_party/glm/mat4x4.hpp
-include/solarus/third_party/glm/matrix.hpp
-include/solarus/third_party/glm/packing.hpp
-include/solarus/third_party/glm/trigonometric.hpp
-include/solarus/third_party/glm/vec2.hpp
-include/solarus/third_party/glm/vec3.hpp
-include/solarus/third_party/glm/vec4.hpp
-include/solarus/third_party/glm/vector_relational.hpp
include/solarus/third_party/hqx/common.h
include/solarus/third_party/hqx/hqx.h
include/solarus/third_party/snes_spc/SNES_SPC.h
@@ -508,19 +254,21 @@ include/solarus/third_party/snes_spc/dsp.h
include/solarus/third_party/snes_spc/spc.h
lib/libsolarus-gui.so
lib/libsolarus-gui.so.1
-lib/libsolarus-gui.so.1.6.2
+lib/libsolarus-gui.so.1.6.4
lib/libsolarus.so
lib/libsolarus.so.1
-lib/libsolarus.so.1.6.2
-share/appdata/solarus.appdata.xml
-share/applications/solarus.desktop
-share/icons/hicolor/128x128/apps/solarus.png
-share/icons/hicolor/16x16/apps/solarus.png
-share/icons/hicolor/24x24/apps/solarus.png
-share/icons/hicolor/256x256/apps/solarus.png
-share/icons/hicolor/32x32/apps/solarus.png
-share/icons/hicolor/48x48/apps/solarus.png
-share/icons/hicolor/512x512/apps/solarus.png
-share/icons/hicolor/64x64/apps/solarus.png
+lib/libsolarus.so.1.6.4
+man/man6/solarus-launcher.6.gz
man/man6/solarus-run.6.gz
-man/man6/solarus.6.gz
+share/appdata/solarus-launcher.appdata.xml
+share/applications/solarus-launcher.desktop
+share/icons/hicolor/16x16/apps/solarus-launcher.png
+share/icons/hicolor/20x20/apps/solarus-launcher.png
+share/icons/hicolor/24x24/apps/solarus-launcher.png
+share/icons/hicolor/32x32/apps/solarus-launcher.png
+share/icons/hicolor/48x48/apps/solarus-launcher.png
+share/icons/hicolor/scalable/apps/solarus-launcher.svg
+share/icons/hicolor/symbolic/apps/solarus-launcher-symbolic.svg
+share/pixmaps/solarus-launcher.png
+%%DATADIR%%-gui/translations/solarus_es.qm
+%%DATADIR%%-gui/translations/solarus_fr.qm