aboutsummaryrefslogtreecommitdiff
path: root/games/speak
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-10 06:31:31 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-10 06:31:31 +0000
commitb8ba0aab09fd58cd558324f1d3da4140bc5640d3 (patch)
treef2e4a404dc51b3cc8ba08976a12353d69acef3d5 /games/speak
parentdd17040118922ff4bd33eb8e75134adc00a2053f (diff)
downloadports-b8ba0aab09fd58cd558324f1d3da4140bc5640d3.tar.gz
ports-b8ba0aab09fd58cd558324f1d3da4140bc5640d3.zip
Stagify the port; fix Makefile header.
Notes
Notes: svn path=/head/; revision=357272
Diffstat (limited to 'games/speak')
-rw-r--r--games/speak/Makefile3
-rw-r--r--games/speak/files/patch-Makefile15
2 files changed, 16 insertions, 2 deletions
diff --git a/games/speak/Makefile b/games/speak/Makefile
index dd7f00dcd8b4..b25e06177565 100644
--- a/games/speak/Makefile
+++ b/games/speak/Makefile
@@ -1,4 +1,4 @@
-# Created by: freebsd@spatula.net
+# Created by: Nicklas Johnson <freebsd@spatula.net>
# $FreeBSD$
PORTNAME= speak
@@ -11,5 +11,4 @@ COMMENT= Generates random middle-management synergy speak
CONFLICTS= espeak-1.[0-9]*
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/speak/files/patch-Makefile b/games/speak/files/patch-Makefile
new file mode 100644
index 000000000000..cc15fb2c8b80
--- /dev/null
+++ b/games/speak/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- Makefile.orig 2000-02-16 03:45:31 +0800
++++ Makefile
+@@ -11,9 +11,9 @@ speak: speak.o
+ ${CC} -o speak speak.o
+
+ install: all
+- ${INSTALL} -c -s -o root -g games -m 755 speak ${BINDIR}
+- ${INSTALL} -d -o root -g games -m 755 ${SPEAKDIR}
+- ${INSTALL} -c -o root -g games -m 644 speak.nouns speak.actions speak.wrk speak.leadins README ${SPEAKDIR}
++ ${INSTALL} -s -m 755 speak ${DESTDIR}${BINDIR}
++ ${INSTALL} -d -m 755 ${DESTDIR}${SPEAKDIR}
++ ${INSTALL} -m 644 speak.nouns speak.actions speak.wrk speak.leadins README ${DESTDIR}${SPEAKDIR}
+
+ clean:
+ rm -f *.core *.o speak