aboutsummaryrefslogtreecommitdiff
path: root/games/species/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-01-30 04:27:43 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-01-30 04:27:43 +0000
commit9ac5382ccbc413b496bcd9c2aeff256755986f94 (patch)
tree1a0123bc0adb5139d925ca7fe9ce4c8ec677b1ea /games/species/Makefile
parent849f4a2e3c2546397ce3d49348d2f6bd35c99382 (diff)
downloadports-9ac5382ccbc413b496bcd9c2aeff256755986f94.tar.gz
ports-9ac5382ccbc413b496bcd9c2aeff256755986f94.zip
Species is a corewars evolver. It is a program to generates corewars warriors
using genetic algorithms. This is the program which generated the best evolved warrior in the recent Multi-Manics corewars competition. Contemporaries include YACE, RedRace, Red Maker and CCAI. Species is definitely the most over-engineered, complicated and buggy Corewars Evolver on the freeware market today! WWW: http://redcoder.sourceforge.net/?p=species
Notes
Notes: svn path=/head/; revision=206430
Diffstat (limited to 'games/species/Makefile')
-rw-r--r--games/species/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/games/species/Makefile b/games/species/Makefile
new file mode 100644
index 000000000000..fd7a776ef77d
--- /dev/null
+++ b/games/species/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: species
+# Date created: 2008-01-15
+# Whom: alepulver
+#
+# $FreeBSD$
+#
+
+PORTNAME= species
+PORTVERSION= 1.2d
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= alepulver
+DISTNAME= redcoder
+
+MAINTAINER= alepulver@FreeBSD.org
+COMMENT= Corewars evolver - generates warriors using genetic algorithms
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+OPTIONS= VISITOOL "Buil GUI tool for displaying evolution" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_VISITOOL)
+USE_WX= 2.4
+ALL_TARGET= all visitool
+PLIST_SUB+= VISITOOL=""
+.else
+PLIST_SUB+= VISITOOL="@comment "
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} koen.* species.ini *.rc ${DATADIR}
+ cd ${WRKSRC} && ${CP} -r bench evolver_hill wilfiz ${DATADIR}
+.if defined(WITH_VISITOOL)
+ ${INSTALL_PROGRAM} ${WRKSRC}/visitool \
+ ${PREFIX}/bin/${PORTNAME}-visitool
+.endif
+
+.include <bsd.port.post.mk>