aboutsummaryrefslogtreecommitdiff
path: root/games/speyes
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-26 22:38:45 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-26 22:38:45 +0000
commit30ae16bebec6fc5c3ae1e28f86c63c83ba3e50e7 (patch)
treef5b84f9c167d328a091386dd6fb757765d8b96d0 /games/speyes
parent0d8aabec62371ef198d3542084c563c40a1a449e (diff)
downloadports-30ae16bebec6fc5c3ae1e28f86c63c83ba3e50e7.tar.gz
ports-30ae16bebec6fc5c3ae1e28f86c63c83ba3e50e7.zip
* Update to 1.2.0
* Pass CFLAGS to build properly * Remove libgnugetopt dependency (getopt.c/getopt1.c now included) PR: 15103 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=23421
Diffstat (limited to 'games/speyes')
-rw-r--r--games/speyes/Makefile11
-rw-r--r--games/speyes/distinfo2
-rw-r--r--games/speyes/files/patch-aa15
3 files changed, 11 insertions, 17 deletions
diff --git a/games/speyes/Makefile b/games/speyes/Makefile
index 5f54de127cf1..50a61ce3d6a4 100644
--- a/games/speyes/Makefile
+++ b/games/speyes/Makefile
@@ -1,26 +1,23 @@
# New ports collection makefile for: speyes
-# Version required: 1.0.0
+# Version required: 1.2.0
# Date created: 03 November 1999
# Whom: Chris D. Faulhaber <jedgar@fxp.org>
#
# $FreeBSD$
#
-DISTNAME= speyes-1.0.0
+DISTNAME= speyes-1.2.0
CATEGORIES= games
MASTER_SITES= http://www.halcyon.com/amalmin/speyes/
MAINTAINER= jedgar@fxp.org
-LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
- gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
NO_INSTALL_MANPAGES= yes
USE_IMAKE= yes
pre-configure:
- @${MV} ${WRKSRC}/Imakefile ${WRKSRC}/Imakefile.orig
- @${SED} -e 's|LOCALBASE|${LOCALBASE}|' \
- < ${WRKSRC}/Imakefile.orig > ${WRKSRC}/Imakefile
+ @${PERL} -pi.orig -e 's:__CFLAGS__:${CFLAGS}:g' ${WRKSRC}/Imakefile
.include <bsd.port.mk>
diff --git a/games/speyes/distinfo b/games/speyes/distinfo
index 33aaa577e435..66e7d785eee1 100644
--- a/games/speyes/distinfo
+++ b/games/speyes/distinfo
@@ -1 +1 @@
-MD5 (speyes-1.0.0.tar.gz) = 1fe85518efebceb559ca62c3e4ee2408
+MD5 (speyes-1.2.0.tar.gz) = 9b287dc3d074886772aea4af7531a6d2
diff --git a/games/speyes/files/patch-aa b/games/speyes/files/patch-aa
index 8fa3e8c9434c..502d44393159 100644
--- a/games/speyes/files/patch-aa
+++ b/games/speyes/files/patch-aa
@@ -1,13 +1,10 @@
---- Imakefile.orig Sat Oct 30 00:31:02 1999
-+++ Imakefile Wed Nov 3 08:28:28 1999
-@@ -2,7 +2,9 @@
-
+--- Imakefile.orig Thu Nov 4 19:43:09 1999
++++ Imakefile Fri Nov 26 17:17:54 1999
+@@ -4,6 +4,7 @@
SYS_LIBRARIES = MathLibrary
DEPLIBS = $(DEPXMULIB) $(DEPXTOOLLIB) $(DEPXLIB)
--LOCAL_LIBRARIES = $(XMULIB) $(XTOOLLIB) $(XLIB) $(XPMLIB)
-+LOCAL_LIBRARIES = $(XMULIB) $(XTOOLLIB) $(XLIB) $(XPMLIB) -lgnugetopt
-+EXTRA_INCLUDES = -ILOCALBASE/include
-+LOCAL_LDFLAGS = -LLOCALBASE/lib
+ LOCAL_LIBRARIES = $(XMULIB) $(XTOOLLIB) $(XLIB) $(XPMLIB)
++CDEBUGFLAGS = __CFLAGS__
SRCS = speyes.c
- OBJS = speyes.o
+ OBJS = speyes.o getopt.o getopt1.o