aboutsummaryrefslogtreecommitdiff
path: root/games/speyes
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-11-26 19:23:25 +0000
committerSteve Price <steve@FreeBSD.org>1999-11-26 19:23:25 +0000
commit762f2e27773501b7526add6edc8c69ba8eed375c (patch)
tree67f07be8a7408505e02952572283ab345af172ae /games/speyes
parent04c0b3aa720118b5432113c45f4cc947ae87abef (diff)
downloadports-762f2e27773501b7526add6edc8c69ba8eed375c.tar.gz
ports-762f2e27773501b7526add6edc8c69ba8eed375c.zip
Intitial import of speyes version 1.0.0.
A WindowMaker dockapp/xeyes clone using SouthPark characters. PR: 14683 Submitted by: Chris D. Faulhaber <jedgar@fxp.org>
Notes
Notes: svn path=/head/; revision=23382
Diffstat (limited to 'games/speyes')
-rw-r--r--games/speyes/Makefile26
-rw-r--r--games/speyes/distinfo1
-rw-r--r--games/speyes/files/patch-aa13
-rw-r--r--games/speyes/pkg-comment1
-rw-r--r--games/speyes/pkg-descr7
-rw-r--r--games/speyes/pkg-plist1
6 files changed, 49 insertions, 0 deletions
diff --git a/games/speyes/Makefile b/games/speyes/Makefile
new file mode 100644
index 000000000000..5f54de127cf1
--- /dev/null
+++ b/games/speyes/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: speyes
+# Version required: 1.0.0
+# Date created: 03 November 1999
+# Whom: Chris D. Faulhaber <jedgar@fxp.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= speyes-1.0.0
+CATEGORIES= games
+MASTER_SITES= http://www.halcyon.com/amalmin/speyes/
+
+MAINTAINER= jedgar@fxp.org
+
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+NO_INSTALL_MANPAGES= yes
+USE_IMAKE= yes
+
+pre-configure:
+ @${MV} ${WRKSRC}/Imakefile ${WRKSRC}/Imakefile.orig
+ @${SED} -e 's|LOCALBASE|${LOCALBASE}|' \
+ < ${WRKSRC}/Imakefile.orig > ${WRKSRC}/Imakefile
+
+.include <bsd.port.mk>
diff --git a/games/speyes/distinfo b/games/speyes/distinfo
new file mode 100644
index 000000000000..33aaa577e435
--- /dev/null
+++ b/games/speyes/distinfo
@@ -0,0 +1 @@
+MD5 (speyes-1.0.0.tar.gz) = 1fe85518efebceb559ca62c3e4ee2408
diff --git a/games/speyes/files/patch-aa b/games/speyes/files/patch-aa
new file mode 100644
index 000000000000..8fa3e8c9434c
--- /dev/null
+++ b/games/speyes/files/patch-aa
@@ -0,0 +1,13 @@
+--- Imakefile.orig Sat Oct 30 00:31:02 1999
++++ Imakefile Wed Nov 3 08:28:28 1999
+@@ -2,7 +2,9 @@
+
+ SYS_LIBRARIES = MathLibrary
+ DEPLIBS = $(DEPXMULIB) $(DEPXTOOLLIB) $(DEPXLIB)
+-LOCAL_LIBRARIES = $(XMULIB) $(XTOOLLIB) $(XLIB) $(XPMLIB)
++LOCAL_LIBRARIES = $(XMULIB) $(XTOOLLIB) $(XLIB) $(XPMLIB) -lgnugetopt
++EXTRA_INCLUDES = -ILOCALBASE/include
++LOCAL_LDFLAGS = -LLOCALBASE/lib
+
+ SRCS = speyes.c
+ OBJS = speyes.o
diff --git a/games/speyes/pkg-comment b/games/speyes/pkg-comment
new file mode 100644
index 000000000000..6090e902687b
--- /dev/null
+++ b/games/speyes/pkg-comment
@@ -0,0 +1 @@
+WindowMaker dockapp/xeyes clone using SouthPark characters
diff --git a/games/speyes/pkg-descr b/games/speyes/pkg-descr
new file mode 100644
index 000000000000..719fc6a343f0
--- /dev/null
+++ b/games/speyes/pkg-descr
@@ -0,0 +1,7 @@
+speyes is a WindowMaker dock app that features the
+SouthPark characters ala xeyes.
+
+WWW: http://www.halcyon.com/amalmin/speyes/speyes.html
+
+-Chris D. Faulhaber
+jedgar@fxp.org
diff --git a/games/speyes/pkg-plist b/games/speyes/pkg-plist
new file mode 100644
index 000000000000..68be375194f7
--- /dev/null
+++ b/games/speyes/pkg-plist
@@ -0,0 +1 @@
+bin/speyes