aboutsummaryrefslogtreecommitdiff
path: root/games/starfighter
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-11-17 09:52:53 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-11-17 09:52:53 +0000
commita949de6d274a8b1ac965b463d6fecc81ab38d262 (patch)
tree4dbebf62c70c185b2cb2e6c162c49b0bf04fd800 /games/starfighter
parent4c630e14270b28609da8a261079ca89205fdcde3 (diff)
downloadports-a949de6d274a8b1ac965b463d6fecc81ab38d262.tar.gz
ports-a949de6d274a8b1ac965b463d6fecc81ab38d262.zip
(Readdition of games/starfighter which was removed on 218872)
Project: Starfighter is an old school 2D shoot 'em up. In the game you take on the role of a rebel pilot called Chris, who is attempting to overthrow a military corporation called Weapco. Weapco has seized control of the known universe and currently rules it with an iron fist. Chris can no longer stand back and watch as millions of people suffer and die. He steals an experimental craft known as "Firefly" and begins his mission to fight his way to Sol, freeing key systems along the way. The game opens with Chris attempting to escape a Weapco patrol that has intercepted him. WWW: http://sourceforge.net/projects/pr-starfighter/ PR: ports/173494 Submitted by: nemysis <nemysis@gmx.ch> Feature safe: yes
Notes
Notes: svn path=/head/; revision=307500
Diffstat (limited to 'games/starfighter')
-rw-r--r--games/starfighter/Makefile52
-rw-r--r--games/starfighter/distinfo4
-rw-r--r--games/starfighter/pkg-descr10
-rw-r--r--games/starfighter/pkg-plist6
4 files changed, 72 insertions, 0 deletions
diff --git a/games/starfighter/Makefile b/games/starfighter/Makefile
new file mode 100644
index 000000000000..f97b241cf665
--- /dev/null
+++ b/games/starfighter/Makefile
@@ -0,0 +1,52 @@
+# Created by nemysis@gmx.ch
+# $FreeBSD$
+
+PORTNAME= starfighter
+PORTVERSION= 1.2
+CATEGORIES= games
+MASTER_SITES= SF/pr-${PORTNAME}/ \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}.png:icons
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Liberate the universe from the evil company WEAPCO
+
+LICENSE= GPLv2
+
+USE_GMAKE= yes
+USE_ICONV= yes
+USE_XORG= x11 xau xdmcp
+USE_SDL= image mixer
+WITH_ZLIB= yes
+
+INSTALLS_ICONS= yes
+
+DESKTOP_ENTRIES="Project Starfighter" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Game;ArcadeGame;" ${FALSE}
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's| -O2 -Wall|${CXXFLAGS}|' \
+ -e 's|docs/\*|docs/index.html|' \
+ -e 's|/usr|${LOCALBASE}|' \
+ -e 's|$$(PREFIX)/games/|$$(PREFIX)/bin/|' \
+ -e 's|/share/games/parallelrealities/|/share/starfighter/|' \
+ ${WRKSRC}/makefile
+
+.if !${PORT_OPTIONS:MDOCS}
+ @${REINPLACE_CMD} -i '' -e '/$$(DESTDIR)$$(DOCDIR)/d' ${WRKSRC}/makefile
+.endif
+ @(cd ${WRKSRC} && ${CP} makefile Makefile)
+
+do-build:
+ @(cd ${WRKSRC} && ${GMAKE})
+
+post-install:
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
+
+.include <bsd.port.mk>
diff --git a/games/starfighter/distinfo b/games/starfighter/distinfo
new file mode 100644
index 000000000000..0a5dcc6fe57f
--- /dev/null
+++ b/games/starfighter/distinfo
@@ -0,0 +1,4 @@
+SHA256 (starfighter/starfighter-1.2.tar.gz) = d2e05e45bbc49cbe4f597e0db715fdf64e2aa771f1c77d5055d9db9d5e32fd5e
+SIZE (starfighter/starfighter-1.2.tar.gz) = 1233548
+SHA256 (starfighter/starfighter.png) = 7e6b0ccb71b5f52c96044db7b063f61f862c87fe3d7405fa6e521d335638c53b
+SIZE (starfighter/starfighter.png) = 1203
diff --git a/games/starfighter/pkg-descr b/games/starfighter/pkg-descr
new file mode 100644
index 000000000000..b28aa019d580
--- /dev/null
+++ b/games/starfighter/pkg-descr
@@ -0,0 +1,10 @@
+Project: Starfighter is an old school 2D shoot 'em up. In the game you take on
+the role of a rebel pilot called Chris, who is attempting to overthrow a
+military corporation called Weapco. Weapco has seized control of the known
+universe and currently rules it with an iron fist. Chris can no longer stand
+back and watch as millions of people suffer and die. He steals an experimental
+craft known as "Firefly" and begins his mission to fight his way to Sol,
+freeing key systems along the way. The game opens with Chris attempting to
+escape a Weapco patrol that has intercepted him.
+
+WWW: http://sourceforge.net/projects/pr-starfighter/
diff --git a/games/starfighter/pkg-plist b/games/starfighter/pkg-plist
new file mode 100644
index 000000000000..847948014d9a
--- /dev/null
+++ b/games/starfighter/pkg-plist
@@ -0,0 +1,6 @@
+bin/starfighter
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+share/pixmaps/starfighter.png
+%%DATADIR%%/starfighter.pak
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%