aboutsummaryrefslogtreecommitdiff
path: root/games/starfighter
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-12-15 13:28:38 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-12-15 13:28:38 +0000
commitc410082fc9b130cfbf6ce46b68c8755a613690fa (patch)
tree20f5411b11793496d81cc545cd6b2b2c22fe29e2 /games/starfighter
parentf05c29d1afa989903fdf9ac486ccac27a29e355d (diff)
downloadports-c410082fc9b130cfbf6ce46b68c8755a613690fa.tar.gz
ports-c410082fc9b130cfbf6ce46b68c8755a613690fa.zip
- Fix the usage of 'python' to get rid of the implicit lang/python
dependency Reported by: exp-run (PR 184591) Approved by: portmgr (blanket)
Notes
Notes: svn path=/head/; revision=336529
Diffstat (limited to 'games/starfighter')
-rw-r--r--games/starfighter/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/games/starfighter/Makefile b/games/starfighter/Makefile
index 3cb7bb64dc8e..8df7b290d752 100644
--- a/games/starfighter/Makefile
+++ b/games/starfighter/Makefile
@@ -17,12 +17,17 @@ COMMENT= Liberate the universe from the evil company WEAPCO
LICENSE= GPLv2
-USES= gmake iconv
+USES= gmake iconv shebangfix
+USE_PYTHON_BUILD= -2.7
USE_XORG= x11 xau xdmcp
USE_SDL= image mixer
WITH_ZLIB= yes
MAKEFILE= makefile
+SHEBANG_FILES= pack.py unpack.py
+python_OLD_CMD= ${SETENV} python
+python_CMD= ${PYTHON_CMD}
+
INSTALLS_ICONS= yes
PLIST_FILES= bin/${PORTNAME} \