aboutsummaryrefslogtreecommitdiff
path: root/games/stratagus
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-11-22 23:36:47 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-11-22 23:36:47 +0000
commit5f38767fb1eccc4dc7e3656c76e84fc4e78c4b62 (patch)
tree712794e6880d88e141da55a709e8a5ce1e86b9f9 /games/stratagus
parent857f685df1fe493ffcbc0444c5267bc771d5d18b (diff)
downloadports-5f38767fb1eccc4dc7e3656c76e84fc4e78c4b62.tar.gz
ports-5f38767fb1eccc4dc7e3656c76e84fc4e78c4b62.zip
- Update to 2.4.2
Notes
Notes: svn path=/head/; revision=518173
Diffstat (limited to 'games/stratagus')
-rw-r--r--games/stratagus/Makefile13
-rw-r--r--games/stratagus/distinfo6
-rw-r--r--games/stratagus/files/patch-src_ai_ai__plan.cpp11
-rw-r--r--games/stratagus/files/patch-src_stratagus_script.cpp20
-rw-r--r--games/stratagus/pkg-plist4
5 files changed, 14 insertions, 40 deletions
diff --git a/games/stratagus/Makefile b/games/stratagus/Makefile
index 578fba760eee..e21e4119e724 100644
--- a/games/stratagus/Makefile
+++ b/games/stratagus/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= stratagus
-PORTVERSION= 2.4.1
+PORTVERSION= 2.4.2
DISTVERSIONPREFIX= v
-PORTREVISION= 6
CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
@@ -19,14 +18,14 @@ LIB_DEPENDS= libpng.so:graphics/png \
USE_GITHUB= yes
GH_ACCOUNT= Wargus
-USES= cmake compiler:c++11-lang gl lua:51 pkgconfig sdl sqlite
+USES= cmake compiler:c++11-lang gl lua:51 pkgconfig sdl sqlite python:run
USE_GL= gl glu
USE_SDL= sdl
CMAKE_ARGS= -DGAMEDIR:STRING="bin" \
-DTOLUA++_APP:STRING="tolua++-${LUA_VER}" \
-DTOLUA++_INCLUDE_DIR:STRING="${LUA_INCDIR}" \
- -DTOLUA++_LIBRARY:STRING="${LUA_LIBDIR}/libtolua++.so" \
- -DENABLE_DEV:BOOL=ON
+ -DTOLUA++_LIBRARY:STRING="${LUA_LIBDIR}/libtolua++.so"
+CMAKE_ON= ENABLE_DEV
CXXFLAGS+= -Wno-c++11-narrowing
@@ -57,6 +56,10 @@ X11_CMAKE_BOOL= WITH_X11
FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
FLUIDSYNTH_CMAKE_BOOL= WITH_FLUIDSYNTH
+post-patch:
+ @${REINPLACE_CMD} -e 's|"python"|"${PYTHON_CMD}"|' \
+ ${WRKSRC}/gameheaders/stratagus-tinyfiledialogs.h
+
post-install:
${INSTALL_DATA} ${WRKSRC}/doc/stratagus.6 ${STAGEDIR}${MAN6PREFIX}/man/man6
diff --git a/games/stratagus/distinfo b/games/stratagus/distinfo
index 0b2f85676f6a..037e96ccb24b 100644
--- a/games/stratagus/distinfo
+++ b/games/stratagus/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1491831354
-SHA256 (Wargus-stratagus-v2.4.1_GH0.tar.gz) = 4f77d0e3cb09c6322a9d5576b55bc2eb498e041a4d77c79dfc3a9b5612913788
-SIZE (Wargus-stratagus-v2.4.1_GH0.tar.gz) = 1087678
+TIMESTAMP = 1538587339
+SHA256 (Wargus-stratagus-v2.4.2_GH0.tar.gz) = 366be8255c7e7cb694661b5db08b81908885a8ff89007d6e24769bf619235b89
+SIZE (Wargus-stratagus-v2.4.2_GH0.tar.gz) = 1114717
diff --git a/games/stratagus/files/patch-src_ai_ai__plan.cpp b/games/stratagus/files/patch-src_ai_ai__plan.cpp
deleted file mode 100644
index cfebe2d31a1b..000000000000
--- a/games/stratagus/files/patch-src_ai_ai__plan.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/ai/ai_plan.cpp.orig 2016-11-08 14:38:09 UTC
-+++ src/ai/ai_plan.cpp
-@@ -343,7 +343,7 @@ int GetTotalBoardCapacity(ITERATOR begin
- int AiForce::PlanAttack()
- {
- CPlayer &player = *AiPlayer->Player;
-- DebugPrint("%d: Planning for force #%lu of player #%d\n"_C_ player.Index
-+ DebugPrint("%d: Planning for force #%lu of player #%d\n" _C_ player.Index
- _C_(long unsigned int)(this - & (AiPlayer->Force[0])) _C_ player.Index);
-
- TerrainTraversal transporterTerrainTraversal;
diff --git a/games/stratagus/files/patch-src_stratagus_script.cpp b/games/stratagus/files/patch-src_stratagus_script.cpp
deleted file mode 100644
index 823e140e209d..000000000000
--- a/games/stratagus/files/patch-src_stratagus_script.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/stratagus/script.cpp.orig 2016-11-08 14:38:09 UTC
-+++ src/stratagus/script.cpp
-@@ -767,7 +767,7 @@ NumberDesc *CclParseNumberDesc(lua_State
- lua_pop(l, 1); // table.
- } else {
- lua_pop(l, 1);
-- LuaError(l, "unknow condition '%s'"_C_ key);
-+ LuaError(l, "unknow condition '%s'" _C_ key);
- }
- } else {
- LuaError(l, "Parse Error in ParseNumber");
-@@ -881,7 +881,7 @@ StringDesc *CclParseStringDesc(lua_State
- res->D.PlayerName = CclParseNumberDesc(l);
- } else {
- lua_pop(l, 1);
-- LuaError(l, "unknow condition '%s'"_C_ key);
-+ LuaError(l, "unknow condition '%s'" _C_ key);
- }
- } else {
- LuaError(l, "Parse Error in ParseString");
diff --git a/games/stratagus/pkg-plist b/games/stratagus/pkg-plist
index 806e0a12ca40..324b896e8ecf 100644
--- a/games/stratagus/pkg-plist
+++ b/games/stratagus/pkg-plist
@@ -1,7 +1,9 @@
bin/png2stratagus
+bin/metaserver
bin/stratagus
@comment include/stratagus-game-installer.nsi
include/stratagus-game-launcher.h
+include/stratagus-gameutils.h
+include/stratagus-tinyfiledialogs.h
@comment include/stratagus-maemo-extract.h
man/man6/stratagus.6.gz
-sbin/metaserver