aboutsummaryrefslogtreecommitdiff
path: root/games/super_methane_brothers
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-24 14:37:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-24 14:37:16 +0000
commit4fbf31e94a3afa45f384b4721921920359379dcf (patch)
tree12bd2c022875765d0d814e4726d85712e54909db /games/super_methane_brothers
parent5585ed9413fb742892a268c8040c5b48bd95ad2c (diff)
downloadports-4fbf31e94a3afa45f384b4721921920359379dcf.tar.gz
ports-4fbf31e94a3afa45f384b4721921920359379dcf.zip
Add super_methane_brothers.
Puff and Blow each have a Methane Gas Gun which fires a cloud of immobilising gas. If this comes into contact with a bad guy he will be absorbed into the gas and then float around the screen for a limited time. Bad guys are harmless in this state. Puff and Blow must suck the floating gas clouds into their guns and blast them out against a vertical surface. Bad guys then turn into bonuses which can be collected. Be warned! - the gas cloud dissolves with time after which baddies become active again and extremely annoyed. WWW: http://www.methane.fsnet.co.uk/ PR: ports/61743 Submitted by: Jean-Yves Lefort <jylefort@brutele.be>
Notes
Notes: svn path=/head/; revision=98963
Diffstat (limited to 'games/super_methane_brothers')
-rw-r--r--games/super_methane_brothers/Makefile63
-rw-r--r--games/super_methane_brothers/distinfo1
-rw-r--r--games/super_methane_brothers/files/patch-source::linux::makefile49
-rw-r--r--games/super_methane_brothers/pkg-descr13
-rw-r--r--games/super_methane_brothers/pkg-plist23
5 files changed, 149 insertions, 0 deletions
diff --git a/games/super_methane_brothers/Makefile b/games/super_methane_brothers/Makefile
new file mode 100644
index 000000000000..28d2bca11ec3
--- /dev/null
+++ b/games/super_methane_brothers/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: Super Methane Brothers
+# Date created: 22 Jan 2004
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= super_methane_brothers
+PORTVERSION= 1.4.6
+CATEGORIES= games
+MASTER_SITES= http://www.methane.fsnet.co.uk/
+DISTNAME= methane
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A port of the Amiga platform game of the same name
+
+LIB_DEPENDS= clanCore.2:${PORTSDIR}/devel/clanlib \
+ mikmod:${PORTSDIR}/audio/libmikmod
+
+WRKSRC= ${WRKDIR}/${DISTNAME}-${PORTVERSION}
+BUILD_WRKSRC= ${WRKSRC}/source/linux
+MAKEFILE= makefile
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+
+MAKE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} \
+ PTHREAD_LIBS=${PTHREAD_LIBS}
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/methane ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} \
+ ${WRKSRC}/authors \
+ ${WRKSRC}/history \
+ ${WRKSRC}/readme \
+ ${WRKSRC}/todo \
+ ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/html
+ ${INSTALL_DATA} \
+ ${WRKSRC}/docs/block.gif \
+ ${WRKSRC}/docs/bug.gif \
+ ${WRKSRC}/docs/cookie.gif \
+ ${WRKSRC}/docs/gamepic.gif \
+ ${WRKSRC}/docs/gen.gif \
+ ${WRKSRC}/docs/info.htm \
+ ${WRKSRC}/docs/mbug.gif \
+ ${WRKSRC}/docs/potion.gif \
+ ${WRKSRC}/docs/puff.gif \
+ ${WRKSRC}/docs/spike.gif \
+ ${WRKSRC}/docs/spring.gif \
+ ${WRKSRC}/docs/sucker.gif \
+ ${WRKSRC}/docs/title.gif \
+ ${WRKSRC}/docs/turbo.gif \
+ ${WRKSRC}/docs/whirly.gif \
+ ${WRKSRC}/docs/zoom.gif \
+ ${DOCSDIR}/html
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/super_methane_brothers/distinfo b/games/super_methane_brothers/distinfo
new file mode 100644
index 000000000000..4dd7424f2c62
--- /dev/null
+++ b/games/super_methane_brothers/distinfo
@@ -0,0 +1 @@
+MD5 (methane.tgz) = fac55b79e9beb84fb2c1508b7a6b4964
diff --git a/games/super_methane_brothers/files/patch-source::linux::makefile b/games/super_methane_brothers/files/patch-source::linux::makefile
new file mode 100644
index 000000000000..7591aab31a9f
--- /dev/null
+++ b/games/super_methane_brothers/files/patch-source::linux::makefile
@@ -0,0 +1,49 @@
+--- source/linux/makefile.orig Thu Jan 22 17:22:08 2004
++++ source/linux/makefile Thu Jan 22 17:40:13 2004
+@@ -1,7 +1,7 @@
+
+ # Comment out the two lines shown below to disable sound
+-MIKMOD_LIBS = `libmikmod-config --cflags` `libmikmod-config --libs`
+-METHANE_FLAGS = -DMETHANE_MIKMOD
++MIKMOD_LIBS = `libmikmod-config --libs`
++METHANE_FLAGS = -DMETHANE_MIKMOD -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+
+ all: message methane
+
+@@ -22,7 +22,7 @@
+ MainSource/misc.o MainSource/objlist.o MainSource/player.o MainSource/power.o MainSource/target.o \
+ MainSource/suck.o MainSource/weapon.o MainSource/sound.o MainData/snddata.o MainData/gfxdata.o MainData/gfxdata2.o \
+ MainData/gfxdata3.o MainData/mapdata.o MainLinux/font32.o MainLinux/doc.o MainLinux/main.o MainMikMod/audiodrv.o \
+- -o methane -lclanCore -lclanApp -lclanDisplay ${MIKMOD_LIBS}
++ -o methane -L${LOCALBASE}/lib -lclanCore -lclanApp -lclanDisplay ${MIKMOD_LIBS} ${PTHREAD_LIBS}
+
+ clean:
+ @rm -Rf MainSource
+@@ -38,23 +38,23 @@
+ MainSource/%.o : ../%.cpp
+ @echo " Compiling $<..."
+ @if [ ! -d MainSource ]; then mkdir MainSource; fi
+- gcc ${CXXFLAGS} ${METHANE_FLAGS} -I ../linux `libmikmod-config --cflags` -c $< -o $@
++ ${CXX} ${CXXFLAGS} ${METHANE_FLAGS} -I ../linux `libmikmod-config --cflags` -c $< -o $@
+
+ # The main data
+ MainData/%.o : ../data/%.cpp
+ @echo " Compiling $<..."
+ @if [ ! -d MainData ]; then mkdir MainData; fi
+- gcc ${CXXFLAGS} ${METHANE_FLAGS} -I ../ `libmikmod-config --cflags` -c $< -o $@
++ ${CXX} ${CXXFLAGS} ${METHANE_FLAGS} -I ../ `libmikmod-config --cflags` -c $< -o $@
+
+ # The linux source code
+ MainLinux/%.o : ../linux/%.cpp
+ @echo " Compiling $<..."
+ @if [ ! -d MainLinux ]; then mkdir MainLinux; fi
+- gcc ${CXXFLAGS} ${METHANE_FLAGS} -I ../ `libmikmod-config --cflags` -c $< -o $@
++ ${CXX} ${CXXFLAGS} ${METHANE_FLAGS} -I ../ `libmikmod-config --cflags` -c $< -o $@
+
+ # The sound driver source code
+ MainMikMod/%.o : ../mikmod/%.cpp
+ @echo " Compiling $<..."
+ @if [ ! -d MainMikMod ]; then mkdir MainMikMod; fi
+- gcc ${CXXFLAGS} ${METHANE_FLAGS} -I ../ `libmikmod-config --cflags` -c $< -o $@
++ ${CXX} ${CXXFLAGS} ${METHANE_FLAGS} -I ../ `libmikmod-config --cflags` -c $< -o $@
+
diff --git a/games/super_methane_brothers/pkg-descr b/games/super_methane_brothers/pkg-descr
new file mode 100644
index 000000000000..ba0adbcafd17
--- /dev/null
+++ b/games/super_methane_brothers/pkg-descr
@@ -0,0 +1,13 @@
+Puff and Blow each have a Methane Gas Gun which fires a cloud of
+immobilising gas. If this comes into contact with a bad guy he will be
+absorbed into the gas and then float around the screen for a limited
+time. Bad guys are harmless in this state. Puff and Blow must suck the
+floating gas clouds into their guns and blast them out against a
+vertical surface. Bad guys then turn into bonuses which can be
+collected. Be warned! - the gas cloud dissolves with time after which
+baddies become active again and extremely annoyed.
+
+WWW: http://www.methane.fsnet.co.uk/
+
+- Jean-Yves Lefort
+jylefort@brutele.be
diff --git a/games/super_methane_brothers/pkg-plist b/games/super_methane_brothers/pkg-plist
new file mode 100644
index 000000000000..4cb40c233684
--- /dev/null
+++ b/games/super_methane_brothers/pkg-plist
@@ -0,0 +1,23 @@
+bin/methane
+%%PORTDOCS%%share/doc/super_methane_brothers/authors
+%%PORTDOCS%%share/doc/super_methane_brothers/history
+%%PORTDOCS%%share/doc/super_methane_brothers/html/block.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/html/bug.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/html/cookie.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/html/gamepic.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/html/gen.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/html/info.htm
+%%PORTDOCS%%share/doc/super_methane_brothers/html/mbug.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/html/potion.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/html/puff.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/html/spike.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/html/spring.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/html/sucker.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/html/title.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/html/turbo.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/html/whirly.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/html/zoom.gif
+%%PORTDOCS%%share/doc/super_methane_brothers/readme
+%%PORTDOCS%%share/doc/super_methane_brothers/todo
+%%PORTDOCS%%@dirrm share/doc/super_methane_brothers/html
+%%PORTDOCS%%@dirrm share/doc/super_methane_brothers