aboutsummaryrefslogtreecommitdiff
path: root/games/supertux-devel/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-09-11 13:16:43 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-09-11 13:16:43 +0000
commit6642bab72491008958c6da278af0e137a5ed32ae (patch)
treee7847ae0f034123ddf1839ab7d3babcd00da2c59 /games/supertux-devel/Makefile
parent3a5c87425fbf975b355be1c9d2a26faa8367c672 (diff)
downloadports-6642bab72491008958c6da278af0e137a5ed32ae.tar.gz
ports-6642bab72491008958c6da278af0e137a5ed32ae.zip
- Update to 0.3.3 (development snapshot)
- Update description and follow upstream naming - SuperTux
Notes
Notes: svn path=/head/; revision=304093
Diffstat (limited to 'games/supertux-devel/Makefile')
-rw-r--r--games/supertux-devel/Makefile32
1 files changed, 17 insertions, 15 deletions
diff --git a/games/supertux-devel/Makefile b/games/supertux-devel/Makefile
index aa16169cf435..1c2584701e3a 100644
--- a/games/supertux-devel/Makefile
+++ b/games/supertux-devel/Makefile
@@ -1,28 +1,30 @@
-# New ports collection makefile for: supertux
-# Date created: 2004-04-17
-# Whom: michael johnson <ahze@ahze.net>
-#
# $FreeBSD$
-#
PORTNAME= supertux
-PORTVERSION= 0.1.3
-PORTREVISION= 9
+PORTVERSION= 0.3.3
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_BERLIOS}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMESUFFIX= -devel
MAINTAINER= makc@FreeBSD.org
-COMMENT= Super Tux is a side-scroller similar to Super Mario Brothers
+COMMENT= SuperTux is a side-scroller similar to Super Mario Brothers
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/smart_ptr.hpp:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= physfs.1:${PORTSDIR}/devel/physfs \
+ curl.6:${PORTSDIR}/ftp/curl \
+ vorbis.4:${PORTSDIR}/audio/libvorbis
USE_BZIP2= yes
USE_SDL= image mixer
-USE_GL= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-debug
+USE_OPENAL= al
+USE_GL= glew
+USE_CMAKE= yes
+MAKE_JOBS_SAFE= yes
post-patch:
- @${REINPLACE_CMD} -e 's,Menu::,,' ${WRKSRC}/src/menu.h
+ ${REINPLACE_CMD} -e '/^#.*<curl\/types.h>/d' \
+ ${WRKSRC}/src/addon/addon_manager.cpp
+ ${REINPLACE_CMD} -e '/^Icon=/s,supertux.png,supertux2.png,' \
+ ${WRKSRC}/supertux2.desktop
.include <bsd.port.mk>