aboutsummaryrefslogtreecommitdiff
path: root/games/supertuxkart/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2020-09-27 23:17:21 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2020-09-27 23:17:21 +0000
commit470470d3e457cc3064a7532db68c9c02d1d0ca02 (patch)
treed85dd50882d1a6b7f83cafc66f9f8124a7b49a7f /games/supertuxkart/Makefile
parent36c1b51f11d546452e2ea2c8309a0997d9a069e4 (diff)
downloadports-470470d3e457cc3064a7532db68c9c02d1d0ca02.tar.gz
ports-470470d3e457cc3064a7532db68c9c02d1d0ca02.zip
- Update to 1.2
Notes
Notes: svn path=/head/; revision=550383
Diffstat (limited to 'games/supertuxkart/Makefile')
-rw-r--r--games/supertuxkart/Makefile52
1 files changed, 23 insertions, 29 deletions
diff --git a/games/supertuxkart/Makefile b/games/supertuxkart/Makefile
index 39097a72f940..cbc4a43bbd03 100644
--- a/games/supertuxkart/Makefile
+++ b/games/supertuxkart/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= supertuxkart
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.2
CATEGORIES= games
MASTER_SITES= SF/supertuxkart/SuperTuxKart/${PORTVERSION}
-DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+DISTNAME= SuperTuxKart-${PORTVERSION}-src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Free 3D kart racing game
@@ -14,25 +13,16 @@ COMMENT= Free 3D kart racing game
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
- libogg.so:audio/libogg \
- libcurl.so:ftp/curl \
- libpng.so:graphics/png \
- libfreetype.so:print/freetype2 \
- libharfbuzz.so:print/harfbuzz \
- libfribidi.so:converters/fribidi \
- libraqm.so:print/libraqm \
- libsqlite3.so:databases/sqlite3
+LIB_DEPENDS= libsqlite3.so:databases/sqlite3 \
+ libcurl.so:ftp/curl
-BROKEN_i386= does not build (error: this directive must appear between .cfi_startproc and .cfi_endproc directives)
+BROKEN_FreeBSD_12_i386= does not build (error: this directive must appear between .cfi_startproc and .cfi_endproc directives)
-USES= alias cmake compiler:c++11-lib gettext gl \
- jpeg openal:al pkgconfig sdl tar:xz xorg
-USE_GL= gl glu glew
-USE_SDL= sdl
-USE_XORG= x11 xrandr
-CMAKE_OFF= USE_WIIUSE BUILD_RECORDER \
- USE_SYSTEM_ENET USE_SYSTEM_SQUISH
+USES= alias cmake compiler:c++11-lib pkgconfig tar:xz
+CMAKE_OFF= USE_WIIUSE \
+ BUILD_RECORDER \
+ USE_SYSTEM_ENET \
+ USE_SYSTEM_SQUISH
CMAKE_ON= USE_SYSTEM_GLEW
PORTDATA= *
@@ -40,28 +30,32 @@ PORTDATA= *
CXXFLAGS+= -DNO_IRR_COMPILE_WITH_JOYSTICK_EVENTS_ \
-D__FREE_BSD_
-OPTIONS_DEFINE= NETTLE WAYLAND
-OPTIONS_DEFAULT=WAYLAND
+OPTIONS_DEFINE= NETTLE SERVER_ONLY
+OPTIONS_DEFAULT=NETTLE
NETTLE_DESC= Use Nettle instead of OpenSSL for cryptography
NETTLE_LIB_DEPENDS= libnettle.so:security/nettle
NETTLE_USES_OFF= ssl
NETTLE_CMAKE_BOOL_OFF= USE_CRYPTO_OPENSSL
-WAYLAND_CMAKE_BOOL= ENABLE_WAYLAND_DEVICE
-WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland \
- libxkbcommon.so:x11/libxkbcommon
-WAYLAND_USE= GL=egl
+SERVER_ONLY_DESC= Build server only
+SERVER_ONLY_CMAKE_BOOL= SERVER_ONLY
+SERVER_ONLY_LIB_DEPENDS_OFF= \
+ libvorbisfile.so:audio/libvorbis \
+ libogg.so:audio/libogg \
+ libpng.so:graphics/png \
+ libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz
+SERVER_ONLY_USES_OFF= gettext gl jpeg openal:al sdl xorg
+SERVER_ONLY_USE_OFF= GL=gl,glu,glew SDL=sdl2 XORG=x11,xrandr
# make sure that bundled libraries are not used
post-extract:
-.for bundled in glew jpeglib libpng libraqm wiiuse zlib
+.for bundled in glew wiiuse
@${RM} -rf ${WRKSRC}/lib/${bundled}
.endfor
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/X11R6/include|${LOCALBASE}/include|' \
- ${WRKSRC}/lib/irrlicht/CMakeLists.txt
@${REINPLACE_CMD} -e 's|Icon=.*|Icon=${PREFIX}/share/icons/hicolor/128x128/apps/supertuxkart.png|' \
${WRKSRC}/data/${PORTNAME}.desktop