aboutsummaryrefslogtreecommitdiff
path: root/games/supertuxkart/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-09-09 00:04:58 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-09-09 00:04:58 +0000
commitbe303627f9c79ef2135cbeadd1645f23f9867899 (patch)
tree232da37cdfd33b2d8ff036bd0611a0cac7c8e856 /games/supertuxkart/Makefile
parent3a3c828c0ffc3394ae4c21451d90de92ed7486aa (diff)
downloadports-be303627f9c79ef2135cbeadd1645f23f9867899.tar.gz
ports-be303627f9c79ef2135cbeadd1645f23f9867899.zip
SuperTuxKart is a Free 3d kart racing game; we want to make the
game fun more than we want to make it realistic. You can play with up to 4 friends on one PC racing against each other, or just try to beat the computer. See the great lighthouse or drive through the sand and visit the pyramids. Race under water or in space, watching the stars passing by. Have some rest under the palms on the beach (watching the other karts overtaking you :) ). But don't fall in the volcano. You can do a single race against other karts, compete in one of several Grand Prix, or try to beat the high score in time trials on your own. WWW: http://supertuxkart.sourceforge.net/
Notes
Notes: svn path=/head/; revision=241063
Diffstat (limited to 'games/supertuxkart/Makefile')
-rw-r--r--games/supertuxkart/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/games/supertuxkart/Makefile b/games/supertuxkart/Makefile
new file mode 100644
index 000000000000..e16c1bc450ef
--- /dev/null
+++ b/games/supertuxkart/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: supertuxkart
+# Date created: 21 Mar 2008
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= supertuxkart
+PORTVERSION= 0.6.2
+CATEGORIES= games
+MASTER_SITES= SF/supertuxkart/SuperTuxKart/${PORTVERSION}
+EXTRACT_SUFX= -src.tar.bz2
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= Free 3D kart racing game
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib
+LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
+ alut.1:${PORTSDIR}/audio/freealut \
+ vorbisfile.6:${PORTSDIR}/audio/libvorbis \
+ ogg.6:${PORTSDIR}/audio/libogg
+
+USE_BZIP2= yes
+USE_GL= gl glu glut
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_SDL= sdl
+USE_GETTEXT= yes
+MAKE_JOBS_SAFE= yes
+
+PORTDOCS= *
+
+# Using LIBS instead of LDFLAGS, otherwise will break when
+# there's devel/bullet port installed
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+ CPPFLAGS="-I${LOCALBASE}/include"
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|$$(datadir)/games|$$(datadir)|g; \
+ s|$$(prefix)/games|$$(prefix)/bin|g'
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-dist_pkgdataDATA||' \
+ ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>