aboutsummaryrefslogtreecommitdiff
path: root/games/supertuxkart/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-05 16:11:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-05 16:11:29 +0000
commitca669f1d880f0fc1a849574eea3bcfc24f679f25 (patch)
tree9b27f38d052d5d1337db86fd4adf5f69dd8524bd /games/supertuxkart/Makefile
parent6089ce09429ac83502216ab38890e45aee92316c (diff)
downloadports-ca669f1d880f0fc1a849574eea3bcfc24f679f25.tar.gz
ports-ca669f1d880f0fc1a849574eea3bcfc24f679f25.zip
- Fix BROKEN_powerpc
- Convert conditional BROKEN to BROKEN_FreeBSD_8
Notes
Notes: svn path=/head/; revision=388587
Diffstat (limited to 'games/supertuxkart/Makefile')
-rw-r--r--games/supertuxkart/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/games/supertuxkart/Makefile b/games/supertuxkart/Makefile
index fa884d947e5b..9260b04ea3d8 100644
--- a/games/supertuxkart/Makefile
+++ b/games/supertuxkart/Makefile
@@ -19,6 +19,9 @@ LIB_DEPENDS= libvorbisfile.so:${PORTSDIR}/audio/libvorbis \
libpng.so:${PORTSDIR}/graphics/png \
libjpeg.so:${PORTSDIR}/graphics/jpeg
+BROKEN_powerpc= does not configure on powerpc
+BROKEN_FreeBSD_8= does not build on 8.x
+
USES= alias cmake compiler:c++11-lib dos2unix gettext \
gmake openal:al pkgconfig tar:xz
USE_GL= gl glu
@@ -50,18 +53,10 @@ XRANDR_CMAKE_OFF= -DUSE_XRANDR=NO
XRANDR_USE= XORG=xrandr
XRANDR_USE_OFF= XORG=xxf86vm
-powerpc_BROKEN= Does not configure on powerpc
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr/X11R6/include|${LOCALBASE}/include|' \
${WRKSRC}/lib/irrlicht/CMakeLists.txt
@${REINPLACE_CMD} -e 's|Icon=.*|Icon=${PREFIX}/share/icons/hicolor/128x128/apps/supertuxkart.png|' \
${WRKSRC}/data/${PORTNAME}.desktop
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 900000
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>