aboutsummaryrefslogtreecommitdiff
path: root/games/tank
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/tank
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'games/tank')
-rw-r--r--games/tank/Makefile2
-rw-r--r--games/tank/files/patch-Makefile.Linux.Mesa4
2 files changed, 3 insertions, 3 deletions
diff --git a/games/tank/Makefile b/games/tank/Makefile
index 1ec3d66ccca7..e26d25a61e33 100644
--- a/games/tank/Makefile
+++ b/games/tank/Makefile
@@ -15,7 +15,7 @@ EXTRACT_SUFX= -src.tar.gz
MAINTAINER= erik@smluc.org
COMMENT= A 3-D network tank game that uses OpenGL/Mesa
-BUILD_DEPENDS= ${X11BASE}/lib/libaux.a:${PORTSDIR}/graphics/libaux
+BUILD_DEPENDS= ${LOCALBASE}/lib/libaux.a:${PORTSDIR}/graphics/libaux
USE_GMAKE= yes
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" PTHREAD_LIBS="${PTHREAD_LIBS}"
diff --git a/games/tank/files/patch-Makefile.Linux.Mesa b/games/tank/files/patch-Makefile.Linux.Mesa
index 92cd5a521a83..2f4debbfbd6a 100644
--- a/games/tank/files/patch-Makefile.Linux.Mesa
+++ b/games/tank/files/patch-Makefile.Linux.Mesa
@@ -10,7 +10,7 @@
MESA = Mesa
-INCLUDE = -I/usr/include -I$(MESA)/include -I$(MESA)/include/GL
-+INCLUDE = -I$(X11BASE)/include -I$(X11BASE)/include/GL
++INCLUDE = -I$(LOCALBASE)/include -I$(LOCALBASE)/include/GL
-CFLAGS = $(INCLUDE) $(ARCH) -O2 -m486 -Wall -pipe \
- -pedantic -funroll-loops -mieee-fp
@@ -18,7 +18,7 @@
+ -pedantic -funroll-loops
-LDFLAGS = -L/usr/X11R6/lib -L$(MESA)/lib
-+LDFLAGS = -L$(X11BASE)/lib
++LDFLAGS = -L$(LOCALBASE)/lib
TAR = tar
COMPRESS = compress -v