aboutsummaryrefslogtreecommitdiff
path: root/games/taxipilot
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-11-20 19:13:28 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-11-20 19:13:28 +0000
commit9f51369429fb0ee010210a8b3dc6447de37e77a4 (patch)
tree370e9ea667984e388f9f0680a4a1e256201b63d9 /games/taxipilot
parentfd744d95ea77d719ae7bce4e222108f134341976 (diff)
downloadports-9f51369429fb0ee010210a8b3dc6447de37e77a4.tar.gz
ports-9f51369429fb0ee010210a8b3dc6447de37e77a4.zip
Unbreak on 4.x 3rd try.
Notes
Notes: svn path=/head/; revision=94512
Diffstat (limited to 'games/taxipilot')
-rw-r--r--games/taxipilot/Makefile10
-rw-r--r--games/taxipilot/files/patch-acinclude.m411
-rw-r--r--games/taxipilot/files/patch-timemanager.h15
3 files changed, 28 insertions, 8 deletions
diff --git a/games/taxipilot/Makefile b/games/taxipilot/Makefile
index b5acf7d5feef..e03b21246e65 100644
--- a/games/taxipilot/Makefile
+++ b/games/taxipilot/Makefile
@@ -16,15 +16,9 @@ COMMENT= A Spacetaxi clone
LIB_DEPENDS= noatun.0:${PORTSDIR}/multimedia/kdemultimedia3
USE_KDELIBS_VER= 3
-GNU_CONFIGURE= yes
+USE_AUTOMAKE= yes
CONFIGURE_TARGET=
CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500028
-BROKEN= "Does not build on 4.x"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/taxipilot/files/patch-acinclude.m4 b/games/taxipilot/files/patch-acinclude.m4
new file mode 100644
index 000000000000..fb1332479bbd
--- /dev/null
+++ b/games/taxipilot/files/patch-acinclude.m4
@@ -0,0 +1,11 @@
+--- admin/acinclude.m4.in.orig Thu Nov 20 19:35:08 2003
++++ admin/acinclude.m4.in Thu Nov 20 19:35:27 2003
+@@ -2937,7 +2937,7 @@
+ AC_REQUIRE([AC_FUNC_ALLOCA])dnl
+ AC_REQUIRE([AC_FUNC_MMAP])dnl
+ AC_REQUIRE([AM_KDE_WITH_NLS])dnl
+- AC_CHECK_HEADERS([argz.h limits.h locale.h nl_types.h string.h values.h alloca.h])
++ AC_CHECK_HEADERS([argz.h limits.h locale.h nl_types.h string.h values.h alloca.h stdint.h])
+ AC_CHECK_FUNCS([getcwd munmap putenv setenv setlocale strchr strcasecmp \
+ __argz_count __argz_stringify __argz_next])
+
diff --git a/games/taxipilot/files/patch-timemanager.h b/games/taxipilot/files/patch-timemanager.h
new file mode 100644
index 000000000000..fc75ba7b5d5f
--- /dev/null
+++ b/games/taxipilot/files/patch-timemanager.h
@@ -0,0 +1,15 @@
+--- taxipilot/timemanager.h.orig Wed Aug 21 11:20:40 2002
++++ taxipilot/timemanager.h Thu Nov 20 19:19:09 2003
+@@ -19,7 +19,12 @@
+ #define TIMEMANAGER_H
+
+ #include <qobject.h>
++#ifdef HAVE_STDINT_H
+ #include <stdint.h>
++#else
++#include <sys/types.h>
++#define int_fast32_t int32_t
++#endif
+ #include <qlist.h>
+
+ #include "timedobject.h"