aboutsummaryrefslogtreecommitdiff
path: root/games/tome4
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2016-11-11 21:37:38 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2016-11-11 21:37:38 +0000
commitdeb5f11aa914447c6a77b87906ecc69adf8a5014 (patch)
treedc8183958da5cc0674f62dc88a9bc4c69c9f5b63 /games/tome4
parent3d3f2d7e8e6db0fee51f6f665dc910d92c627394 (diff)
downloadports-deb5f11aa914447c6a77b87906ecc69adf8a5014.tar.gz
ports-deb5f11aa914447c6a77b87906ecc69adf8a5014.zip
Use the portable vesion of luajit when building on aarch64
PR: 214411 Submitted by: lifanov@mail.lifanov.com (maintainer) MFH: 2016Q4
Notes
Notes: svn path=/head/; revision=425910
Diffstat (limited to 'games/tome4')
-rw-r--r--games/tome4/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/games/tome4/Makefile b/games/tome4/Makefile
index c84e99718e87..952ced8073c4 100644
--- a/games/tome4/Makefile
+++ b/games/tome4/Makefile
@@ -20,8 +20,6 @@ BUILD_DEPENDS= premake4:devel/premake4
LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
libpng16.so:graphics/png
-BROKEN_aarch64= Fails to build: No support for this architecture (yet)
-
DESKTOP_ENTRIES="ToME 4" "" "${PORTNAME}" \
"${PORTNAME}" "Game;RolePlaying;" ""
@@ -35,9 +33,14 @@ USE_CSTD= gnu89
SUB_FILES= tome4
MAKE_JOBS_UNSAFE=yes
+LUA_TYPE=
pre-build:
@${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/premake4.lua
+.if ${ARCH} == aarch64
+ (cd ${WRKSRC} && premake4 --lua=default gmake)
+.else
(cd ${WRKSRC} && premake4 gmake)
+.endif
@${REINPLACE_CMD} 's|-lpthread|-pthread|' ${WRKSRC}/build/TEngine.make
do-install: