aboutsummaryrefslogtreecommitdiff
path: root/games/toycars
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-08-14 13:42:14 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2007-08-14 13:42:14 +0000
commit07d506189059812e0f3810430c37a26f07d020e1 (patch)
treefbf32ca28a03ad6c319160eac8e87d0be384f79b /games/toycars
parentb90590351d639c7dff1cf4bab6743cad12ea074b (diff)
downloadports-07d506189059812e0f3810430c37a26f07d020e1.tar.gz
ports-07d506189059812e0f3810430c37a26f07d020e1.zip
- Update to 0.3.3
- Remove 4.x-specific patches PR: 115477 Submitted by: Dmitry Marakasov (maintainer)
Notes
Notes: svn path=/head/; revision=197666
Diffstat (limited to 'games/toycars')
-rw-r--r--games/toycars/Makefile12
-rw-r--r--games/toycars/distinfo6
-rw-r--r--games/toycars/files/patch-src-Player.cpp13
-rw-r--r--games/toycars/files/patch-src-ToyCar.h14
-rw-r--r--games/toycars/pkg-plist9
5 files changed, 13 insertions, 41 deletions
diff --git a/games/toycars/Makefile b/games/toycars/Makefile
index 47fc5dd5882a..fb557e60f702 100644
--- a/games/toycars/Makefile
+++ b/games/toycars/Makefile
@@ -6,21 +6,23 @@
#
PORTNAME= toycars
-PORTVERSION= 0.3.2
-PORTREVISION= 1
+PORTVERSION= 0.3.3
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= toycars
+MASTER_SITES= SF
MAINTAINER= amdmi3@amdmi3.ru
COMMENT= Physics-based 2D racing game
+LIB_DEPENDS= openal.0:${PORTSDIR}/audio/openal \
+ alut.1:${PORTSDIR}/audio/freealut
+
USE_SDL= mixer image sdl
USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}lib -L${X11BASE}/lib"
PORTDOCS= README
diff --git a/games/toycars/distinfo b/games/toycars/distinfo
index 776f204b756d..a59196c7216b 100644
--- a/games/toycars/distinfo
+++ b/games/toycars/distinfo
@@ -1,3 +1,3 @@
-MD5 (toycars-0.3.2.tar.gz) = 70821d80bfc103feeeb98afb409b73aa
-SHA256 (toycars-0.3.2.tar.gz) = 46ca7231510eb3d8318933af93999d2ef3d762ae6e6d9db05287d59a70e14211
-SIZE (toycars-0.3.2.tar.gz) = 5042224
+MD5 (toycars-0.3.3.tar.gz) = fef0de40f5921c7b13866222a583129d
+SHA256 (toycars-0.3.3.tar.gz) = 0a62e2b48f2371fcdab17f016eb2e16a53489914d877bc106c7550e163f13c07
+SIZE (toycars-0.3.3.tar.gz) = 5336046
diff --git a/games/toycars/files/patch-src-Player.cpp b/games/toycars/files/patch-src-Player.cpp
deleted file mode 100644
index 789e7e83b524..000000000000
--- a/games/toycars/files/patch-src-Player.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/Player.cpp.orig Sun Aug 13 14:36:55 2006
-+++ src/Player.cpp Thu Aug 24 21:22:42 2006
-@@ -31,6 +31,10 @@
-
- // member functions
-
-+#ifndef INFINITY
-+#define INFINITY MAXFLOAT
-+#endif
-+
- Player::Player(ToyCar& inCar, list<Tuple> *path, int inPlayerNumber)
- : car(inCar), lapFlag(0), laps(-1), curLap(-1e-1), prevLap(-1e-1), revolutions(-1), bestLapTime(INFINITY), courseTime(0.0),
- pathEnd(path->end()), pathClosestPerp(INFINITY), pathSize(path->size()), playerNumber(inPlayerNumber)
diff --git a/games/toycars/files/patch-src-ToyCar.h b/games/toycars/files/patch-src-ToyCar.h
deleted file mode 100644
index d01b2247a582..000000000000
--- a/games/toycars/files/patch-src-ToyCar.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/ToyCar.h.orig Mon Dec 12 04:11:19 2005
-+++ src/ToyCar.h Mon Dec 19 11:39:10 2005
-@@ -25,6 +25,11 @@
- #include "WheelSprite.h"
- #include "ScSprite.h"
-
-+#include <stdio.h>
-+#include <time.h>
-+#include <unistd.h>
-+#include <string>
-+
- // ToyCar class
-
- class ToyCar : public Vehicle, public ScSprite
diff --git a/games/toycars/pkg-plist b/games/toycars/pkg-plist
index e879c43185d3..b7ec167960c2 100644
--- a/games/toycars/pkg-plist
+++ b/games/toycars/pkg-plist
@@ -14,21 +14,18 @@ bin/toycars
%%DATADIR%%/data/images/loading.png
%%DATADIR%%/data/images/needle.png
%%DATADIR%%/data/images/title.png
-%%DATADIR%%/data/sounds/._Motor_Car_Song.ogg
%%DATADIR%%/data/sounds/Motor_Car_Song.ogg
-%%DATADIR%%/data/sounds/Motor_Car_Song.ogg.u53
+%%DATADIR%%/data/sounds/bang_6.wav
+%%DATADIR%%/data/sounds/engine.aiff
+%%DATADIR%%/data/sounds/engine.wav
%%DATADIR%%/data/tilesets/default/default.xml
%%DATADIR%%/data/tilesets/default/tiles.png
%%DATADIR%%/data/tracks/Chewed-Oval/Chewed-Oval.map
%%DATADIR%%/data/tracks/Chewed-Oval/Chewed-Oval.xml
-%%DATADIR%%/data/tracks/Circuit/._Circuit.xml
%%DATADIR%%/data/tracks/Circuit/Circuit.xml
-%%DATADIR%%/data/tracks/Circuit/Circuit.xml.6xg
%%DATADIR%%/data/tracks/Circuit/oval.map
-%%DATADIR%%/data/tracks/Corner/._Corner.xml
%%DATADIR%%/data/tracks/Corner/Corner.xml
%%DATADIR%%/data/tracks/Corner/corner.map
-%%DATADIR%%/data/tracks/Horseshoe/._Horseshoe.xml
%%DATADIR%%/data/tracks/Horseshoe/Horseshoe.xml
%%DATADIR%%/data/tracks/Horseshoe/horseshoe.map
%%DATADIR%%/data/tracks/Rings/Rings.xml