aboutsummaryrefslogtreecommitdiff
path: root/games/ttt
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-12 13:49:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-12 13:49:24 +0000
commit934e321c28e5ca3a3de41cf8260b81c333a98b73 (patch)
tree764154f953ac70f1b8e33a1fe4befaaa8126bb11 /games/ttt
parent9d7b190e24cb02bbc3c6d3862c37819b4ecca403 (diff)
downloadports-934e321c28e5ca3a3de41cf8260b81c333a98b73.tar.gz
ports-934e321c28e5ca3a3de41cf8260b81c333a98b73.zip
TTT (Tic-Tac-Toe)
"ttt" is a very simple one - or two - player Tic Tac Toe game played using a mouse. PR: ports/83282 Submitted by: Alejandro Pulver <alejandro@varnet.biz>
Notes
Notes: svn path=/head/; revision=138991
Diffstat (limited to 'games/ttt')
-rw-r--r--games/ttt/Makefile61
-rw-r--r--games/ttt/distinfo2
-rw-r--r--games/ttt/pkg-descr9
-rw-r--r--games/ttt/pkg-plist22
4 files changed, 94 insertions, 0 deletions
diff --git a/games/ttt/Makefile b/games/ttt/Makefile
new file mode 100644
index 000000000000..d46d178e9606
--- /dev/null
+++ b/games/ttt/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: ttt
+# Date created: 11 July 2005
+# Whom: Alejandro Pulver <alejandro@varnet.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ttt
+PORTVERSION= 2003.03.14
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.billsgames.com/unix/x/ttt/
+
+MAINTAINER= alejandro@varnet.biz
+COMMENT= Simple one or two player Tic Tac Toe game
+
+USE_GMAKE= yes
+USE_SDL= mixer sdl
+USE_REINPLACE= yes
+
+OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
+
+# net/ttt
+CONFLICTS= ttt-1*
+NO_LATEST_LINK= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+# Fix Makefile
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}| ; \
+ s|\(-Wall\)|${CFLAGS} \1|' \
+ ${WRKSRC}/${MAKEFILE}
+
+# Enable/disable compilation optimizations
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/${MAKEFILE}
+.endif
+
+# Fix paths to ${DATADIR}
+ @${REINPLACE_CMD} -e 's|\(images/\)|${DATADIR}/\1| ; \
+ s|\(sounds/\)|${DATADIR}/\1|' \
+ ${WRKSRC}/ttt.c
+
+do-install:
+# Program
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+# Data
+ ${MKDIR} ${DATADIR}
+.for d in images sounds
+ ${CP} -R ${WRKSRC}/${d} ${DATADIR}
+.endfor
+
+# Fix wrong permissions
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}
+ ${FIND} ${DATADIR} -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} ${SHAREMODE}
+ ${FIND} ${DATADIR} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} ${BINMODE}
+
+.include <bsd.port.post.mk>
diff --git a/games/ttt/distinfo b/games/ttt/distinfo
new file mode 100644
index 000000000000..721180d2094e
--- /dev/null
+++ b/games/ttt/distinfo
@@ -0,0 +1,2 @@
+MD5 (ttt-2003.03.14.tar.gz) = 25c00a720820614e75dd31a593b4aa3e
+SIZE (ttt-2003.03.14.tar.gz) = 130205
diff --git a/games/ttt/pkg-descr b/games/ttt/pkg-descr
new file mode 100644
index 000000000000..1f0dfe960423
--- /dev/null
+++ b/games/ttt/pkg-descr
@@ -0,0 +1,9 @@
+TTT (Tic-Tac-Toe)
+
+"ttt" is a very simple one - or two - player Tic Tac Toe game played using a
+mouse.
+
+WWW: http://www.newbreedsoftware.com/ttt/
+
+- Alejandro Pulver
+alejandro@varnet.biz
diff --git a/games/ttt/pkg-plist b/games/ttt/pkg-plist
new file mode 100644
index 000000000000..d744bd9645de
--- /dev/null
+++ b/games/ttt/pkg-plist
@@ -0,0 +1,22 @@
+bin/ttt
+%%DATADIR%%/images/grid.bmp
+%%DATADIR%%/images/o.bmp
+%%DATADIR%%/images/start_1ply.bmp
+%%DATADIR%%/images/start_2ply.bmp
+%%DATADIR%%/images/title.bmp
+%%DATADIR%%/images/turn_o.bmp
+%%DATADIR%%/images/turn_x.bmp
+%%DATADIR%%/images/win_draw.bmp
+%%DATADIR%%/images/win_o.bmp
+%%DATADIR%%/images/win_x.bmp
+%%DATADIR%%/images/x.bmp
+%%DATADIR%%/sounds/badspot.wav
+%%DATADIR%%/sounds/draw.wav
+%%DATADIR%%/sounds/intro.wav
+%%DATADIR%%/sounds/o.wav
+%%DATADIR%%/sounds/start.wav
+%%DATADIR%%/sounds/win.wav
+%%DATADIR%%/sounds/x.wav
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%