aboutsummaryrefslogtreecommitdiff
path: root/games/tuxracer/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-04 21:39:48 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-11-04 21:39:48 +0000
commita11ab5293ab968f77d9f1193e460b590830efa89 (patch)
treeb14759f47085b4b77346ee34a981a31cd42ebe69 /games/tuxracer/Makefile
parentaede0fed8e8e1e9c2eb759f5d41a416f0ad0366c (diff)
downloadports-a11ab5293ab968f77d9f1193e460b590830efa89.tar.gz
ports-a11ab5293ab968f77d9f1193e460b590830efa89.zip
- Add stage support
- Convert USE_TK and USE_GMAKE to USES
Notes
Notes: svn path=/head/; revision=332788
Diffstat (limited to 'games/tuxracer/Makefile')
-rw-r--r--games/tuxracer/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/games/tuxracer/Makefile b/games/tuxracer/Makefile
index ab4acaaf93db..89687a57b0f4 100644
--- a/games/tuxracer/Makefile
+++ b/games/tuxracer/Makefile
@@ -16,8 +16,7 @@ COMMENT= 3D penguin racing game using OpenGL
USE_SDL= mixer sdl
USE_GL= gl
USE_XORG= x11 xt xmu xi
-USE_TK= yes
-USE_GMAKE= yes
+USES= gmake tk
USE_AUTOTOOLS= automake14 autoconf
AUTOMAKE_ARGS= -a
CONFIGURE_ENV= THREAD_LIB="${PTHREAD_LIBS}"
@@ -29,13 +28,12 @@ CONFIGURE_ARGS= --with-tcl-inc="${TCL_INCLUDEDIR}" \
--with-data-dir=${DATADIR}
MAKE_ENV= ${CONFIGURE_ENV}
-NO_STAGE= yes
post-extract:
@${RM} ${WRKSRC}/missing
post-install:
- @${MKDIR} ${DATADIR}
- @(cd ${WORKDATA} ${WRKDIR}/${PORTNAME}-data-${PORTVERSION} \
- && ${COPYTREE_SHARE} . ${DATADIR})
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ (cd ${WORKDATA} ${WRKDIR}/${PORTNAME}-data-${PORTVERSION} \
+ && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
.include <bsd.port.mk>