aboutsummaryrefslogtreecommitdiff
path: root/games/tuxtype/Makefile
diff options
context:
space:
mode:
authorArmin Pirkovitsch <sperber@FreeBSD.org>2012-07-19 17:34:24 +0000
committerArmin Pirkovitsch <sperber@FreeBSD.org>2012-07-19 17:34:24 +0000
commit8100f5d4098f5d4824a9270491f17eba8599b7f1 (patch)
tree1994b14925c9f2d73acb248d95ee9700fad04d11 /games/tuxtype/Makefile
parent48c78dd0a88e2766c17732f320ef462106ae7269 (diff)
downloadports-8100f5d4098f5d4824a9270491f17eba8599b7f1.tar.gz
ports-8100f5d4098f5d4824a9270491f17eba8599b7f1.zip
- Fix build
- Remove trailing spaces PR: ports/169416 Submitted by: KATO Tsuguru <tkato432 _at_ yahoo.com> Approved by: beat (mentor)
Notes
Notes: svn path=/head/; revision=301172
Diffstat (limited to 'games/tuxtype/Makefile')
-rw-r--r--games/tuxtype/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/games/tuxtype/Makefile b/games/tuxtype/Makefile
index c61668adec2f..9aed938ab272 100644
--- a/games/tuxtype/Makefile
+++ b/games/tuxtype/Makefile
@@ -21,8 +21,6 @@ LICENSE= GPLv3 # (or later)
BUILD_DEPENDS= gsed:${PORTSDIR}/textproc/gsed
-BROKEN= does not compile
-
OPTIONS_DEFINE= NLS SVG DOCS
OPTIONS_DEFAULT= SVG
@@ -40,7 +38,7 @@ CONFIGURE_ENV= T4K_COMMON_CFLAGS="-I${T4K_WRKSRC}/src" \
MAKE_JOBS_SAFE= yes
CPPFLAGS+= $$(pkg-config --cflags SDL_Pango) -I${LOCALBASE}/include \
- -DHAVE_ALPHASORT -DHAVE_SCANDIR -DHAVE_FSYNC -DICONV_CONST=""
+ -DHAVE_ALPHASORT -DHAVE_SCANDIR -DHAVE_FSYNC -DICONV_CONST=""
LDFLAGS+= $$(pkg-config --libs SDL_Pango) -L${LOCALBASE}/lib
T4K_NAME= t4k_common
@@ -51,6 +49,7 @@ T4K_WRKSRC= ${WRKDIR}/${T4K_NAME}-${T4K_VERSION}
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls