aboutsummaryrefslogtreecommitdiff
path: root/games/uhexen2/files
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2008-04-21 21:00:24 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2008-04-21 21:00:24 +0000
commitcc1cc825c96f9bcce29b635b3ae0a1e6de7744c1 (patch)
tree9b97d0e59fef0c00dfdc4a6998328ef0c3987457 /games/uhexen2/files
parentab501a20d6ecc075e97da7d2820354f593ee7c4e (diff)
downloadports-cc1cc825c96f9bcce29b635b3ae0a1e6de7744c1.tar.gz
ports-cc1cc825c96f9bcce29b635b3ae0a1e6de7744c1.zip
- Update to version 1.4.3.
Notes
Notes: svn path=/head/; revision=211733
Diffstat (limited to 'games/uhexen2/files')
-rw-r--r--games/uhexen2/files/Makefile2
-rw-r--r--games/uhexen2/files/patch-hexen2__Makefile20
-rw-r--r--games/uhexen2/files/patch-hexenworld__Client__Makefile20
-rw-r--r--games/uhexen2/files/patch-launcher__Makefile47
-rw-r--r--games/uhexen2/files/patch-scripts__makefile.inc36
5 files changed, 25 insertions, 100 deletions
diff --git a/games/uhexen2/files/Makefile b/games/uhexen2/files/Makefile
index de530387c93b..f2a465732964 100644
--- a/games/uhexen2/files/Makefile
+++ b/games/uhexen2/files/Makefile
@@ -16,9 +16,11 @@ ifeq ($(BUILD_HW),yes)
endif
ifeq ($(BUILD_LAUNCHER_GTK1),yes)
$(MAKE) -C launcher GTK1=yes
+ cd launcher && mv h2launcher h2launcher.gtk1
$(MAKE) -C launcher clean
endif
ifeq ($(BUILD_LAUNCHER_GTK2),yes)
$(MAKE) -C launcher
+ cd launcher && mv h2launcher h2launcher.gtk2
$(MAKE) -C launcher clean
endif
diff --git a/games/uhexen2/files/patch-hexen2__Makefile b/games/uhexen2/files/patch-hexen2__Makefile
index 54ec06f63a20..00ad7dd1846a 100644
--- a/games/uhexen2/files/patch-hexen2__Makefile
+++ b/games/uhexen2/files/patch-hexen2__Makefile
@@ -1,6 +1,6 @@
---- hexen2/Makefile.orig Sat Sep 15 09:16:44 2007
-+++ hexen2/Makefile Mon Oct 8 15:56:50 2007
-@@ -113,13 +113,13 @@
+--- ./hexen2/Makefile.orig 2008-04-03 20:37:23.000000000 -0300
++++ ./hexen2/Makefile 2008-04-21 15:15:19.000000000 -0300
+@@ -120,13 +120,13 @@
USE_SDLAUDIO=yes
USE_MIDI=yes
USE_CDAUDIO=yes
@@ -15,8 +15,8 @@
+USE_X86_ASM?=no
COMPILE_32BITS=no
- # build environment sanity checks
-@@ -176,7 +176,7 @@
+ # include the common dirty stuff
+@@ -179,7 +179,7 @@
else
@@ -25,13 +25,3 @@
ifdef NO_UNIT_AT_A_TIME
CFLAGS := $(CFLAGS) $(call check_gcc,-fno-unit-at-a-time,)
-@@ -184,7 +184,9 @@
-
- ifeq ($(OPT_EXTRA),yes)
- # Note: re-check these flags for non-ia32 machines
-+ifeq ($(MACH_TYPE),x86)
- CFLAGS := $(CFLAGS) $(call check_gcc,-falign-loops=2 -falign-jumps=2 -falign-functions=2,-malign-loops=2 -malign-jumps=2 -malign-functions=2)
-+endif
- CFLAGS := $(CFLAGS) -fomit-frame-pointer
- endif
- endif
diff --git a/games/uhexen2/files/patch-hexenworld__Client__Makefile b/games/uhexen2/files/patch-hexenworld__Client__Makefile
index ebe2b3f1f39c..78d1537f4166 100644
--- a/games/uhexen2/files/patch-hexenworld__Client__Makefile
+++ b/games/uhexen2/files/patch-hexenworld__Client__Makefile
@@ -1,6 +1,6 @@
---- hexenworld/Client/Makefile.orig Sat Sep 15 09:16:44 2007
-+++ hexenworld/Client/Makefile Mon Oct 8 15:51:44 2007
-@@ -113,13 +113,13 @@
+--- ./hexenworld/Client/Makefile.orig 2008-04-03 20:37:25.000000000 -0300
++++ ./hexenworld/Client/Makefile 2008-04-21 15:15:19.000000000 -0300
+@@ -115,13 +115,13 @@
USE_SDLAUDIO=yes
USE_MIDI=yes
USE_CDAUDIO=yes
@@ -15,8 +15,8 @@
+USE_X86_ASM?=no
COMPILE_32BITS=no
- # build environment sanity checks
-@@ -176,7 +176,7 @@
+ # include the common dirty stuff
+@@ -167,7 +167,7 @@
else
@@ -25,13 +25,3 @@
ifdef NO_UNIT_AT_A_TIME
CFLAGS := $(CFLAGS) $(call check_gcc,-fno-unit-at-a-time,)
-@@ -184,7 +184,9 @@
-
- ifeq ($(OPT_EXTRA),yes)
- # Note: re-check these flags for non-ia32 machines
-+ifeq ($(MACH_TYPE),x86)
- CFLAGS := $(CFLAGS) $(call check_gcc,-falign-loops=2 -falign-jumps=2 -falign-functions=2,-malign-loops=2 -malign-jumps=2 -malign-functions=2)
-+endif
- CFLAGS := $(CFLAGS) -fomit-frame-pointer
- endif
- endif
diff --git a/games/uhexen2/files/patch-launcher__Makefile b/games/uhexen2/files/patch-launcher__Makefile
index e14a1e3927b1..88bc4a94edac 100644
--- a/games/uhexen2/files/patch-launcher__Makefile
+++ b/games/uhexen2/files/patch-launcher__Makefile
@@ -1,44 +1,11 @@
---- launcher/Makefile.orig Mon Aug 13 10:01:46 2007
-+++ launcher/Makefile Sun Oct 21 14:38:45 2007
-@@ -19,19 +19,7 @@
-
- HOST_OS:=$(shell uname)
-
--CC_DEFAULT:=gcc
--ifeq ($(origin CC),environment)
--CC_OVERRIDE:=1
--ifeq ($(CC),)
--CC_OVERRIDE:=
--endif
--endif
--ifeq ($(origin CC),command line)
--CC_OVERRIDE:=1
--endif
--ifeq ($(CC_OVERRIDE),)
--CC := $(CC_DEFAULT)
--endif
-+CC_DEFAULT:=cc
-
- LINKER:= $(CC)
-
-@@ -39,11 +27,7 @@
- XDELTA_FLAGS:=
- XDELTA_LINK:= -L$(XDELTA_DIR)/.libs -lxdelta -L$(XDELTA_DIR)/libedsio/.libs -ledsio
-
--ifdef DEMO
--H2LAUNCH:= h2demo
--else
- H2LAUNCH:= h2launcher
--endif
-
- ifdef GTK1
- GTK_CFLAGS:= $(shell gtk-config --cflags)
-@@ -124,7 +108,7 @@
+--- launcher/Makefile.orig 2007-10-25 06:06:52.000000000 -0300
++++ launcher/Makefile 2008-04-21 17:28:38.000000000 -0300
+@@ -116,7 +116,7 @@
ALL_OBJECTS := $(LAUNCHER_OBJS) $(GUI_OBJS) $(XPATCH_OBJS) \
$(LIBXDELTA_OBJS) $(LIBEDSIO_OBJS) $(LAUNCHER_MAIN)
--$(H2LAUNCH): $(LAUNCHER_OBJS) $(LAUNCHER_MAIN) $(GUI_OBJS) $(XPATCH_OBJS)
-+$(H2LAUNCH): $(ALL_OBJECTS)
- @rm -f $(H2LAUNCH)
- $(LINKER) -o $(H2LAUNCH) $(ALL_OBJECTS) $(LDFLAGS)
+-$(BINARY): $(LAUNCHER_OBJS) $(LAUNCHER_MAIN) $(GUI_OBJS) $(XPATCH_OBJS)
++$(BINARY): $(ALL_OBJECTS)
+ @rm -f $(BINARY)
+ $(LINKER) -o $(BINARY) $(ALL_OBJECTS) $(LDFLAGS)
diff --git a/games/uhexen2/files/patch-scripts__makefile.inc b/games/uhexen2/files/patch-scripts__makefile.inc
index b89449a8a24c..9870a02275f1 100644
--- a/games/uhexen2/files/patch-scripts__makefile.inc
+++ b/games/uhexen2/files/patch-scripts__makefile.inc
@@ -1,35 +1,11 @@
---- scripts/makefile.inc.orig Thu Jul 12 14:41:20 2007
-+++ scripts/makefile.inc Mon Oct 8 16:11:27 2007
-@@ -17,7 +17,7 @@
-
+--- scripts/makefile.inc.orig 2008-04-02 14:55:23.000000000 -0300
++++ scripts/makefile.inc 2008-04-21 15:18:12.000000000 -0300
+@@ -29,7 +29,7 @@
# Common paths:
+
# X directory
-X11BASE ?=/usr/X11R6
+X11BASE ?=/usr/local
- # MinGW32 directory:
- MINGWDIR ?=/mingw
-@@ -73,22 +73,7 @@
- endif
-
- # Compiler selection:
--# refuse cc for CC which is the default for make
--# accept environment or command line overrides.
--CC_DEFAULT:=gcc
--ifeq ($(origin CC),environment)
--CC_OVERRIDE:=1
--# watch for stale environment defs
--ifeq ($(CC),)
--CC_OVERRIDE:=
--endif
--endif
--ifeq ($(origin CC),command line)
--CC_OVERRIDE:=1
--endif
--ifeq ($(CC_OVERRIDE),)
--CC := $(CC_DEFAULT)
--endif
-+CC ?= cc
-
- NASM ?= $(NASM_BIN)
- WINDRES ?= windres
+ # Local w32stuff directory:
+ W32STUFF :=$(UHEXEN2_TOP)/w32stuff