aboutsummaryrefslogtreecommitdiff
path: root/games/ultimatestunts
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-07-28 07:16:31 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-07-28 07:16:31 +0000
commit75bf744d3c49c72152cf84b1cbd9b6814d322a8b (patch)
tree391b30c297aece3cc39a8678d7ee99bd83422591 /games/ultimatestunts
parent00a6d7c8e522cfc6b3ffcfce692ce325f2cbf10b (diff)
downloadports-75bf744d3c49c72152cf84b1cbd9b6814d322a8b.tar.gz
ports-75bf744d3c49c72152cf84b1cbd9b6814d322a8b.zip
games/ultimatestunts: Fix build with Clang 6 and lld
gamerenderer.cpp:81:30: error: non-constant-expression cannot be narrowed from type 'double' to 'GLfloat' (aka 'float') in initializer list [-Wc++11-narrowing] GLfloat specular_color[] = {3.0*lightCol.x, 3.0*lightCol.y, 3.0*lightCol.z, 1.0}; ^~~~~~~~~~~~~~ http://beefy12.nyi.freebsd.org/data/head-amd64-default/p475044_s336572/logs/ultimatestunts-0.7.7.1_4.log - Fix bad absolute symlink - Mark as LLD_UNSAFE because of audio/openal-soft dependency [1] PR: 226980 [1]
Notes
Notes: svn path=/head/; revision=475503
Diffstat (limited to 'games/ultimatestunts')
-rw-r--r--games/ultimatestunts/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/games/ultimatestunts/Makefile b/games/ultimatestunts/Makefile
index 9ef31f1c6c77..9d5b84c796ae 100644
--- a/games/ultimatestunts/Makefile
+++ b/games/ultimatestunts/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ultimatestunts
PORTVERSION= 0.7.7.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/sourcecode \
SF/nemysisfreebsdp/${CATEGORIES}/:icons
@@ -19,13 +19,16 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libvorbisfile.so:audio/libvorbis
-USES= gettext openal:al,alut pkgconfig
+USES= compiler gettext openal:al,alut pkgconfig
USE_GL= gl glu
USE_SDL= sdl image
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openal
MAKE_JOBS_UNSAFE= yes
+LLD_UNSAFE= yes
+CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_clang= -Wno-c++11-narrowing
CPPFLAGS+= $$(pkgconf --cflags-only-I sdl)
LDFLAGS+= $$(pkgconf --libs-only-L sdl)
@@ -66,7 +69,7 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \
${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
.endfor
- ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${RLN} ${STAGEDIR}${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
${STAGEDIR}${PREFIX}/share/pixmaps
.if ${PORT_OPTIONS:MDOCS}