aboutsummaryrefslogtreecommitdiff
path: root/games/untahris
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-06-18 11:46:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-06-18 11:46:51 +0000
commit3037cb61c7f1ac5ae9a15cee2365daa2d4036028 (patch)
treee391a5b5894d27043bb95bd6680b03174979f810 /games/untahris
parent28eb882aa04c420b3fe972dd8748b80c90c5cd82 (diff)
downloadports-3037cb61c7f1ac5ae9a15cee2365daa2d4036028.tar.gz
ports-3037cb61c7f1ac5ae9a15cee2365daa2d4036028.zip
- Trim Makefile headers
- Drop ABI versions from LIB_DEPENDS - OptionsNG - Pet portlint - Switch to dynamic plist where useful
Notes
Notes: svn path=/head/; revision=321181
Diffstat (limited to 'games/untahris')
-rw-r--r--games/untahris/Makefile21
-rw-r--r--games/untahris/files/patch-intface.cpp16
-rw-r--r--games/untahris/pkg-plist14
3 files changed, 19 insertions, 32 deletions
diff --git a/games/untahris/Makefile b/games/untahris/Makefile
index ef2048810210..1d52e8ed9af0 100644
--- a/games/untahris/Makefile
+++ b/games/untahris/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: untahris
-# Date created: 08 Sep 2006
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= untahris
PORTVERSION= 3.1
@@ -16,11 +12,14 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Play several classic fun, simple arcade games in multiplayer mode
USE_SDL= sdl net ttf mixer
-PORTDOCS= *
-
+USE_DOS2UNIX= intface.cpp
WRKSRC= ${WRKDIR}/${PORTNAME}
-.include <bsd.port.pre.mk>
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= *
+PORTDATA= *
+
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's|VeraBd.ttf|${DATADIR}/VeraBd.ttf|; \
@@ -33,13 +32,15 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/untahris ${PREFIX}/bin/
+.if !defined(NOPORTDATA)
${MKDIR} ${DATADIR}
.for f in VeraBd.ttf graph16*.unt *.wav
${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}/
.endfor
-.if !defined(NOPORTDOCS)
+.endif
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/untahris/files/patch-intface.cpp b/games/untahris/files/patch-intface.cpp
index 83c93315ab1e..65f57f28757d 100644
--- a/games/untahris/files/patch-intface.cpp
+++ b/games/untahris/files/patch-intface.cpp
@@ -1,11 +1,11 @@
--- intface.cpp.orig 2009-05-20 01:41:32.000000000 +0400
+++ intface.cpp 2009-07-07 17:38:01.000000000 +0400
@@ -834,7 +834,7 @@
- Ic(icBazooka).fillWith("0", d.Res);
- Ic(icBazooka).gradFill(d.Res*4/8-1, 0, d.Res*4/8, d.Res*3/4, 0x80FFFFFF, 0xFFFFFFFF);
-
-- char buf[64];
-+ char buf[1024];
- sprintf(buf, "graph%d%s.unt", d.Res, gtNames[c.graphicsType]);
- FILE *f = fopen(buf, "rt");
- if(f) {
+ Ic(icBazooka).fillWith("0", d.Res);
+ Ic(icBazooka).gradFill(d.Res*4/8-1, 0, d.Res*4/8, d.Res*3/4, 0x80FFFFFF, 0xFFFFFFFF);
+
+- char buf[64];
++ char buf[1024];
+ sprintf(buf, "graph%d%s.unt", d.Res, gtNames[c.graphicsType]);
+ FILE *f = fopen(buf, "rt");
+ if(f) {
diff --git a/games/untahris/pkg-plist b/games/untahris/pkg-plist
deleted file mode 100644
index bb13b2ad853a..000000000000
--- a/games/untahris/pkg-plist
+++ /dev/null
@@ -1,14 +0,0 @@
-bin/untahris
-%%DATADIR%%/VeraBd.ttf
-%%DATADIR%%/birth.wav
-%%DATADIR%%/blue.wav
-%%DATADIR%%/death.wav
-%%DATADIR%%/graph16gradient.unt
-%%DATADIR%%/graph16lines.unt
-%%DATADIR%%/graph16retro.unt
-%%DATADIR%%/green.wav
-%%DATADIR%%/hit.wav
-%%DATADIR%%/place.wav
-%%DATADIR%%/red.wav
-%%DATADIR%%/shoot.wav
-@dirrm %%DATADIR%%