aboutsummaryrefslogtreecommitdiff
path: root/games/vamos/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-01-26 21:39:49 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-01-26 21:39:49 +0000
commit355dfb22d5b8c10186ae74ed094fd53ee6a2e847 (patch)
tree4ad821efd602a193d52d4adb6f6d0d989617c088 /games/vamos/Makefile
parentb09673b70d39fdedf6a34e8a0dcff1db1d52c7bf (diff)
downloadports-355dfb22d5b8c10186ae74ed094fd53ee6a2e847.tar.gz
ports-355dfb22d5b8c10186ae74ed094fd53ee6a2e847.zip
- Bump PORTREVISION
- Change master sites - Disable all warnings with -w - Add icon 128x128, change vamos_icons.tar.gz - Change Desktop entry file - Strip library - Recreate patches with make makepatch
Notes
Notes: svn path=/head/; revision=341293
Diffstat (limited to 'games/vamos/Makefile')
-rw-r--r--games/vamos/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/games/vamos/Makefile b/games/vamos/Makefile
index 64284eaf6b5f..e2073c0658f5 100644
--- a/games/vamos/Makefile
+++ b/games/vamos/Makefile
@@ -3,9 +3,10 @@
PORTNAME= vamos
PORTVERSION= 0.7.1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/ \
- SF/nemysisfreebsdp/:icons
+ SF/nemysisfreebsdp/${CATEGORIES}/:icons
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX} \
${PORTNAME}_icons${EXTRACT_SUFX}:icons
@@ -26,7 +27,7 @@ CONFIGURE_ARGS= ac_cv_lib_freeglut_glutGetModifiers=no \
--disable-unit-tests
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS} -w
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
INFO= vamos
@@ -40,13 +41,13 @@ DOCSRCDIR2= ${WRKSRC}/doc
DOCSDIR2= ${DOCSDIR}/doc
DOC_FILES2= matrixfaq.htm
-INSTALLS_ICONS= yes
-ICON_SIZES= 32x32 48x48 64x64 72x72 96x96
+OPTIONS_DEFINE= DOCS
-DESKTOP_ENTRIES="Vamos" "${COMMENT}" ${PORTNAME} \
- "${PORTNAME}" "Game;ArcadeGame;" false
+INSTALLS_ICONS= yes
+ICON_SIZES= 32x32 48x48 64x64 72x72 96x96 128x128
-OPTIONS_DEFINE= DOCS
+DESKTOP_ENTRIES="Vamos" "" ${PORTNAME} \
+ "${PORTNAME}" "Game;ArcadeGame;" ""
post-extract:
@${CHMOD} ${BINMODE} ${WRKSRC}/config/install-sh
@@ -60,6 +61,10 @@ post-patch:
/^AM_CXXFLAGS/s| -L/usr/lib/boost||'
post-install:
+.for l in geometry media body track world
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libvamos-${l}.so.0
+.endfor
+
.for s in ${ICON_SIZES}
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps
${INSTALL_DATA} ${WRKDIR}/${PORTNAME}_${s}.png \