aboutsummaryrefslogtreecommitdiff
path: root/games/vamos
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-04-03 07:08:23 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-04-03 07:08:23 +0000
commit3f9fd0160ad53cdf2315d777ce44b271516e567f (patch)
treec5af1b64e6bb4c3a8152f8a7856ff1869e7cabfc /games/vamos
parent1cd097fb7129d1a0dd19d40a0eed29b165f448ad (diff)
downloadports-3f9fd0160ad53cdf2315d777ce44b271516e567f.tar.gz
ports-3f9fd0160ad53cdf2315d777ce44b271516e567f.zip
Add compiler:c++11-lang to USES to fix the following on GCC-based
architectures: /usr/local/lib/libboost_filesystem.so: undefined reference to 'std::runtime_error::runtime_error(char const*)@GLIBCXX_3.4.21' While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=497662
Diffstat (limited to 'games/vamos')
-rw-r--r--games/vamos/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/vamos/Makefile b/games/vamos/Makefile
index 4abb9fdbf318..82cbc2eeb0ed 100644
--- a/games/vamos/Makefile
+++ b/games/vamos/Makefile
@@ -18,8 +18,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
libpng.so:graphics/png
+
+USES= compiler:c++11-lang libtool openal:al,alut pkgconfig
USE_CXXSTD= c++98
-USES= libtool openal:al,alut pkgconfig
USE_XORG= sm ice x11 xi xext xmu
USE_GL= glut
USE_SDL= sdl