aboutsummaryrefslogtreecommitdiff
path: root/games/vdrift-data/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-06 20:09:24 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2006-10-06 20:09:24 +0000
commita75d70501212ab5fc759166cde69b516c066fd3e (patch)
tree9272ad40b6fd19227dee865a109cca6fe7b28fc9 /games/vdrift-data/Makefile
parentcce4c384e85b4ef4e1ddda43e0d78aff814a1d49 (diff)
downloadports-a75d70501212ab5fc759166cde69b516c066fd3e.tar.gz
ports-a75d70501212ab5fc759166cde69b516c066fd3e.zip
- Update to 20061006
Notes
Notes: svn path=/head/; revision=174672
Diffstat (limited to 'games/vdrift-data/Makefile')
-rw-r--r--games/vdrift-data/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/games/vdrift-data/Makefile b/games/vdrift-data/Makefile
index 052c437f68d8..208868a649f4 100644
--- a/games/vdrift-data/Makefile
+++ b/games/vdrift-data/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= data
-PORTVERSION= 20060708
-PORTREVISION= 1
+PORTVERSION= 20061006
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= vdrift
@@ -22,7 +21,7 @@ USE_BZIP2= yes
NO_BUILD= yes
DATADIR= ${PREFIX}/share/vdrift
PLIST= ${WRKDIR}/pkg-plist
-WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}2006-02-21
+WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}2006-10-06-src
OPTIONS= MINIMAL "Install minimal requerimients of data files" off \
FULL "Install all data files" on
@@ -40,31 +39,31 @@ pre-everything::
.endif
.if defined(WITH_MINIMAL)
-DISTFILES+= ${PKGNAMEPREFIX}2006-07-08-${PORTNAME}-minimal.tar.bz2
+DISTFILES+= ${PKGNAMEPREFIX}2006-10-06-${PORTNAME}-minimal.tar.bz2
.endif
.if defined(WITH_FULL)
-DISTFILES+= ${PKGNAMEPREFIX}2006-07-08-${PORTNAME}-full.tar.bz2
+DISTFILES+= ${PKGNAMEPREFIX}2006-10-06-${PORTNAME}-full.tar.bz2
.endif
post-extract:
- @cd ${WRKDIR}/data && \
+ @cd ${WRKSRC}/data && \
${FIND} * -name SConscript -print0 | ${XARGS} -0 ${RM}
.for DIRE in settings/replays settings/screenshots carparts/turbo carparts/transmission \
carparts/suspension carparts/other carparts/exhaust carparts/engine
- @${RMDIR} ${WRKDIR}/data/${DIRE}
+ @${RMDIR} ${WRKSRC}/data/${DIRE}
.endfor
pre-install:
@${RM} -f ${PLIST}
- @cd ${WRKDIR}/data && \
+ @cd ${WRKSRC}/data && \
${FIND} * -type f | ${SORT} | ${SED} -e 's|^|%%DATADIR%%/|' >> ${PLIST} && \
${FIND} * -type d | ${SORT} -r | ${SED} -e 's|^|@dirrm %%DATADIR%%/|' >> ${PLIST}
@${ECHO_CMD} "@dirrm %%DATADIR%%" >> ${PLIST}
do-install:
${MKDIR} ${DATADIR}
- cd ${WRKDIR}/data && \
+ cd ${WRKSRC}/data && \
${FIND} * -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;