aboutsummaryrefslogtreecommitdiff
path: root/games/vegastrike
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-09-30 19:24:30 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-09-30 19:24:30 +0000
commit1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66 (patch)
tree8b44219153a720f367633c8fe248933750735b7d /games/vegastrike
parent7cb0f3c9b4ec333deb7e94ba00c6dc2d3b9c6220 (diff)
downloadports-1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66.tar.gz
ports-1ee4da6dd1d50ed85cd3a614fc8a30b02f3ccf66.zip
Let USES=localbase add -L${LOCALBASE}/lib to LIBS instead of LDFLAGS.
USES=localbase:ldflags can be used to set LDFLAGS. Normally LDFLAGS appears too early on the command line causing some ports to link with their own libraries in LOCALBASE (if installed) instead of WRKSRC. Also make use of _USES_POST so -L${LOCALBASE}/lib is added as late as possible after anything a port Makefile might set. Use _USES_POST instead of .include in libedit.mk and libarchive.mk so things like 'USES=libedit localbase:ldflags' work correctly. Fix some issues with LIBS in some ports. Switch ports that don't support LIBS to localbase:ldflags. PR: 212987 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=423014
Diffstat (limited to 'games/vegastrike')
-rw-r--r--games/vegastrike/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/vegastrike/Makefile b/games/vegastrike/Makefile
index efbdef0bf5ef..fb8522d3be0a 100644
--- a/games/vegastrike/Makefile
+++ b/games/vegastrike/Makefile
@@ -20,7 +20,8 @@ LIB_DEPENDS= libboost_python.so:devel/boost-python-libs \
libvorbis.so:audio/libvorbis \
libogg.so:audio/libogg
-USES= dos2unix gmake localbase openal:al pkgconfig python tar:bzip2
+USES= dos2unix gmake localbase:ldflags openal:al pkgconfig python \
+ tar:bzip2
GNU_CONFIGURE= yes
USE_SDL= sdl
USE_GL= glut