aboutsummaryrefslogtreecommitdiff
path: root/games/vegastrike
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2012-08-04 22:52:02 +0000
committerKoop Mast <kwm@FreeBSD.org>2012-08-04 22:52:02 +0000
commit5aa7246575084f0aefcffe71d7305d0b36b2ed33 (patch)
treea3b9f3e6c4e41379a4ad771026302ecf0ad0ae1b /games/vegastrike
parent2d4609c1309d60a953f0d9a6be96d373ca6ccfc6 (diff)
downloadports-5aa7246575084f0aefcffe71d7305d0b36b2ed33.tar.gz
ports-5aa7246575084f0aefcffe71d7305d0b36b2ed33.zip
Switch from libglut to freeglut and retire libglut. Libglut hasn't been
developed in years and has been dropped from the MESA 8.0 distribution. Freeglut is a rewrite of glut and is actively developed and is used by many linux distributions instead of libglut. Bump all ports that directly depend on libglut because of the shlib version change. There are some extra items in this patch. *) Because freeglut doesn't have the same dependancies as libglut, some ports need extra dependencies added to USE_XORG to make them build. *) Mark graphics/f90gl broken, f90gl depends on a header that is only shipped with libglut. *) Remove option for libglut/freeglut selection in games/cake, only freeglut remains now. *) While here fix a png related build issue games/vegastrike. Thanks to miwi for running the exp-run. Approved by: portmgr (miwi) Collaboration with: zeising@ Obtained from: xorg-dev staging area.
Notes
Notes: svn path=/head/; revision=302037
Diffstat (limited to 'games/vegastrike')
-rw-r--r--games/vegastrike/Makefile4
-rw-r--r--games/vegastrike/files/patch-src-gfx-vsimage.cpp11
2 files changed, 13 insertions, 2 deletions
diff --git a/games/vegastrike/Makefile b/games/vegastrike/Makefile
index d0b851be1b51..d76a9818fd50 100644
--- a/games/vegastrike/Makefile
+++ b/games/vegastrike/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vegastrike
PORTVERSION= 0.5.0
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/OldFiles
DISTNAME= vegastrike-source-${PORTVERSION}
@@ -26,6 +26,8 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_PYTHON= yes
USE_SDL= sdl
+USE_XORG= sm ice xi x11 xext xrender xinerama xi xrandr xcursor \
+ xcomposite xdamage xfixes
USE_GL= gl glu glut
USE_GNOME= gtk20
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/games/vegastrike/files/patch-src-gfx-vsimage.cpp b/games/vegastrike/files/patch-src-gfx-vsimage.cpp
index 7ce8c9d06513..75a529293995 100644
--- a/games/vegastrike/files/patch-src-gfx-vsimage.cpp
+++ b/games/vegastrike/files/patch-src-gfx-vsimage.cpp
@@ -1,5 +1,5 @@
--- src/gfx/vsimage.cpp.orig 2008-04-24 14:12:37.000000000 +0200
-+++ src/gfx/vsimage.cpp 2010-03-31 16:39:55.000000000 +0200
++++ src/gfx/vsimage.cpp 2012-06-15 21:20:32.000000000 +0200
@@ -147,7 +147,7 @@
unsigned char sig[8];
file->Begin();
@@ -18,3 +18,12 @@
png_set_expand (png_ptr);
png_read_update_info (png_ptr,info_ptr);
+@@ -865,7 +865,7 @@
+ png_destroy_write_struct(&png_ptr, (png_infopp)NULL);
+ return BadFormat;
+ }
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf( png_ptr ))) {
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ return BadFormat;
+ }