aboutsummaryrefslogtreecommitdiff
path: root/games/veloren-weekly
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-02-14 21:58:23 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-02-15 00:59:23 +0000
commit1ab35236f75037b806db9bfe7b99aad9fe1cffc0 (patch)
treeb5a8aeb1f421bbca5835ffa255bb29679d5955c6 /games/veloren-weekly
parente5ea17138f44b50da6b08d60d9d864d2917612e9 (diff)
downloadports-1ab35236f75037b806db9bfe7b99aad9fe1cffc0.tar.gz
ports-1ab35236f75037b806db9bfe7b99aad9fe1cffc0.zip
games/veloren-weekly: update to s20240214
Diffstat (limited to 'games/veloren-weekly')
-rw-r--r--games/veloren-weekly/Makefile4
-rw-r--r--games/veloren-weekly/distinfo6
-rw-r--r--games/veloren-weekly/files/patch-unix40
3 files changed, 39 insertions, 11 deletions
diff --git a/games/veloren-weekly/Makefile b/games/veloren-weekly/Makefile
index 0d6e7976ec9f..d259d2f8f2b2 100644
--- a/games/veloren-weekly/Makefile
+++ b/games/veloren-weekly/Makefile
@@ -1,5 +1,5 @@
PORTNAME= veloren
-PORTVERSION= s20240211
+PORTVERSION= s20240214
CATEGORIES= games wayland
PKGNAMESUFFIX= -weekly
@@ -25,7 +25,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:audio/alsa-pl
USES= cargo xorg
USE_XORG= xcb
USE_GITLAB= yes
-GL_TAGNAME= v0.15.0-1141-gf159dd535 # git describe --match='v[0-9]*' weekly
+GL_TAGNAME= v0.15.0-1160-g5c4e68cce # git describe --match='v[0-9]*' weekly
CARGO_ENV= VELOREN_USERDATA_STRATEGY=system SHADERC_LIB_DIR="${LOCALBASE}/lib"
PLIST_FILES= bin/${PORTNAME}-server-cli \
bin/${PORTNAME}-voxygen \
diff --git a/games/veloren-weekly/distinfo b/games/veloren-weekly/distinfo
index ee5785d065c0..a17449a84ca7 100644
--- a/games/veloren-weekly/distinfo
+++ b/games/veloren-weekly/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1707681816
+TIMESTAMP = 1707953009
SHA256 (rust/crates/ab_glyph-0.2.23.crate) = 80179d7dd5d7e8c285d67c4a1e652972a92de7475beddfb92028c76463b13225
SIZE (rust/crates/ab_glyph-0.2.23.crate) = 18537
SHA256 (rust/crates/ab_glyph_rasterizer-0.1.8.crate) = c71b1793ee61086797f5c80b6efa2b8ffa6d5dd703f118545808a7f2e27f7046
@@ -1617,5 +1617,5 @@ SHA256 (IsseW-wgpu-5ea16016402bb83b4ccd7ac8e6d4b0a2f85da6a0_GH0.tar.gz) = 65b2e7
SIZE (IsseW-wgpu-5ea16016402bb83b4ccd7ac8e6d4b0a2f85da6a0_GH0.tar.gz) = 9995366
SHA256 (xMAC94x-portpicker-rs-df6b37872f3586ac3b21d08b56c8ec7cd92fb172_GH0.tar.gz) = 29252101e189bbe067f0bacba18181afc69a2fb9bc031bbba8dcbade45dec02f
SIZE (xMAC94x-portpicker-rs-df6b37872f3586ac3b21d08b56c8ec7cd92fb172_GH0.tar.gz) = 2210
-SHA256 (veloren-v0.15.0-1141-gf159dd535.tar.bz2) = c1fd8c12754d787aa1d86da7778c1c3ca42950f3f17ececfefa05e433662c597
-SIZE (veloren-v0.15.0-1141-gf159dd535.tar.bz2) = 290587691
+SHA256 (veloren-v0.15.0-1160-g5c4e68cce.tar.bz2) = 51aa543152cb711d062d0718945423ae541515c23efd6d48fe722a64cc548257
+SIZE (veloren-v0.15.0-1160-g5c4e68cce.tar.bz2) = 290606883
diff --git a/games/veloren-weekly/files/patch-unix b/games/veloren-weekly/files/patch-unix
index cfcc77aa4d91..732a4f05a035 100644
--- a/games/veloren-weekly/files/patch-unix
+++ b/games/veloren-weekly/files/patch-unix
@@ -1,16 +1,44 @@
Relax Linux checks for the code works on any non-Windows platform.
---- server-cli/src/main.rs.orig 2024-01-31 15:30:47 UTC
+--- server-cli/src/main.rs.orig 2024-02-14 21:58:23 UTC
+++ server-cli/src/main.rs
-@@ -57,7 +57,7 @@ fn main() -> io::Result<()> {
-
- let sigusr1_signal = Arc::new(AtomicBool::new(false));
+@@ -66,14 +66,14 @@ fn main() -> io::Result<()> {
+ // Load settings
+ let settings = settings::Settings::load();
- #[cfg(any(target_os = "linux", target_os = "macos"))]
+ #[cfg(not(target_os = "windows"))]
- let _ = signal_hook::flag::register(signal_hook::consts::SIGUSR1, Arc::clone(&sigusr1_signal));
+ {
+ for signal in &settings.shutdown_signals {
+ let _ = signal_hook::flag::register(signal.to_signal(), Arc::clone(&shutdown_signal));
+ }
+ }
+
+- #[cfg(not(any(target_os = "linux", target_os = "macos")))]
++ #[cfg(target_os = "windows")]
+ if !settings.shutdown_signals.is_empty() {
+ tracing::warn!(
+ "Server configuration contains shutdown signals, but your platform does not support \
+--- server-cli/src/settings.rs.orig 2024-02-14 21:58:23 UTC
++++ server-cli/src/settings.rs
+@@ -15,7 +15,7 @@ impl ShutdownSignal {
+ }
- let (_guards, _guards2) = if basic {
+ impl ShutdownSignal {
+- #[cfg(any(target_os = "linux", target_os = "macos"))]
++ #[cfg(not(target_os = "windows"))]
+ pub fn to_signal(self) -> core::ffi::c_int {
+ match self {
+ Self::SIGUSR1 => signal_hook::consts::SIGUSR1,
+@@ -44,7 +44,7 @@ impl Default for Settings {
+ update_shutdown_message: "The server is restarting for an update".to_owned(),
+ web_address: SocketAddr::from((Ipv4Addr::LOCALHOST, 14005)),
+ web_chat_secret: None,
+- shutdown_signals: if cfg!(any(target_os = "linux", target_os = "macos")) {
++ shutdown_signals: if cfg!(not(target_os = "windows")) {
+ vec![ShutdownSignal::SIGUSR1]
+ } else {
+ Vec::new()
--- voxygen/src/main.rs.orig 2024-02-07 19:13:27 UTC
+++ voxygen/src/main.rs
@@ -51,7 +51,7 @@ fn main() {