aboutsummaryrefslogtreecommitdiff
path: root/games/violetland
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-01-31 13:38:42 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-01-31 13:38:42 +0000
commitf5f6cd6d9b51abcfaf7d5a03d342e91dc742074d (patch)
tree384a6fe89b7bf8bffcc478f3462d538eea755790 /games/violetland
parent49be72eaa4585216ade79b274fca337c2bf4866a (diff)
downloadports-f5f6cd6d9b51abcfaf7d5a03d342e91dc742074d.tar.gz
ports-f5f6cd6d9b51abcfaf7d5a03d342e91dc742074d.zip
Chase boost update
Notes
Notes: svn path=/head/; revision=311310
Diffstat (limited to 'games/violetland')
-rw-r--r--games/violetland/Makefile4
-rw-r--r--games/violetland/files/patch-boost-1.5241
2 files changed, 44 insertions, 1 deletions
diff --git a/games/violetland/Makefile b/games/violetland/Makefile
index bf5020a0cf29..a9941a07a4e6 100644
--- a/games/violetland/Makefile
+++ b/games/violetland/Makefile
@@ -3,6 +3,7 @@
PORTNAME= violetland
PORTVERSION= 0.4.3
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= GOOGLE_CODE \
http://mirror.amdmi3.ru/distfiles/
@@ -11,7 +12,7 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}-src
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Top-down survival shoot 'em up
-LIB_DEPENDS= boost_filesystem.4:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= boost_filesystem:${PORTSDIR}/devel/boost-libs
USE_ZIP= yes
USE_SDL= sdl mixer image ttf
@@ -19,6 +20,7 @@ USE_GL= gl glu
MAKE_JOBS_SAFE= yes
USE_CMAKE= yes
USE_GETTEXT= yes
+USE_DOS2UNIX= yes
CMAKE_ARGS= -DDATA_INSTALL_DIR="${DATADIR}"
WRKSRC= ${WRKDIR}/${PORTNAME}-v${PORTVERSION}
diff --git a/games/violetland/files/patch-boost-1.52 b/games/violetland/files/patch-boost-1.52
new file mode 100644
index 000000000000..c90329f43b04
--- /dev/null
+++ b/games/violetland/files/patch-boost-1.52
@@ -0,0 +1,41 @@
+--- CMakeLists.txt.old 2012-11-05 15:19:11.501044743 +0100
++++ CMakeLists.txt 2012-11-05 15:19:25.415250207 +0100
+@@ -8,7 +8,6 @@
+ find_package(SDL_mixer REQUIRED)
+ find_package(OpenGL REQUIRED)
+ find_package(Boost COMPONENTS filesystem system REQUIRED)
+-add_definitions(-DBOOST_FILESYSTEM_VERSION=2)
+
+ if(${MINGW})
+ set(INTL_LIBRARY intl)
+--- src/system/utility/FileUtility.cpp.old 2012-11-05 21:26:07.865488297 +0100
++++ src/system/utility/FileUtility.cpp 2012-11-05 21:30:44.881208230 +0100
+@@ -20,7 +20,7 @@
+
+ while (dir_it != boost::filesystem::directory_iterator()) {
+ if (boost::filesystem::is_regular_file(*dir_it))
+- files.push_back(dir_it->filename());
++ files.push_back(dir_it->path().filename().string());
+ ++dir_it;
+ }
+ return files;
+@@ -32,8 +32,8 @@
+
+ while (dir_it != boost::filesystem::directory_iterator()) {
+ if (boost::filesystem::is_directory(*dir_it))
+- if (dir_it->path().filename()[0] != '.')
+- subDirs.push_back(dir_it->path().filename());
++ if (dir_it->path().filename().string()[0] != '.')
++ subDirs.push_back(dir_it->path().filename().string());
+ ++dir_it;
+ }
+ return subDirs;
+@@ -45,7 +45,7 @@
+
+ while (dir_it != boost::filesystem::directory_iterator()) {
+ if (boost::filesystem::is_directory(*dir_it))
+- if (dir_it->path().filename()[0] != '.')
++ if (dir_it->path().filename().string()[0] != '.')
+ ++count;
+ ++dir_it;
+ }