aboutsummaryrefslogtreecommitdiff
path: root/games/vms-empire/Makefile
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-12-15 08:06:55 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-12-15 08:06:55 +0000
commit2dbb5ddf0a2ee2258894144f53592cb544654994 (patch)
tree4917b81d3b6f3832cf343a2788fc762f609010a5 /games/vms-empire/Makefile
parent85ddce8024f86edd4a453a55a7b8718ff7af9972 (diff)
downloadports-2dbb5ddf0a2ee2258894144f53592cb544654994.tar.gz
ports-2dbb5ddf0a2ee2258894144f53592cb544654994.zip
- Update to 1.13, announce message:
Comment on entry to and exit from edit mode. Cleaned up packaging and install/uninstall productions. - Rename from games/empire to games/vms-empire to match Upstream name - Remove DISTNAME - Change PLIST_FILES, changed by me and Upstream - Remove obsolete REINPLACE - Simplify installation handling, changed by me and Upstream - Add REINPLACE, fix GNU/Linux paths - Strip executable - Change pkg-descr
Notes
Notes: svn path=/head/; revision=374736
Diffstat (limited to 'games/vms-empire/Makefile')
-rw-r--r--games/vms-empire/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/games/vms-empire/Makefile b/games/vms-empire/Makefile
new file mode 100644
index 000000000000..814a83f1393f
--- /dev/null
+++ b/games/vms-empire/Makefile
@@ -0,0 +1,35 @@
+# Created by: Andrey Zakhvatov
+# $FreeBSD$
+
+PORTNAME= vms-empire
+PORTVERSION= 1.13
+CATEGORIES= games
+MASTER_SITES= http://www.catb.org/~esr/vms-empire/
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Simulation of a full-scale war between two emperors
+
+LICENSE= GPLv2
+
+PORTDOCS= AUTHORS BUGS HACKING NEWS README
+OPTIONS_DEFINE= DOCS
+
+PLIST_FILES= bin/${PORTNAME} \
+ man/man6/${PORTNAME}.6.gz \
+ share/appdata/${PORTNAME}.xml \
+ ${DESKTOPDIR}/${PORTNAME}.desktop \
+ share/icons/hicolor/48x48/apps/${PORTNAME}.png
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CFLAGS|CFLAGS?|; \
+ s|/usr/bin|${PREFIX}/bin|; \
+ s|/usr/share/|${PREFIX}/share/|; \
+ s|/usr/local/share/man|${PREFIX}/man|' \
+ ${WRKSRC}/Makefile
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>