aboutsummaryrefslogtreecommitdiff
path: root/games/wargus
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-12-24 09:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2022-02-25 19:12:28 +0000
commit601bb414d25aaf9803f1bc8ad380ea218218f78f (patch)
tree452e3e4521334c371cb0e2177aef433c23807a99 /games/wargus
parentc9f5fec2c6a3bacd891052491076366f1db4369c (diff)
downloadports-601bb414d25aaf9803f1bc8ad380ea218218f78f.tar.gz
ports-601bb414d25aaf9803f1bc8ad380ea218218f78f.zip
games/wargus: add stormlib support
PR: 260561, 260563 Submitted by: agh@riseup.net
Diffstat (limited to 'games/wargus')
-rw-r--r--games/wargus/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/games/wargus/Makefile b/games/wargus/Makefile
index b30f77a409e9..eda95cd0e129 100644
--- a/games/wargus/Makefile
+++ b/games/wargus/Makefile
@@ -2,6 +2,7 @@
PORTNAME= wargus
PORTVERSION= 3.2.0
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= games
@@ -23,13 +24,17 @@ GH_ACCOUNT= Wargus
USES= cmake compiler:c++11-lang pkgconfig
CMAKE_ARGS= -DGAMEDIR:STRING="bin" \
-DSHAREDIR:STRING="${DATADIR_REL}"
-CMAKE_OFF= WITH_STORMLIB # not in ports
SUB_FILES= pkg-message
PORTDATA= *
PORTDOCS= *
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS STORMLIB
+OPTIONS_DEFAULT=STORMLIB
+
+STORMLIB_DESC= Enable StormLib support
+STORMLIB_CMAKE_BOOL= WITH_STORMLIB StormLib_FIND_REQUIRED
+STORMLIB_LIB_DEPENDS= libstorm.so:archivers/stormlib
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/*.6 ${STAGEDIR}${MAN6PREFIX}/share/man/man6/