aboutsummaryrefslogtreecommitdiff
path: root/games/wesnoth
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-02-08 14:02:15 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-02-08 14:02:15 +0000
commit080c9f314cbc4d04083474a102bd370b5fdddc65 (patch)
treefbd2e339a69cee2e02f79383a1d688b4a3d00d04 /games/wesnoth
parent0bf9ab1b91cf3075fc68ee71d2d486de73748f97 (diff)
downloadports-080c9f314cbc4d04083474a102bd370b5fdddc65.tar.gz
ports-080c9f314cbc4d04083474a102bd370b5fdddc65.zip
Update to 0.8.10, see the changelog for details: http://changelog.wesnoth.org/
Notes
Notes: svn path=/head/; revision=128274
Diffstat (limited to 'games/wesnoth')
-rw-r--r--games/wesnoth/Makefile4
-rw-r--r--games/wesnoth/distinfo8
-rw-r--r--games/wesnoth/files/patch-src::game.cpp18
3 files changed, 23 insertions, 7 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 08c85c6fda65..4648fa49bfc1 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= wesnoth
-PORTVERSION= 0.8.9
+PORTVERSION= 0.8.10
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.wesnoth.org/files/
@@ -124,7 +124,5 @@ post-patch:
@${REINPLACE_CMD} -e 's|[$$][(]datadir[)]/applications|${X11BASE}/share/gnome/apps/Games|g ; \
s|[$$][(]datadir[)]/icons|${X11BASE}/share/gnome/pixmaps|g' \
${WRKSRC}/icons/Makefile.in
- @${REINPLACE_CMD} -e 's|@SDL_CFLAGS@|@SDL_CFLAGS@ -I../sdl_ttf|g' \
- ${WRKSRC}/src/tools/Makefile.in
.include <bsd.port.post.mk>
diff --git a/games/wesnoth/distinfo b/games/wesnoth/distinfo
index 6f2a7baf899d..bae41976f2f8 100644
--- a/games/wesnoth/distinfo
+++ b/games/wesnoth/distinfo
@@ -1,4 +1,4 @@
-MD5 (wesnoth-0.8.9.tar.gz) = 4a4a0b68d3895dae86337c04812e4952
-SIZE (wesnoth-0.8.9.tar.gz) = 36499929
-MD5 (wesnoth-lite-0.8.9.tar.gz) = 4d46efe6c5c74527c7d6b89fa1411b41
-SIZE (wesnoth-lite-0.8.9.tar.gz) = 20702849
+MD5 (wesnoth-0.8.10.tar.gz) = 0fbda4c35f0a6cf9f18df453a7f83f7c
+SIZE (wesnoth-0.8.10.tar.gz) = 36687797
+MD5 (wesnoth-lite-0.8.10.tar.gz) = cb1ee68e19958a0a38e9a5a0af31161a
+SIZE (wesnoth-lite-0.8.10.tar.gz) = 20886365
diff --git a/games/wesnoth/files/patch-src::game.cpp b/games/wesnoth/files/patch-src::game.cpp
new file mode 100644
index 000000000000..d9ef6b95584f
--- /dev/null
+++ b/games/wesnoth/files/patch-src::game.cpp
@@ -0,0 +1,18 @@
+--- src/game.cpp.orig Mon Feb 7 20:32:47 2005
++++ src/game.cpp Mon Feb 7 20:32:56 2005
+@@ -1,4 +1,4 @@
+-/* $Id: game.cpp,v 1.188 2005/02/06 10:40:12 isaaccp Exp $ */
++/* $Id: game.cpp,v 1.189 2005/02/06 21:31:27 silene Exp $ */
+ /*
+ Copyright (C) 2003 by David White <davidnwhite@optusnet.com.au>
+ Part of the Battle for Wesnoth Project http://wesnoth.whitevine.net
+@@ -1514,7 +1514,8 @@
+ // initialized to have get_intl_dir() to work. Note: this
+ // setlocale() but this does not take GUI language setting
+ // into account.
+- setlocale (LC_ALL, "");
++ setlocale(LC_ALL, "C");
++ setlocale(LC_MESSAGES, "");
+ const std::string& intl_dir = get_intl_dir();
+ bindtextdomain (PACKAGE, intl_dir.c_str());
+ bind_textdomain_codeset (PACKAGE, "UTF-8");