aboutsummaryrefslogtreecommitdiff
path: root/games/wesnoth
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2009-09-02 08:53:51 +0000
committerPhilip Paeps <philip@FreeBSD.org>2009-09-02 08:53:51 +0000
commitd4ea1c8240656aa1cccb8bcaa3a421c363bbd16a (patch)
treea6b8d3d58b5063479d2b0027ee0c69ed27838428 /games/wesnoth
parent41e1eee13cbf01e5cbbb60867cb6a8b9ec130c77 (diff)
downloadports-d4ea1c8240656aa1cccb8bcaa3a421c363bbd16a.tar.gz
ports-d4ea1c8240656aa1cccb8bcaa3a421c363bbd16a.zip
Fix fribidi2 detection and use using pkg-config.
- use autotools - copy fixes from wesnoth 1.7.3 (actually r36767 and r37394) for files configure.ac src/Makefile.am src/font.cpp - adapt existing patches for automake run: patch-Makefile.in -> patch-Makefile.am patch-src-Makefile.in -> patch-src-Makefile.am PR: ports/138105 Submitted by: Anonymous <swell.k@gmail.com>
Notes
Notes: svn path=/head/; revision=240701
Diffstat (limited to 'games/wesnoth')
-rw-r--r--games/wesnoth/Makefile4
-rw-r--r--games/wesnoth/files/patch-Makefile.am11
-rw-r--r--games/wesnoth/files/patch-Makefile.in11
-rw-r--r--games/wesnoth/files/patch-configure.ac56
-rw-r--r--games/wesnoth/files/patch-src-Makefile.am34
-rw-r--r--games/wesnoth/files/patch-src-Makefile.in11
-rw-r--r--games/wesnoth/files/patch-src-font.cpp44
-rw-r--r--games/wesnoth/files/patch-src_font.cpp14
8 files changed, 148 insertions, 37 deletions
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index c32a155ab2f9..bbb287426c69 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -27,7 +27,9 @@ USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
WANT_GNOME= yes
USE_BZIP2= yes
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= aclocal:110 autoheader:262 automake:110 autoconf:262
+ACLOCAL_ARGS= -Im4
+AUTOMAKE_ARGS= --add-missing --copy
CONFIGURE_ARGS= --localstatedir=/var \
--with-libiconv-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE} \
diff --git a/games/wesnoth/files/patch-Makefile.am b/games/wesnoth/files/patch-Makefile.am
new file mode 100644
index 000000000000..94a713e45171
--- /dev/null
+++ b/games/wesnoth/files/patch-Makefile.am
@@ -0,0 +1,11 @@
+--- Makefile.am~
++++ Makefile.am
+@@ -5,7 +5,7 @@ pkgdatadir=$(datadir)/@DATADIR@
+ bin_SCRIPTS =
+
+ # Ignore junk -- object files, editor backup files, wmllint backup files.
+-findfilterflags=! \( -name .svn -prune -o -name ".\#*" -o -name "*~" -o -name "*bak" -o -name 'Makefile' -o -name '*Makefile' -o -type d -o -wholename "data/test/*" \)
++findfilterflags=! \( -name .svn -prune -o -name ".\#*" -o -name "*~" -o -name "*bak" -o -name 'Makefile' -o -name '*Makefile' -o -type d -o -path "data/test/*" \)
+
+ # List all datafiles, ignoring junk
+ finddata=(cd $(top_srcdir) && find data fonts icons images sounds $(findfilterflags) -print )
diff --git a/games/wesnoth/files/patch-Makefile.in b/games/wesnoth/files/patch-Makefile.in
deleted file mode 100644
index 67524d8aeb8b..000000000000
--- a/games/wesnoth/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig 2009-03-24 16:52:32.000000000 +0100
-+++ Makefile.in 2009-03-24 16:52:43.000000000 +0100
-@@ -279,7 +279,7 @@
- bin_SCRIPTS =
-
- # Ignore junk -- object files, editor backup files, wmllint backup files.
--findfilterflags = ! \( -name .svn -prune -o -name ".\#*" -o -name "*~" -o -name "*bak" -o -name 'Makefile' -o -name '*Makefile' -o -type d -o -wholename "data/test/*" \)
-+findfilterflags = ! \( -name .svn -prune -o -name ".\#*" -o -name "*~" -o -name "*bak" -o -name 'Makefile' -o -name '*Makefile' -o -type d -o -path "data/test/*" \)
-
- # List all datafiles, ignoring junk
- finddata = (cd $(top_srcdir) && find data fonts icons images sounds $(findfilterflags) -print )
diff --git a/games/wesnoth/files/patch-configure.ac b/games/wesnoth/files/patch-configure.ac
new file mode 100644
index 000000000000..48f95633b96e
--- /dev/null
+++ b/games/wesnoth/files/patch-configure.ac
@@ -0,0 +1,56 @@
+--- configure.ac~
++++ configure.ac
+@@ -111,7 +111,7 @@ then
+ fi
+
+ # Make tests default in svn version
+-svn_in_version=`expr match "$WESNOTH_VERSION" '.*svn'`
++svn_in_version=`expr "$WESNOTH_VERSION" : '.*svn'`
+ test_build=yes
+ if test $svn_in_version = 0
+ then
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 36766)
++++ configure.ac (revision 37394)
+@@ -416,21 +416,27 @@
+
+ # fribidi-config
+
+-AC_PATH_PROGS([FRIBIDI_CONFIG], [fribidi-config], [none])
+-
+-if test "x$FRIBIDI_CONFIG" = "xnone"; then
+- fribidifound=no
+- AC_MSG_WARN([*** FRIBIDI not found.])
+-else
+- fribidifound=yes
+- FRIBIDI_CFLAGS=`$FRIBIDI_CONFIG --cflags`
+- FRIBIDI_LIBS=`$FRIBIDI_CONFIG --libs`
++if test "x$fribidi" != "xno"; then
++ PKG_CHECK_MODULES([FRIBIDI2], [fribidi >= 0.19.0],
++ [
++ fribidifound=yes
++ ],
++ [
++ AC_MSG_RESULT(no)
++ PKG_CHECK_MODULES([FRIBIDI], [fribidi],
++ [
++ fribidifound=yes
++ oldfribidi=yes
++ ],
++ [
++ fribidifound=no
++ AC_MSG_RESULT(no)
++ ])
++ ])
++ AM_CONDITIONAL([FRIBIDI], [test "x$fribidifound" = xyes])
++ AM_CONDITIONAL([OLD_FRIBIDI], [test "x$oldfribidi" = xyes])
+ fi
+
+-AC_SUBST([FRIBIDI_CFLAGS])
+-AC_SUBST([FRIBIDI_LIBS])
+-AM_CONDITIONAL([FRIBIDI], [test "x$fribidifound" = xyes -a "x$fribidi" = xyes ])
+-
+ # python
+ AC_PATH_PROG(PYTHON, python, none)
+ AC_SUBST(pkgpythondir)
diff --git a/games/wesnoth/files/patch-src-Makefile.am b/games/wesnoth/files/patch-src-Makefile.am
new file mode 100644
index 000000000000..00646474e20b
--- /dev/null
+++ b/games/wesnoth/files/patch-src-Makefile.am
@@ -0,0 +1,34 @@
+--- src/Makefile.am~
++++ src/Makefile.am
+@@ -400,7 +400,7 @@ game_config.o: revision.hpp
+ REVISION = $(shell LC_ALL=C svnversion -n $(topdir) 2>/dev/null)
+ .PRECIOUS: revision.hpp
+ revision.hpp: FORCE
+- if [ "$(REVISION)" == "" ] || [ "$(REVISION)" == "exported" ]; then echo '' >/tmp/westemp$$$$; \
++ if [ "$(REVISION)" = "" ] || [ "$(REVISION)" = "exported" ]; then echo '' >/tmp/westemp$$$$; \
+ else echo '#define REVISION "$(REVISION)"' >/tmp/westemp$$$$; fi;\
+ if cmp -s revision.hpp /tmp/westemp$$$$ 2>/dev/null; then :; else cp /tmp/westemp$$$$ revision.hpp; fi; \
+ if [ -e /tmp/westemp$$$$ ]; then rm /tmp/westemp$$$$; fi
+Index: src/Makefile.am
+===================================================================
+--- src/Makefile.am (revision 37393)
++++ src/Makefile.am (revision 37394)
+@@ -485,10 +485,16 @@
+ -DLOCALEDIR=\"$(LOCALEDIR)\" -DHAS_RELATIVE_LOCALEDIR=$(HAS_RELATIVE_LOCALEDIR)
+
+ if FRIBIDI
+- AM_CXXFLAGS += -DHAVE_FRIBIDI @FRIBIDI_CFLAGS@
+- AM_CFLAGS += -DHAVE_FRIBIDI @FRIBIDI_CFLAGS@
++if OLD_FRIBIDI
++ CXXFLAGS += -DOLD_FRIBIDI @FRIBIDI_CFLAGS@
++ CFLAGS += -DOLD_FRIBIDI @FRIBIDI_CFLAGS@
+ THELIBS += @FRIBIDI_LIBS@
++else
++ CXXFLAGS += -DHAVE_FRIBIDI @FRIBIDI2_CFLAGS@
++ CFLAGS += -DHAVE_FRIBIDI @FRIBIDI2_CFLAGS@
++ THELIBS += @FRIBIDI2_LIBS@
+ endif
++endif
+
+ if X11
+ CXXFLAGS += -D_X11 @X_CFLAGS@
diff --git a/games/wesnoth/files/patch-src-Makefile.in b/games/wesnoth/files/patch-src-Makefile.in
deleted file mode 100644
index 13f43fc9c441..000000000000
--- a/games/wesnoth/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig 2008-11-02 19:33:40.000000000 +0100
-+++ src/Makefile.in 2008-11-02 19:33:49.000000000 +0100
-@@ -1783,7 +1783,7 @@
- game_config.o: revision.hpp
- .PRECIOUS: revision.hpp
- revision.hpp: FORCE
-- if [ "$(REVISION)" == "" ] || [ "$(REVISION)" == "exported" ]; then echo '' >/tmp/westemp$$$$; \
-+ if [ "$(REVISION)" = "" ] || [ "$(REVISION)" = "exported" ]; then echo '' >/tmp/westemp$$$$; \
- else echo '#define REVISION "$(REVISION)"' >/tmp/westemp$$$$; fi;\
- if cmp -s revision.hpp /tmp/westemp$$$$ 2>/dev/null; then :; else cp /tmp/westemp$$$$ revision.hpp; fi; \
- if [ -e /tmp/westemp$$$$ ]; then rm /tmp/westemp$$$$; fi
diff --git a/games/wesnoth/files/patch-src-font.cpp b/games/wesnoth/files/patch-src-font.cpp
new file mode 100644
index 000000000000..301914022384
--- /dev/null
+++ b/games/wesnoth/files/patch-src-font.cpp
@@ -0,0 +1,44 @@
+Index: src/font.cpp
+===================================================================
+--- src/font.cpp (revision 36766)
++++ src/font.cpp (revision 37394)
+@@ -50,10 +50,7 @@
+ #define ERR_FT LOG_STREAM(err, log_font)
+
+ #ifdef HAVE_FRIBIDI
+-#include <fribidi/fribidi.h>
+-
+-#else
+-
++#include <fribidi.h>
+ #endif
+
+ namespace {
+@@ -467,16 +464,25 @@
+ void text_surface::bidi_cvt()
+ {
+ char *c_str = const_cast<char *>(str_.c_str()); // fribidi forgot const...
+- int len = str_.length();
++ FriBidiStrIndex len = str_.length();
+ FriBidiChar *bidi_logical = new FriBidiChar[len + 2];
+ FriBidiChar *bidi_visual = new FriBidiChar[len + 2];
+ char *utf8str = new char[4*len + 1]; //assume worst case here (all 4 Byte characters)
+ FriBidiCharType base_dir = FRIBIDI_TYPE_ON;
+- int n;
++ FriBidiStrIndex n;
+
++
++#ifdef OLD_FRIBIDI
+ n = fribidi_utf8_to_unicode (c_str, len, bidi_logical);
++#else
++ n = fribidi_charset_to_unicode(FRIBIDI_CHAR_SET_UTF8, c_str, len, bidi_logical);
++#endif
+ fribidi_log2vis(bidi_logical, n, &base_dir, bidi_visual, NULL, NULL, NULL);
++#ifdef OLD_FRIBIDI
+ fribidi_unicode_to_utf8 (bidi_visual, n, utf8str);
++#else
++ fribidi_unicode_to_charset(FRIBIDI_CHAR_SET_UTF8, bidi_visual, n, utf8str);
++#endif
+ is_rtl_ = base_dir == FRIBIDI_TYPE_RTL;
+ str_ = std::string(utf8str);
+ delete[] bidi_logical;
diff --git a/games/wesnoth/files/patch-src_font.cpp b/games/wesnoth/files/patch-src_font.cpp
deleted file mode 100644
index 4497d7c7296b..000000000000
--- a/games/wesnoth/files/patch-src_font.cpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/font.cpp.orig 2009-08-24 23:47:26.000000000 -0400
-+++ src/font.cpp 2009-08-24 23:48:51.000000000 -0400
-@@ -474,9 +474,9 @@ void text_surface::bidi_cvt()
- FriBidiCharType base_dir = FRIBIDI_TYPE_ON;
- int n;
-
-- n = fribidi_utf8_to_unicode (c_str, len, bidi_logical);
-+ n = fribidi_charset_to_unicode (FRIBIDI_CHAR_SET_UTF8, c_str, len, bidi_logical);
- fribidi_log2vis(bidi_logical, n, &base_dir, bidi_visual, NULL, NULL, NULL);
-- fribidi_unicode_to_utf8 (bidi_visual, n, utf8str);
-+ fribidi_unicode_to_charset (FRIBIDI_CHAR_SET_UTF8, bidi_visual, n, utf8str);
- is_rtl_ = base_dir == FRIBIDI_TYPE_RTL;
- str_ = std::string(utf8str);
- delete[] bidi_logical;