aboutsummaryrefslogtreecommitdiff
path: root/games/widelands
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /games/widelands
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'games/widelands')
-rw-r--r--games/widelands/Makefile6
-rw-r--r--games/widelands/files/patch-src-graphic-SDL_mng.cc35
2 files changed, 39 insertions, 2 deletions
diff --git a/games/widelands/Makefile b/games/widelands/Makefile
index 8f46dbfef84b..9f1360f16a3f 100644
--- a/games/widelands/Makefile
+++ b/games/widelands/Makefile
@@ -7,7 +7,7 @@
PORTNAME= widelands
DISTVERSION= build16
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
MASTER_SITES= http://launchpadlibrarian.net/69520494/ \
http://mirror.amdmi3.ru/distfiles/
@@ -17,12 +17,13 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Realtime strategy game inspired by Settlers II
LIB_DEPENDS= ggzcore.9:${PORTSDIR}/games/ggz-client-libs \
- png.6:${PORTSDIR}/graphics/png \
+ png15:${PORTSDIR}/graphics/png \
GLEW.1:${PORTSDIR}/graphics/glew
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
USE_BZIP2= yes
USE_CMAKE= yes
+USE_GETTEXT= yes
CMAKE_OUTSOURCE=yes
CMAKE_ARGS= -DWL_INSTALL_PREFIX="${PREFIX}" \
-DWL_INSTALL_DATADIR="share/widelands" \
@@ -31,6 +32,7 @@ CMAKE_ARGS= -DWL_INSTALL_PREFIX="${PREFIX}" \
USE_LUA= 5.1+
USE_SDL= sdl mixer image net ttf gfx
USE_PYTHON_BUILD=2.5+
+CFLAGS+= -I${LOCALBASE}/include/libpng15
MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/widelands
diff --git a/games/widelands/files/patch-src-graphic-SDL_mng.cc b/games/widelands/files/patch-src-graphic-SDL_mng.cc
new file mode 100644
index 000000000000..b7abbd1cc1e0
--- /dev/null
+++ b/games/widelands/files/patch-src-graphic-SDL_mng.cc
@@ -0,0 +1,35 @@
+--- src/graphic/SDL_mng.cc.orig 2011-04-15 20:40:26.000000000 +0200
++++ src/graphic/SDL_mng.cc 2012-05-03 23:15:20.000000000 +0200
+@@ -26,6 +26,7 @@
+ #include <SDL_endian.h>
+
+ #include <png.h>
++#include <pngpriv.h>
+
+ /* Chunk structure */
+ struct chunk_t {
+@@ -230,7 +231,7 @@
+ }
+
+ /* png_read_data callback; return <size> bytes from wherever */
+-static void png_read_data(png_structp ctx, png_bytep area, png_size_t size)
++static void local_png_read_data(png_structp ctx, png_bytep area, png_size_t size)
+ {
+ SDL_RWread(static_cast<SDL_RWops *>(png_get_io_ptr(ctx)), area, size, 1);
+ }
+@@ -276,13 +277,13 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in png_create_read_struct() earlier.
+ */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ SDL_SetError("Error reading the PNG file.");
+ goto done;
+ }
+
+ /* Set up the input control */
+- png_set_read_fn(png_ptr, src, png_read_data);
++ png_set_read_fn(png_ptr, src, local_png_read_data);
+
+ /* tell PNG not to read the signature */
+ png_set_sig_bytes(png_ptr, 8);