aboutsummaryrefslogtreecommitdiff
path: root/games/wxlauncher
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-09-24 18:10:04 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-09-24 18:10:04 +0000
commit789f1b90798565d33cf39b930567144c84c02886 (patch)
tree6c394fe15aa6bd805a3b69f44b2a96078ace7698 /games/wxlauncher
parent837ff9f943b8f549ce0f4fe6f48948cadacdc99b (diff)
downloadports-789f1b90798565d33cf39b930567144c84c02886.tar.gz
ports-789f1b90798565d33cf39b930567144c84c02886.zip
games/wxlauncher: update to 0.10.0
- Change GH_ACCOUNT, GH_PROJECT and WWW to new GitHub address - Add pkgconfig to USES - Change USE_SDL value to sdl2, because of new dependency - Explicitly define used wxWidgets version through WXVER CMake's define - Adapt patches for new version - Remove WX_UNICODE define, after ports r397085 changes Changes: https://github.com/scp-fs2open/wxLauncher/compare/release-0.9.6...release-0.10.0 PR: 202939 Submitted by: lightside <lightside@gmx.com> (maintainer)
Notes
Notes: svn path=/head/; revision=397703
Diffstat (limited to 'games/wxlauncher')
-rw-r--r--games/wxlauncher/Makefile24
-rw-r--r--games/wxlauncher/distinfo4
-rw-r--r--games/wxlauncher/files/patch-code_apis_JoystickManager.cpp18
-rw-r--r--games/wxlauncher/pkg-descr2
4 files changed, 20 insertions, 28 deletions
diff --git a/games/wxlauncher/Makefile b/games/wxlauncher/Makefile
index a553469dedc5..eb7410704a6d 100644
--- a/games/wxlauncher/Makefile
+++ b/games/wxlauncher/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= wxlauncher
-PORTVERSION= 0.9.6
+PORTVERSION= 0.10.0
DISTVERSIONPREFIX= release-
-PORTREVISION= 2
CATEGORIES= games
MAINTAINER= lightside@gmx.com
@@ -17,11 +16,11 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}markdown>0:${PORTSDIR}/textproc/py-markdow
${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
USE_GITHUB= yes
-GH_ACCOUNT= wxLauncher
+GH_ACCOUNT= scp-fs2open
+GH_PROJECT= wxLauncher
-USES= cmake:outsource openal python:2,build
-USE_SDL= sdl
-WX_UNICODE= yes
+USES= cmake:outsource openal pkgconfig python:2,build
+USE_SDL= sdl2
CMAKE_ARGS+= -DRESOURCES_PATH:STRING="${DATADIR}"
PORTDATA= *
@@ -45,20 +44,13 @@ WX3_CXXFLAGS= -std=c++11
WX3_USES= compiler:c++11-lib
WX3_USE= WX=3.0+
WX3_USE_OFF= WX=2.8
-
-.include <bsd.port.options.mk>
-
-# Allow to build with using concrete wxWidgets version
-.if ${PORT_OPTIONS:MWX3}
-SED_RE_WX3= wxWidgets 2\./,+1d
-.else
-SED_RE_WX3= NOT wxWidgets_FOUND/,+3d
-.endif
+WX3_CMAKE_ON= -DWXVER:STRING="3.0"
+WX3_CMAKE_OFF= -DWXVER:STRING="2.8"
post-patch: .SILENT
# Change version_strings.cpp.in file, based on GH_TAGNAME, without using git
${REINPLACE_CMD} -e '/find_program(GIT_EXECUTABLE/d ; \
- /version_strings.cpp will be generated/d ; /${SED_RE_WX3}' \
+ /version_strings.cpp will be generated/d' \
${WRKSRC}/CMakeLists.txt
${REINPLACE_CMD} -e 's|123456789abc+ unknown custom tip|${GH_TAGNAME}|' \
${WRKSRC}/code/global/version_strings.cpp.in
diff --git a/games/wxlauncher/distinfo b/games/wxlauncher/distinfo
index 3df3810def0b..ab2503147781 100644
--- a/games/wxlauncher/distinfo
+++ b/games/wxlauncher/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wxLauncher-wxlauncher-release-0.9.6_GH0.tar.gz) = 24a90722a63ee8a711e268bd78535bbb1ec99a2b27fd7c3750517d07424b6979
-SIZE (wxLauncher-wxlauncher-release-0.9.6_GH0.tar.gz) = 893799
+SHA256 (scp-fs2open-wxLauncher-release-0.10.0_GH0.tar.gz) = b47c88be4d7cc6582a7b7816cf8dc9fe1502947f3bdd509bc0b4b6fcf06a8bc0
+SIZE (scp-fs2open-wxLauncher-release-0.10.0_GH0.tar.gz) = 2434207
diff --git a/games/wxlauncher/files/patch-code_apis_JoystickManager.cpp b/games/wxlauncher/files/patch-code_apis_JoystickManager.cpp
index c10088726827..e00354e4d7a4 100644
--- a/games/wxlauncher/files/patch-code_apis_JoystickManager.cpp
+++ b/games/wxlauncher/files/patch-code_apis_JoystickManager.cpp
@@ -1,13 +1,13 @@
---- code/apis/JoystickManager.cpp.orig 2015-04-11 22:15:55 UTC
+--- code/apis/JoystickManager.cpp.orig 2015-08-26 04:54:06 UTC
+++ code/apis/JoystickManager.cpp
-@@ -65,8 +65,10 @@ bool JoyMan::IsInitialized() {
+@@ -84,9 +84,9 @@ bool JoyMan::IsInitialized() {
+ \sa JoyMan::WasCompiledIn()
*/
- bool JoyMan::Initialize() {
- if ( JoyMan::IsInitialized() ) {
+ bool JoyMan::Initialize(ApiType apiType) {
+#if USE_JOYSTICK
- wxLogDebug(_T("JoyMan already initialized with %d joysticks"),
- joysticks.Count());
-+#endif
- return true;
- }
+ currentApi = apiType;
+-#if USE_JOYSTICK
+ if ( JoyMan::IsInitialized() ) {
+ wxLogDebug(_T("JoyMan already initialized"));
+ return true;
diff --git a/games/wxlauncher/pkg-descr b/games/wxlauncher/pkg-descr
index d7ff9aaef98e..7268d02194ba 100644
--- a/games/wxlauncher/pkg-descr
+++ b/games/wxlauncher/pkg-descr
@@ -5,4 +5,4 @@ community looking for an easy way to control fs2_open on various platforms and
to those looking for an easy way to find and get updates to their Freespace 2
MODs and TCs.
-WWW: http://github.com/wxLauncher/wxlauncher
+WWW: http://github.com/scp-fs2open/wxLauncher